aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-01-22 08:57:32 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-01-22 08:57:32 +0800
commitdf71cd6edd1e2fe53af3af2cdbb5678374c16d6f (patch)
treeb5d2b7ce971377b9c0e2d8160a0a79f3aeab8453 /www
parentb1fa783260401e31d9a0bf24603512a30a54b5d6 (diff)
downloadfreebsd-ports-gnome-df71cd6edd1e2fe53af3af2cdbb5678374c16d6f.tar.gz
freebsd-ports-gnome-df71cd6edd1e2fe53af3af2cdbb5678374c16d6f.tar.zst
freebsd-ports-gnome-df71cd6edd1e2fe53af3af2cdbb5678374c16d6f.zip
Add p5-HTTP-Router 0.01, perl extension of Yet Another Path Router for
HTTP.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Router/Makefile37
-rw-r--r--www/p5-HTTP-Router/distinfo3
-rw-r--r--www/p5-HTTP-Router/pkg-descr3
-rw-r--r--www/p5-HTTP-Router/pkg-plist12
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b12c3412fb0e..d2fa43711d0f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -922,6 +922,7 @@
SUBDIR += p5-HTTP-Request-AsCGI
SUBDIR += p5-HTTP-Request-Params
SUBDIR += p5-HTTP-Response-Encoding
+ SUBDIR += p5-HTTP-Router
SUBDIR += p5-HTTP-Server-Simple
SUBDIR += p5-HTTP-Server-Simple-Mason
SUBDIR += p5-HTTP-Server-Simple-Recorder
diff --git a/www/p5-HTTP-Router/Makefile b/www/p5-HTTP-Router/Makefile
new file mode 100644
index 000000000000..b0cd06888cdc
--- /dev/null
+++ b/www/p5-HTTP-Router/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: HTTP::Router
+# Date created: 22 Jan 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Router
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of Yet Another Path Router for HTTP
+
+RUN_DEPENDS= \
+ p5-Mouse>=0.14:${PORTSDIR}/devel/p5-Mouse \
+ p5-namespace-clean>0:${PORTSDIR}/devel/p5-namespace-clean \
+ p5-URI-Template-Restrict>0:${PORTSDIR}/net/p5-URI-Template-Restrict \
+ p5-Hash-Merge>0:${PORTSDIR}/textproc/p5-Hash-Merge \
+ p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Lingua-EN-Inflect-Number>0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect-Number \
+ p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-Text-SimpleTemplate>0:${PORTSDIR}/textproc/p5-Text-SimpleTemplate
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Router.3 \
+ HTTP::Router::Debug.3 \
+ HTTP::Router::Mapper.3 \
+ HTTP::Router::Match.3 \
+ HTTP::Router::Resources.3 \
+ HTTP::Router::Route.3 \
+ HTTP::Router::RouteSet.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Router/distinfo b/www/p5-HTTP-Router/distinfo
new file mode 100644
index 000000000000..9b323ea900a6
--- /dev/null
+++ b/www/p5-HTTP-Router/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Router-0.01.tar.gz) = 8fd73fe7153b1a92fcd91c860ca12f1e
+SHA256 (HTTP-Router-0.01.tar.gz) = 5c0464ea5a3a9462e367d7635e6f6b499f6d995b2c49622a1149893f535900e9
+SIZE (HTTP-Router-0.01.tar.gz) = 57085
diff --git a/www/p5-HTTP-Router/pkg-descr b/www/p5-HTTP-Router/pkg-descr
new file mode 100644
index 000000000000..24eb81c55fe0
--- /dev/null
+++ b/www/p5-HTTP-Router/pkg-descr
@@ -0,0 +1,3 @@
+HTTP::Router provides a Merb-like way of constructing routing tables.
+
+WWW: http://search.cpan.org/dist/HTTP-Router/
diff --git a/www/p5-HTTP-Router/pkg-plist b/www/p5-HTTP-Router/pkg-plist
new file mode 100644
index 000000000000..34705c16a846
--- /dev/null
+++ b/www/p5-HTTP-Router/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/HTTP/Router/Route.pm
+%%SITE_PERL%%/HTTP/Router/Debug.pm
+%%SITE_PERL%%/HTTP/Router/Mapper.pm
+%%SITE_PERL%%/HTTP/Router/Match.pm
+%%SITE_PERL%%/HTTP/Router/RouteSet.pm
+%%SITE_PERL%%/HTTP/Router/Resources.pm
+%%SITE_PERL%%/HTTP/Router.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Router/.packlist
+@dirrm %%SITE_PERL%%/HTTP/Router
+@dirrmtry %%SITE_PERL%%/HTTP
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Router
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP