aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2008-06-23 10:06:09 +0800
committeraraujo <araujo@FreeBSD.org>2008-06-23 10:06:09 +0800
commite023959bde9bce5304b3fea69ee4b7aabf50b0e7 (patch)
tree0b80df26764a5eb9eebc8d049502b8b06d6b41e9 /www
parent1eccd8680df7bf9f847b346159df916ade886113 (diff)
downloadfreebsd-ports-gnome-e023959bde9bce5304b3fea69ee4b7aabf50b0e7.tar.gz
freebsd-ports-gnome-e023959bde9bce5304b3fea69ee4b7aabf50b0e7.tar.zst
freebsd-ports-gnome-e023959bde9bce5304b3fea69ee4b7aabf50b0e7.zip
- www/mod_security2 has been renamed to www/mod_security21 because I prepare the ports structure to receive a new series of mod_security.
PR: ports/124827 Repocopy by: marcus
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/mod_security2/Makefile89
-rw-r--r--www/mod_security2/distinfo3
-rw-r--r--www/mod_security2/files/mod_security2.conf.in3
-rw-r--r--www/mod_security2/files/pkg-message.rules.in10
-rw-r--r--www/mod_security2/pkg-descr9
-rw-r--r--www/mod_security21/Makefile5
7 files changed, 3 insertions, 118 deletions
diff --git a/www/Makefile b/www/Makefile
index c067b81cd355..9d64044a0c84 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -457,7 +457,7 @@
SUBDIR += mod_ruby
SUBDIR += mod_scgi
SUBDIR += mod_security
- SUBDIR += mod_security2
+ SUBDIR += mod_security21
SUBDIR += mod_sed
SUBDIR += mod_sequester
SUBDIR += mod_shapvh
diff --git a/www/mod_security2/Makefile b/www/mod_security2/Makefile
deleted file mode 100644
index 5c6ca710f4d8..000000000000
--- a/www/mod_security2/Makefile
+++ /dev/null
@@ -1,89 +0,0 @@
-# New ports collection makefile for: mod_security2
-# Date created: 9 November 2006
-# Whom: Dominic Mitchell <dom@happygiraffe.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mod_security2
-PORTVERSION= 2.1.7
-PORTREVISION= 1
-CATEGORIES= www security
-MASTER_SITES= http://www.modsecurity.org/download/
-DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
-
-MAINTAINER= araujo@FreeBSD.org
-COMMENT= An intrusion detection and prevention engine
-
-USE_APACHE= 2.0+
-AP_FAST_BUILD= yes
-AP_GENPLIST= yes
-AP_EXTRAS+= -DWITH_LIBXML2
-AP_INC= ${LOCALBASE}/include/libxml2
-AP_LIB= ${LOCALBASE}/lib
-USE_GNOME= libxml2
-MODULENAME= mod_security2
-WRKSRCTOP= ${WRKDIR}/${DISTNAME}
-WRKSRC= ${WRKSRCTOP}/apache2
-SRC_FILE= *.c
-PORTDOCS= *
-DOCS= CHANGES LICENSE README.TXT modsecurity.conf-minimal
-DOCSDIR= ${PREFIX}/share/doc/${MODULENAME}
-SUB_FILES+= mod_security2.conf
-SUB_LIST+= APACHEETCDIR="${APACHEETCDIR}"
-
-.if !defined(SKIP_RULES)
-SUB_FILES+= pkg-message.rules
-
-PLIST_DIRS+= ${APACHEETCDIR}/Includes/mod_security2/optional_rules
-PLIST_DIRS+= ${APACHEETCDIR}/Includes/mod_security2
-
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/CHANGELOG
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/LICENSE
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/README
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_23_request_limits.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_10_config.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_20_protocol_violations.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_21_protocol_anomalies.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_30_http_policy.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_35_bad_robots.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_40_generic_attacks.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_45_trojans.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/modsecurity_crs_50_outbound.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/optional_rules/modsecurity_crs_20_protocol_violations.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/optional_rules/modsecurity_crs_21_protocol_anomalies.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/optional_rules/modsecurity_crs_40_generic_attacks.conf
-PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_security2/optional_rules/modsecurity_crs_55_marketing.conf
-
-.endif
-
-REINPLACE_ARGS= -i ""
-
-.include <bsd.port.pre.mk>
-
-.if ${APACHE_VERSION} == 22
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e '\
- s|SecRuleEngine On|SecRuleEngine DetectionOnly|; \
- s|SecAuditLog.*logs/modsec_audit.log|SecAuditLog /var/log/httpd-modsec2_audit.log|; \
- s|SecDebugLog.*logs/modsec_debug.log|SecDebugLog /var/log/httpd-modsec2_debug.log|; \
- s|SecServerSignature "Apache/2.2.0 (Fedora)"|SecServerSignature "Apache/${APACHE_VERSION:C/[0-9]/\0./g}x (${OPSYS})"|; \
- ' ${WRKSRCTOP}/rules/modsecurity_crs_10_config.conf
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DOCS:S,^,${WRKSRCTOP}/,} ${DOCSDIR}/
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "doc rules" ${DOCSDIR}/)
-.endif
-.if !defined(SKIP_RULES)
- @${INSTALL_DATA} ${WRKDIR}/mod_security2.conf ${PREFIX}/${APACHEETCDIR}/Includes/
- @cd ${WRKSRCTOP} && ${PAX} -rw -pe -s +rules+mod_security2+ rules ${PREFIX}/${APACHEETCDIR}/Includes
- @${CAT} ${PKGMESSAGE}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/www/mod_security2/distinfo b/www/mod_security2/distinfo
deleted file mode 100644
index a083cd29803d..000000000000
--- a/www/mod_security2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (modsecurity-apache_2.1.7.tar.gz) = 19c34dd5611e0c516c0717de793f4640
-SHA256 (modsecurity-apache_2.1.7.tar.gz) = 3960aaa4a4f6087f990b0d25c3756c3a505f3b19a909e4724980dc5bbc583513
-SIZE (modsecurity-apache_2.1.7.tar.gz) = 679496
diff --git a/www/mod_security2/files/mod_security2.conf.in b/www/mod_security2/files/mod_security2.conf.in
deleted file mode 100644
index 9553e12a1cc2..000000000000
--- a/www/mod_security2/files/mod_security2.conf.in
+++ /dev/null
@@ -1,3 +0,0 @@
-<IfModule security2_module>
- Include %%APACHEETCDIR%%/Includes/mod_security2/*.conf
-</IfModule>
diff --git a/www/mod_security2/files/pkg-message.rules.in b/www/mod_security2/files/pkg-message.rules.in
deleted file mode 100644
index 206d2f1aae54..000000000000
--- a/www/mod_security2/files/pkg-message.rules.in
+++ /dev/null
@@ -1,10 +0,0 @@
-
-The modsecurity 2 Core Rules have been installed in
-
- %%PREFIX%%/%%APACHEETCDIR%%/Includes/mod_security2/
-
-and run in "DetectionOnly" mode as not to disturb operatings.
-
-Please read http://www.modsecurity.org/projects/rules/index.html
-
-Logging is done to /var/log/httpd-modsec-*.log
diff --git a/www/mod_security2/pkg-descr b/www/mod_security2/pkg-descr
deleted file mode 100644
index 91757c63af8d..000000000000
--- a/www/mod_security2/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-ModSecurity is an embeddable web application firewall. It provides
-protection from a range of attacks against web applications and allows
-for HTTP traffic monitoring and real-time analysis with no changes to
-existing infrastructure.
-
-It is also an open source project that aims to make the web application
-firewall technology available to everyone.
-
-WWW: http://www.modsecurity.org/
diff --git a/www/mod_security21/Makefile b/www/mod_security21/Makefile
index 5c6ca710f4d8..b11669edba69 100644
--- a/www/mod_security21/Makefile
+++ b/www/mod_security21/Makefile
@@ -5,12 +5,11 @@
# $FreeBSD$
#
-PORTNAME= mod_security2
+PORTNAME= mod_security21
PORTVERSION= 2.1.7
-PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= http://www.modsecurity.org/download/
-DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
+DISTNAME= ${PORTNAME:S/_//:S/21//}-apache_${PORTVERSION}
MAINTAINER= araujo@FreeBSD.org
COMMENT= An intrusion detection and prevention engine