aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-23 14:38:13 +0800
committerclsung <clsung@FreeBSD.org>2006-07-23 14:38:13 +0800
commite705910814fc5c5796f3cdf59f3bed95ab0262f9 (patch)
tree6e60a8aff74d0d2e263aad98e9dfb12663345048 /www
parentca6ee42eaee0253d3e7a0f05cd9f559aa08b1cb6 (diff)
downloadfreebsd-ports-gnome-e705910814fc5c5796f3cdf59f3bed95ab0262f9.tar.gz
freebsd-ports-gnome-e705910814fc5c5796f3cdf59f3bed95ab0262f9.tar.zst
freebsd-ports-gnome-e705910814fc5c5796f3cdf59f3bed95ab0262f9.zip
Add p5-HTTP-Cookies-iCab 1.07, cookie storage and management for iCab.
PR: ports/100658 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Cookies-iCab/Makefile35
-rw-r--r--www/p5-HTTP-Cookies-iCab/distinfo3
-rw-r--r--www/p5-HTTP-Cookies-iCab/pkg-descr4
-rw-r--r--www/p5-HTTP-Cookies-iCab/pkg-plist6
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a84dccd6dad5..588b9fd5cb7e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -653,6 +653,7 @@
SUBDIR += p5-HTTP-BrowserDetect
SUBDIR += p5-HTTP-Cache-Transparent
SUBDIR += p5-HTTP-Cookies-Mozilla
+ SUBDIR += p5-HTTP-Cookies-iCab
SUBDIR += p5-HTTP-DAV
SUBDIR += p5-HTTP-GHTTP
SUBDIR += p5-HTTP-Lite
diff --git a/www/p5-HTTP-Cookies-iCab/Makefile b/www/p5-HTTP-Cookies-iCab/Makefile
new file mode 100644
index 000000000000..c208cd555117
--- /dev/null
+++ b/www/p5-HTTP-Cookies-iCab/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-HTTP-Cookies-iCab
+# Date created: 2006-07-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Cookies-iCab
+PORTVERSION= 1.07
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Cookie storage and management for iCab
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Cookies::iCab.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or later. Please install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500602 || ${PERL_LEVEL} == 500700 || ${PERL_LEVEL} == 500701
+RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Cookies-iCab/distinfo b/www/p5-HTTP-Cookies-iCab/distinfo
new file mode 100644
index 000000000000..46774f36c8d4
--- /dev/null
+++ b/www/p5-HTTP-Cookies-iCab/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Cookies-iCab-1.07.tar.gz) = 4587a0467736152b27501eb9086672f5
+SHA256 (HTTP-Cookies-iCab-1.07.tar.gz) = 67238a1711fbaa49c22638138d127cd63d186ed0632360b541d46e86ed8383d8
+SIZE (HTTP-Cookies-iCab-1.07.tar.gz) = 4793
diff --git a/www/p5-HTTP-Cookies-iCab/pkg-descr b/www/p5-HTTP-Cookies-iCab/pkg-descr
new file mode 100644
index 000000000000..a9e53082288f
--- /dev/null
+++ b/www/p5-HTTP-Cookies-iCab/pkg-descr
@@ -0,0 +1,4 @@
+This package overrides the load() and save() methods of HTTP::Cookies
+so it can work with iCab cookie files.
+
+WWW: http://search.cpan.org/dist/HTTP-Cookies-iCab/
diff --git a/www/p5-HTTP-Cookies-iCab/pkg-plist b/www/p5-HTTP-Cookies-iCab/pkg-plist
new file mode 100644
index 000000000000..74aeaad6a31f
--- /dev/null
+++ b/www/p5-HTTP-Cookies-iCab/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cookies/iCab/.packlist
+%%SITE_PERL%%/HTTP/Cookies/iCab.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cookies/iCab
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cookies
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP