aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-12 03:18:11 +0800
committerswills <swills@FreeBSD.org>2014-03-12 03:18:11 +0800
commite855e4c1126ed59b05c4892589543679fb165db9 (patch)
treea9801c71aee0429666ec206ec0631fb67d4381a7 /www
parent73d85573218894922a87d21cc1c1a8841c814a4e (diff)
downloadfreebsd-ports-gnome-e855e4c1126ed59b05c4892589543679fb165db9.tar.gz
freebsd-ports-gnome-e855e4c1126ed59b05c4892589543679fb165db9.tar.zst
freebsd-ports-gnome-e855e4c1126ed59b05c4892589543679fb165db9.zip
Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for
Ruby/Rack applications. Puma is intended for use in both development and production environments. In order to get the best throughput, it is highly recommended that you use a Ruby implementation with real threads like Rubinius or JRuby. WWW: http://puma.io/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-puma/Makefile21
-rw-r--r--www/rubygem-puma/distinfo2
-rw-r--r--www/rubygem-puma/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d0c5e15eb230..1938ae3a62f0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1821,6 +1821,7 @@
SUBDIR += rubygem-nicovideo
SUBDIR += rubygem-ntlm-http
SUBDIR += rubygem-passenger
+ SUBDIR += rubygem-puma
SUBDIR += rubygem-puma16
SUBDIR += rubygem-rabbirack
SUBDIR += rubygem-rack
diff --git a/www/rubygem-puma/Makefile b/www/rubygem-puma/Makefile
new file mode 100644
index 000000000000..168d7757243f
--- /dev/null
+++ b/www/rubygem-puma/Makefile
@@ -0,0 +1,21 @@
+# Created by: Steve Wills <swills@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= puma
+PORTVERSION= 2.8.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@freebsd.org
+COMMENT= Fast, multithreaded and highly concurrent ruby web server
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= rubygem-rack>=1.1.0:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/puma bin/pumactl
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-puma/distinfo b/www/rubygem-puma/distinfo
new file mode 100644
index 000000000000..88a4ad846196
--- /dev/null
+++ b/www/rubygem-puma/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/puma-2.8.1.gem) = 19bebe90d87badea30070d254fa0195d01b1036da647b6249b57d02dd96fd06a
+SIZE (rubygem/puma-2.8.1.gem) = 87040
diff --git a/www/rubygem-puma/pkg-descr b/www/rubygem-puma/pkg-descr
new file mode 100644
index 000000000000..4e3518985cb1
--- /dev/null
+++ b/www/rubygem-puma/pkg-descr
@@ -0,0 +1,7 @@
+Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for
+Ruby/Rack applications. Puma is intended for use in both development and
+production environments. In order to get the best throughput, it is highly
+recommended that you use a Ruby implementation with real threads like Rubinius
+or JRuby.
+
+WWW: http://puma.io/