aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-12-03 02:14:19 +0800
committermat <mat@FreeBSD.org>2013-12-03 02:14:19 +0800
commite9c4aa86e7175d0ccc84171f8dff5e67860b7bac (patch)
tree0fa2f5f20c3086f3203e2bafaba5deb11f297742 /www
parenta5e1b2b556d2c71246bcc112f5af87f1ddc4daad (diff)
downloadfreebsd-ports-gnome-e9c4aa86e7175d0ccc84171f8dff5e67860b7bac.tar.gz
freebsd-ports-gnome-e9c4aa86e7175d0ccc84171f8dff5e67860b7bac.tar.zst
freebsd-ports-gnome-e9c4aa86e7175d0ccc84171f8dff5e67860b7bac.zip
The patch for adding syslog support sets the wrong define variable causing syslog support to not be built.
maintainer timeout. PR: ports/180639 Submitted by: Dave Duchscher
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile1
-rw-r--r--www/nginx/files/extra-patch-syslog_support2
2 files changed, 2 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 11a27b98190d..e5fce7612332 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.4.4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
diff --git a/www/nginx/files/extra-patch-syslog_support b/www/nginx/files/extra-patch-syslog_support
index 019313f3214d..fc0bc6b662ff 100644
--- a/www/nginx/files/extra-patch-syslog_support
+++ b/www/nginx/files/extra-patch-syslog_support
@@ -721,7 +721,7 @@ index 54e1c26..2b05157 100644
+ SYSLOG_FACILITY="LOG_DAEMON"
+fi
+if test "${USE_SYSLOG}" = "YES"; then
-+ CFLAGS="$CFLAGS -DUSE_SYSLOG -DSYSLOG_FACILITY=${SYSLOG_FACILITY}"
++ CFLAGS="$CFLAGS -DNGX_ENABLE_SYSLOG -DSYSLOG_FACILITY=${SYSLOG_FACILITY}"
+fi
cat << END > $NGX_MAKEFILE