aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-07-02 17:00:16 +0800
committerosa <osa@FreeBSD.org>2009-07-02 17:00:16 +0800
commited5fedabf50cb21e07cd942237bdc2287aa20b50 (patch)
treef6b7fa248e92c7508ae72329eb3c091be2ed8b4e /www
parentc04e9a184b0fe6e9e25e27fdd5eaa64a5f387581 (diff)
downloadfreebsd-ports-gnome-ed5fedabf50cb21e07cd942237bdc2287aa20b50.tar.gz
freebsd-ports-gnome-ed5fedabf50cb21e07cd942237bdc2287aa20b50.tar.zst
freebsd-ports-gnome-ed5fedabf50cb21e07cd942237bdc2287aa20b50.zip
Fix X-Progress-ID argument parsing in third-party uploadprogress module.
Do not bump PORTREVISIONs. PR: ports/136064
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile4
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c14
-rw-r--r--www/nginx/Makefile4
-rw-r--r--www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c14
4 files changed, 36 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 3242fcb4ced5..c2d93b21dc7c 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -313,6 +313,10 @@ post-patch:
's!$$HTTP_ACCESSKEY_MODULE!ngx_http_accesskey_module!' \
${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}/config
.endif
+.if defiend(WITH_HTTP_UPLOAD_PROGRESS)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_uploadprogress_module.c
+.endif
.if defined(WITH_HTTP_FANCYINDEX_MODULE)
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c b/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c
new file mode 100644
index 000000000000..abaffde0d94c
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c
@@ -0,0 +1,14 @@
+--- ../nginx_uploadprogress_module/ngx_http_uploadprogress_module.c.orig 2009-06-26 15:32:01.000000000 +0400
++++ ../nginx_uploadprogress_module/ngx_http_uploadprogress_module.c 2009-06-26 15:38:30.000000000 +0400
+@@ -187,8 +187,9 @@
+ if (i) {
+ start_p = p += 14;
+ while (p < r->args.data + r->args.len) {
+- if (*p++ != '&') {
+- continue;
++ if (*p++ == '&') {
++ p--;
++ break;
+ }
+ }
+
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 842c71225d28..840038738294 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -311,6 +311,10 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
.endif
+.if defined(WITH_HTTP_UPLOAD_PROGRESS)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_uploadprogress_module.c
+.endif
.if defined(WITH_PASSENGER_MODULE)
@${REINPLACE_CMD} 's!g++!${CXX}!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
diff --git a/www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c b/www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c
new file mode 100644
index 000000000000..abaffde0d94c
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_uploadprogress_module.c
@@ -0,0 +1,14 @@
+--- ../nginx_uploadprogress_module/ngx_http_uploadprogress_module.c.orig 2009-06-26 15:32:01.000000000 +0400
++++ ../nginx_uploadprogress_module/ngx_http_uploadprogress_module.c 2009-06-26 15:38:30.000000000 +0400
+@@ -187,8 +187,9 @@
+ if (i) {
+ start_p = p += 14;
+ while (p < r->args.data + r->args.len) {
+- if (*p++ != '&') {
+- continue;
++ if (*p++ == '&') {
++ p--;
++ break;
+ }
+ }
+