aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-11 14:03:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-11 14:03:31 +0800
commitf002b3aac2027dd74d21548ce99250106fc199a5 (patch)
treea436ab00f90e99823d492e8e6cfb9bf2ea817a74 /www
parent6dfd4248be1b26f4a1c180db12919ba805aa841d (diff)
downloadfreebsd-ports-gnome-f002b3aac2027dd74d21548ce99250106fc199a5.tar.gz
freebsd-ports-gnome-f002b3aac2027dd74d21548ce99250106fc199a5.tar.zst
freebsd-ports-gnome-f002b3aac2027dd74d21548ce99250106fc199a5.zip
- Add p5-LWP-Protocol-https 6.02
The LWP::Protocol::https module provide support for using https schemed URLs with LWP. This module is a plug-in to the LWP protocol handling, so you don't use it directly. Once the module is installed LWP is able to access sites using HTTP over SSL/TLS. If hostname verification is requested by LWP::UserAgent's ssl_opts, and neither SSL_ca_file nor SSL_ca_path is set, then SSL_ca_file is implied to be the one provided by Mozilla::CA. If the Mozilla::CA module isn't available SSL requests will fail. Either install this module, set up an alternative SSL_ca_file or disable hostname verification. This module used to be bundled with the libwww-perl, but it was unbundled in v6.02 in order to be able to declare its dependencies properly for the CPAN tool-chain. Applications that need https support can just declare their dependency on LWP::Protocol::https and will no longer need to know what underlying modules to install. WWW: http://search.cpan.org/dist/LWP-Protocol-https/
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-LWP-Protocol-https/Makefile26
-rw-r--r--www/p5-LWP-Protocol-https/distinfo2
-rw-r--r--www/p5-LWP-Protocol-https/pkg-descr18
-rw-r--r--www/p5-LWP-Protocol-https/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3edda6c64ec4..e6c8c21d4da8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1104,6 +1104,7 @@
SUBDIR += p5-LWP-ConnCache-MaxKeepAliveRequests
SUBDIR += p5-LWP-MediaTypes
SUBDIR += p5-LWP-Online
+ SUBDIR += p5-LWP-Protocol-https
SUBDIR += p5-LWP-UserAgent-Determined
SUBDIR += p5-LWP-UserAgent-POE
SUBDIR += p5-LWP-UserAgent-WithCache
diff --git a/www/p5-LWP-Protocol-https/Makefile b/www/p5-LWP-Protocol-https/Makefile
new file mode 100644
index 000000000000..39d951eed7ad
--- /dev/null
+++ b/www/p5-LWP-Protocol-https/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-LWP-Protocol-https
+# Date created: 2011-06-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Protocol-https
+PORTVERSION= 6.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Provide https support for LWP::UserAgent
+
+# We remove p5-libwww here to avoid cyclic dependency
+RUN_DEPENDS= p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Mozilla-CA>=20110101:${PORTSDIR}/www/p5-Mozilla-CA \
+ p5-Net-HTTP>=6:${PORTSDIR}/net/p5-Net-HTTP
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Protocol::https.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-Protocol-https/distinfo b/www/p5-LWP-Protocol-https/distinfo
new file mode 100644
index 000000000000..247d1530b2fd
--- /dev/null
+++ b/www/p5-LWP-Protocol-https/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LWP-Protocol-https-6.02.tar.gz) = c50388fde02a4c3eb98f9cfb74fa4422a6136a4244ccafb54355927736b14a78
+SIZE (LWP-Protocol-https-6.02.tar.gz) = 3443
diff --git a/www/p5-LWP-Protocol-https/pkg-descr b/www/p5-LWP-Protocol-https/pkg-descr
new file mode 100644
index 000000000000..76afd158f49e
--- /dev/null
+++ b/www/p5-LWP-Protocol-https/pkg-descr
@@ -0,0 +1,18 @@
+The LWP::Protocol::https module provide support for using https schemed URLs
+with LWP. This module is a plug-in to the LWP protocol handling, so you don't
+use it directly. Once the module is installed LWP is able to access sites using
+HTTP over SSL/TLS.
+
+If hostname verification is requested by LWP::UserAgent's ssl_opts, and neither
+SSL_ca_file nor SSL_ca_path is set, then SSL_ca_file is implied to be the one
+provided by Mozilla::CA. If the Mozilla::CA module isn't available SSL requests
+will fail. Either install this module, set up an alternative SSL_ca_file or
+disable hostname verification.
+
+This module used to be bundled with the libwww-perl, but it was unbundled in
+v6.02 in order to be able to declare its dependencies properly for the CPAN
+tool-chain. Applications that need https support can just declare their
+dependency on LWP::Protocol::https and will no longer need to know what
+underlying modules to install.
+
+WWW: http://search.cpan.org/dist/LWP-Protocol-https/
diff --git a/www/p5-LWP-Protocol-https/pkg-plist b/www/p5-LWP-Protocol-https/pkg-plist
new file mode 100644
index 000000000000..59d8450a5ca8
--- /dev/null
+++ b/www/p5-LWP-Protocol-https/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/LWP/Protocol/https.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Protocol/https/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Protocol/https
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Protocol
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP
+@dirrmtry %%SITE_PERL%%/LWP/Protocol
+@dirrmtry %%SITE_PERL%%/LWP