aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-19 00:12:07 +0800
committererwin <erwin@FreeBSD.org>2006-07-19 00:12:07 +0800
commitf3a87a27d583f9341a99f81bac89c71e5ae48b0b (patch)
treef7bfb16d0370e44e82062177f13b06dcbf7949c7 /www
parent17a586dacea4272ffab3fc995435dca6b97342fb (diff)
downloadfreebsd-ports-gnome-f3a87a27d583f9341a99f81bac89c71e5ae48b0b.tar.gz
freebsd-ports-gnome-f3a87a27d583f9341a99f81bac89c71e5ae48b0b.tar.zst
freebsd-ports-gnome-f3a87a27d583f9341a99f81bac89c71e5ae48b0b.zip
Add p5-WWW-Google-News 0.11, access to Google's News Service (Not
Usenet). PR: ports/100474 Submitted by: Tsung-Han Yeh <snowfly at yuntech.edu.tw>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Google-News/Makefile33
-rw-r--r--www/p5-WWW-Google-News/distinfo3
-rw-r--r--www/p5-WWW-Google-News/pkg-descr4
-rw-r--r--www/p5-WWW-Google-News/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 54ec99abfaf1..358e165b7279 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -758,6 +758,7 @@
SUBDIR += p5-WWW-Babelfish
SUBDIR += p5-WWW-Curl
SUBDIR += p5-WWW-Dilbert
+ SUBDIR += p5-WWW-Google-News
SUBDIR += p5-WWW-IMDb
SUBDIR += p5-WWW-Link
SUBDIR += p5-WWW-Mechanize
diff --git a/www/p5-WWW-Google-News/Makefile b/www/p5-WWW-Google-News/Makefile
new file mode 100644
index 000000000000..530705058ec1
--- /dev/null
+++ b/www/p5-WWW-Google-News/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-WWW-Google-News
+# Date created: 2006-07-17
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-News
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Access to Google's News Service (Not Usenet)
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::News.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+SASL
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Google-News/distinfo b/www/p5-WWW-Google-News/distinfo
new file mode 100644
index 000000000000..eff3657d9a44
--- /dev/null
+++ b/www/p5-WWW-Google-News/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Google-News-0.11.tar.gz) = 612241d97145176cc208608ce7b4703a
+SHA256 (WWW-Google-News-0.11.tar.gz) = 1e33b904dc94465d4672fd6ee25daf228c0bfb121c12f994e60548b7569eee28
+SIZE (WWW-Google-News-0.11.tar.gz) = 5992
diff --git a/www/p5-WWW-Google-News/pkg-descr b/www/p5-WWW-Google-News/pkg-descr
new file mode 100644
index 000000000000..bac1a39555e5
--- /dev/null
+++ b/www/p5-WWW-Google-News/pkg-descr
@@ -0,0 +1,4 @@
+This is a simple screen scraper for Google's News service.
+
+Author: Scott Holdren <scott@sitening.com>
+WWW: http://search.cpan.org/~splotchy/WWW-Google-News-0.11/
diff --git a/www/p5-WWW-Google-News/pkg-plist b/www/p5-WWW-Google-News/pkg-plist
new file mode 100644
index 000000000000..24338a314955
--- /dev/null
+++ b/www/p5-WWW-Google-News/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/WWW/Google/News.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/News/.packlist
+@dirrm share/nls/en_US.US-ASCII
+@dirrm share/nls/POSIX
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/News
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Google
+@dirrmtry %%SITE_PERL%%/WWW