aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-05 15:27:27 +0800
committeraz <az@FreeBSD.org>2012-06-05 15:27:27 +0800
commitf61b03b398ea21c2e2fcac46f485ea2b213efa84 (patch)
tree8c566502d6f3f58ac3696ab7552acb24f7204673 /www
parent8bc5b80bcec5dfbf97874152ef756c87561ba3d5 (diff)
downloadfreebsd-ports-gnome-f61b03b398ea21c2e2fcac46f485ea2b213efa84.tar.gz
freebsd-ports-gnome-f61b03b398ea21c2e2fcac46f485ea2b213efa84.tar.zst
freebsd-ports-gnome-f61b03b398ea21c2e2fcac46f485ea2b213efa84.zip
- Remove SITE_PERL from *_DEPENDS
Diffstat (limited to 'www')
-rw-r--r--www/p5-Bundle-Sledge/Makefile40
-rw-r--r--www/p5-CGI-ArgChecker/Makefile2
-rw-r--r--www/p5-CGI-Builder/Makefile4
-rw-r--r--www/p5-CGI-Upload/Makefile6
-rw-r--r--www/p5-HTML-Pager/Makefile2
-rw-r--r--www/p5-WWW-Link/Makefile12
6 files changed, 32 insertions, 34 deletions
diff --git a/www/p5-Bundle-Sledge/Makefile b/www/p5-Bundle-Sledge/Makefile
index 37cca340ebac..7fb622c8f58f 100644
--- a/www/p5-Bundle-Sledge/Makefile
+++ b/www/p5-Bundle-Sledge/Makefile
@@ -15,25 +15,25 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A bundle to install all modules used for Sledge
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2 \
- ${SITE_PERL}/Test/Inline.pm:${PORTSDIR}/devel/p5-Test-Inline \
- ${SITE_PERL}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert \
- ${SITE_PERL}/Class/Fields.pm:${PORTSDIR}/devel/p5-Class-Fields \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- ${SITE_PERL}/Class/Singleton.pm:${PORTSDIR}/devel/p5-Class-Singleton \
- ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm \
- ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/HTML/StickyQuery.pm:${PORTSDIR}/www/p5-HTML-StickyQuery \
- ${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/Data/Properties.pm:${PORTSDIR}/devel/p5-Data-Properties \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2 \
+ p5-Test-Inline>=0:${PORTSDIR}/devel/p5-Test-Inline \
+ p5-Carp-Assert>=0:${PORTSDIR}/devel/p5-Carp-Assert \
+ p5-Class-Fields>=0:${PORTSDIR}/devel/p5-Class-Fields \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton \
+ p5-Class-Trigger>=0:${PORTSDIR}/devel/p5-Class-Trigger \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-HTML-FillInForm>=0:${PORTSDIR}/www/p5-HTML-FillInForm \
+ p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
+ p5-HTML-StickyQuery>=0:${PORTSDIR}/www/p5-HTML-StickyQuery \
+ p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Jcode>=0:${PORTSDIR}/japanese/p5-Jcode \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-Data-Properties>=0:${PORTSDIR}/devel/p5-Data-Properties \
+ p5-Error>=0:${PORTSDIR}/lang/p5-Error \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_APACHE= 20+
@@ -41,6 +41,4 @@ PERL_CONFIGURE= yes
MAN3= Bundle::Sledge.3
-JCODE= ${SITE_PERL}/Jcode.pm
-
.include <bsd.port.mk>
diff --git a/www/p5-CGI-ArgChecker/Makefile b/www/p5-CGI-ArgChecker/Makefile
index 8fdc70d72190..9a9b9efdddf0 100644
--- a/www/p5-CGI-ArgChecker/Makefile
+++ b/www/p5-CGI-ArgChecker/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module implementing a cgi interface to String::Checker
-BUILD_DEPENDS= ${SITE_PERL}/String/Checker.pm:${PORTSDIR}/devel/p5-String-Checker
+BUILD_DEPENDS= p5-String-Checker>=0:${PORTSDIR}/devel/p5-String-Checker
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-CGI-Builder/Makefile b/www/p5-CGI-Builder/Makefile
index f2234f71b2e9..455c69fa0f61 100644
--- a/www/p5-CGI-Builder/Makefile
+++ b/www/p5-CGI-Builder/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module intended to make it easier to create reusable web apps
-BUILD_DEPENDS= ${SITE_PERL}/IO/Util.pm:${PORTSDIR}/devel/p5-IO-Util \
- ${SITE_PERL}/Class/constr.pm:${PORTSDIR}/devel/p5-OOTools
+BUILD_DEPENDS= p5-IO-Util>=0:${PORTSDIR}/devel/p5-IO-Util \
+ p5-OOTools>=0:${PORTSDIR}/devel/p5-OOTools
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-CGI-Upload/Makefile b/www/p5-CGI-Upload/Makefile
index 2b2ef95e0711..e80b8cf67b77 100644
--- a/www/p5-CGI-Upload/Makefile
+++ b/www/p5-CGI-Upload/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= CGI class for handling browser file uploads
-BUILD_DEPENDS= ${SITE_PERL}/HTTP/BrowserDetect.pm:${PORTSDIR}/www/p5-HTTP-BrowserDetect \
- ${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic \
- ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+BUILD_DEPENDS= p5-HTTP-BrowserDetect>=0:${PORTSDIR}/www/p5-HTTP-BrowserDetect \
+ p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
+ p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
PERL_CONFIGURE= yes
diff --git a/www/p5-HTML-Pager/Makefile b/www/p5-HTML-Pager/Makefile
index 9c9628ba5739..77219d1a81a1 100644
--- a/www/p5-HTML-Pager/Makefile
+++ b/www/p5-HTML-Pager/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module for handling CGI HTML paging of arbitrary data
-BUILD_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
+BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/www/p5-WWW-Link/Makefile b/www/p5-WWW-Link/Makefile
index edd7cc0fa161..0eb242dcecb8 100644
--- a/www/p5-WWW-Link/Makefile
+++ b/www/p5-WWW-Link/Makefile
@@ -14,12 +14,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Maintain information about the state of links
-BUILD_DEPENDS= ${SITE_PERL}/HTTP/Response.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/HTML/Stream.pm:${PORTSDIR}/www/p5-HTML-Stream \
- ${SITE_PERL}/CGI/Form.pm:${PORTSDIR}/www/p5-CGI-modules \
- ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet \
- ${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
- ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-HTML-Stream>=0:${PORTSDIR}/www/p5-HTML-Stream \
+ p5-CGI-modules>=0:${PORTSDIR}/www/p5-CGI-modules \
+ p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
+ p5-MLDBM>=0:${PORTSDIR}/databases/p5-MLDBM \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes