aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2016-02-10 08:03:49 +0800
committerosa <osa@FreeBSD.org>2016-02-10 08:03:49 +0800
commitf8c476ce66a71a1eb39bf5d0d205dc7105a56b27 (patch)
treec1b917fc0a1b1310cc4080c2948117b22994d635 /www
parentaa20f3ee47e931b01adb815b20cb8b4b730dfb14 (diff)
downloadfreebsd-ports-gnome-f8c476ce66a71a1eb39bf5d0d205dc7105a56b27.tar.gz
freebsd-ports-gnome-f8c476ce66a71a1eb39bf5d0d205dc7105a56b27.tar.zst
freebsd-ports-gnome-f8c476ce66a71a1eb39bf5d0d205dc7105a56b27.zip
Upgrade from 1.9.10 to 1.9.11.
Due to internal changes (TCP support in resolver) I've just added several hacks for some third-party module. These changes should be removed once modules will be updated. <ChangeLog> *) Feature: TCP support in resolver. *) Feature: dynamic modules. *) Bugfix: the $request_length variable did not include size of request headers when using HTTP/2. *) Bugfix: in the ngx_http_v2_module. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile24
-rw-r--r--www/nginx-devel/distinfo4
2 files changed, 25 insertions, 3 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index bd9464072c45..f8b8944d87ca 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nginx
-PORTVERSION= 1.9.10
+PORTVERSION= 1.9.11
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa
@@ -1008,6 +1008,14 @@ post-patch:
's!--std=c99!-DMONGO_HAVE_STDINT!' \
${WRKSRC_gridfs}/config
.endif
+.if ${PORT_OPTIONS:MLUA}
+ @${REINPLACE_CMD} \
+ 's!ngx_udp_connection_t!ngx_resolver_connection_t!g; \
+ s!udp_connections!connections!g; \
+ s!udp_connection.connection!udp_connection.udp!g; \
+ s!uc->connection!uc->udp!g' \
+ ${WRKSRC_lua}/src/ngx_http_lua_socket_udp.*
+.endif
.if ${PORT_OPTIONS:MPASSENGER}
@${REINPLACE_CMD} \
'177,179s!true!false!' \
@@ -1031,6 +1039,20 @@ post-patch:
's!%%PREFIX%%!${LOCALBASE}!g' \
${WRKDIR}/nginx-sflow-module-${NGINX_SFLOW_VERSION}/ngx_http_sflow_config.h
.endif
+.if ${PORT_OPTIONS:MSTATSD}
+ @${REINPLACE_CMD} \
+ 's!ngx_udp_connection_t!ngx_resolver_connection_t!g; \
+ s!uc->connection!uc->udp!g; \
+ s!e->udp_connection->connection!e->udp_connection->udp!g' \
+ ${WRKSRC_statsd}/ngx_http_statsd.c
+.endif
+.if ${PORT_OPTIONS:MUDPLOG}
+ @${REINPLACE_CMD} \
+ 's!ngx_udp_connection_t!ngx_resolver_connection_t!g; \
+ s!uc->connection!uc->udp!g; \
+ s!e->udp_connection->connection!e->udp_connection->udp!g' \
+ ${WRKDIR}/nginx_udplog_module-${NGINX_UDPLOG_VERSION}/ngx_http_udplog_module.c
+.endif
.if ${PORT_OPTIONS:MICONV}
@${REINPLACE_CMD} \
's!%%PREFIX%%!${LOCALBASE}!g' \
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index f4f88963ffdc..439f84a879af 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.9.10.tar.gz) = fb14d76844cab0a5a0880768be28965e74f9956790f618c454ef6098e26631d9
-SIZE (nginx-1.9.10.tar.gz) = 889267
+SHA256 (nginx-1.9.11.tar.gz) = 6a5c72f4afaf57a6db064bba0965d72335f127481c5d4e64ee8714e7b368a51f
+SIZE (nginx-1.9.11.tar.gz) = 895373
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
SHA256 (ngx_http_auth_pam_module-1.2.tar.gz) = 5a85970ba61a99f55a26d2536a11d512b39bbd622f5737d25a9a8c10db81efa9