aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-23 22:37:54 +0800
committerantoine <antoine@FreeBSD.org>2014-08-23 22:37:54 +0800
commitf935ae4bcbeba886dc6346e868bdc9e7365f5a18 (patch)
tree995a2a51ce6f6cc0a599d47c1b4448b98201071c /www
parentb53b73e9b5294bc18dea0c12b219be6fe3a1b193 (diff)
downloadfreebsd-ports-gnome-f935ae4bcbeba886dc6346e868bdc9e7365f5a18.tar.gz
freebsd-ports-gnome-f935ae4bcbeba886dc6346e868bdc9e7365f5a18.tar.zst
freebsd-ports-gnome-f935ae4bcbeba886dc6346e868bdc9e7365f5a18.zip
Fix some files unreadable by regular users, this causes errors like:
File "/usr/local/lib/python2.7/site-packages/pkg_resources.py", line 1514, in _get with open(path, 'rb') as stream: IOError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/site-packages/WebError-0.10.3-py2.7.egg-info/entry_points.txt' While here, modernize a bit
Diffstat (limited to 'www')
-rw-r--r--www/py-WebError/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/www/py-WebError/Makefile b/www/py-WebError/Makefile
index f0574f95dbca..a609325384d2 100644
--- a/www/py-WebError/Makefile
+++ b/www/py-WebError/Makefile
@@ -3,7 +3,7 @@
PORTNAME= WebError
PORTVERSION= 0.10.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,14 +18,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Paste>=1.7:${PORTSDIR}/www/py-paste \
${PYTHON_PKGNAMEPREFIX}Tempita>=0.3:${PORTSDIR}/textproc/py-Tempita \
${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
-.include <bsd.port.pre.mk>
+post-extract:
+ ${CHMOD} -R a+r ${WRKSRC}
-.if ${PYTHON_REL} < 260
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.8:${PORTSDIR}/devel/py-simplejson
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>