aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2011-11-29 01:20:52 +0800
committerosa <osa@FreeBSD.org>2011-11-29 01:20:52 +0800
commitfad28e55b9139f7cf54fcea9c366dd0bcfc4f382 (patch)
tree565b5e7e2f6e81ebba95816c81194e19a9bba5da /www
parent32e24e19aae9645e5843a881b3a79b4fc783f676 (diff)
downloadfreebsd-ports-gnome-fad28e55b9139f7cf54fcea9c366dd0bcfc4f382.tar.gz
freebsd-ports-gnome-fad28e55b9139f7cf54fcea9c366dd0bcfc4f382.tar.zst
freebsd-ports-gnome-fad28e55b9139f7cf54fcea9c366dd0bcfc4f382.zip
Update from 1.1.8 to 1.1.9.
Feature safe: yes. <ChangeLog> *) Change: now double quotes are encoded in an "echo" SSI-command output. Thanks to Zaur Abasmirzoev. *) Feature: the "valid" parameter of the "resolver" directive. By default TTL returned by a DNS server is used. Thanks to Kirill A. Korinskiy. *) Bugfix: nginx might hang after a worker process abnormal termination. *) Bugfix: a segmentation fault might occur in a worker process if SNI was used; the bug had appeared in 1.1.2. *) Bugfix: in the "keepalive_disable" directive; the bug had appeared in 1.1.8. Thanks to Alexander Usov. *) Bugfix: SIGWINCH signal did not work after first binary upgrade; the bug had appeared in 1.1.1. *) Bugfix: backend responses with length not matching "Content-Length" header line are no longer cached. *) Bugfix: in the "scgi_param" directive, if complex parameters were used. *) Bugfix: in the "epoll" event method. Thanks to Yichun Zhang. *) Bugfix: in the ngx_http_flv_module. Thanks to Piotr Sikora. *) Bugfix: in the ngx_http_mp4_module. *) Bugfix: IPv6 addresses are now handled properly in a request line and in a "Host" request header line. *) Bugfix: "add_header" and "expires" directives did not work if a request was proxied and response status code was 206. *) Bugfix: nginx could not be built on FreeBSD 10. *) Bugfix: nginx could not be built on AIX. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile3
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/patch-src::os::unix::ngx_files.c11
3 files changed, 3 insertions, 15 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 5ce068036e1f..d82bc93f0445 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 1.1.8
-PORTREVISION= 1
+PORTVERSION= 1.1.9
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index c5124dfb3ab1..ea95c6d99b17 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.1.8.tar.gz) = 2f5d2d08fa59043aaae45c72c16ff052fabe1f5ba95fe5475d4994a5a55c9945
-SIZE (nginx-1.1.8.tar.gz) = 695829
+SHA256 (nginx-1.1.9.tar.gz) = d3c87524563e1b85860888686a6cb6d3421861aac686d3d8daf1cfe48bee6d35
+SIZE (nginx-1.1.9.tar.gz) = 701459
SHA256 (giom-nginx_accept_language_module-02262ce.tar.gz) = 3191f4caa70d9a8942c4f10b6abaaa96af451991d4b5e1e3d7b991376b00bf0c
SIZE (giom-nginx_accept_language_module-02262ce.tar.gz) = 3398
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx-devel/files/patch-src::os::unix::ngx_files.c b/www/nginx-devel/files/patch-src::os::unix::ngx_files.c
deleted file mode 100644
index cd90393b5253..000000000000
--- a/www/nginx-devel/files/patch-src::os::unix::ngx_files.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/os/unix/ngx_files.c.orig 2011-10-21 15:04:46.000000000 +0400
-+++ src/os/unix/ngx_files.c 2011-11-21 17:43:45.000000000 +0400
-@@ -464,7 +464,7 @@
- }
-
-
--#if (NGX_HAVE_POSIX_FADVISE)
-+#if (NGX_HAVE_POSIX_FADVISE) && !(NGX_HAVE_F_READAHEAD)
-
- ngx_int_t
- ngx_read_ahead(ngx_fd_t fd, size_t n)