aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-05-06 00:16:31 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-05-06 00:16:31 +0800
commitfd89780e022b8479d7b2c5f89eaeaae861a99a30 (patch)
tree1eb8221f0468c16f7b1a9e972d503b2199bac2f1 /www
parentd08cdda31f34924bd97b2c68ac4ac180bb01b08c (diff)
downloadfreebsd-ports-gnome-fd89780e022b8479d7b2c5f89eaeaae861a99a30.tar.gz
freebsd-ports-gnome-fd89780e022b8479d7b2c5f89eaeaae861a99a30.tar.zst
freebsd-ports-gnome-fd89780e022b8479d7b2c5f89eaeaae861a99a30.zip
Fix selection of HTTP_XSLT and MODSECURITY so that the proper LIB_DEPENDS on
libxslt is added.
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile5
-rw-r--r--www/nginx/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index c68c1d3d99ad..5e43c0b243c3 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.9.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -512,7 +513,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-goodies-nginx-sticky-module-ng-c825
.endif
.if ${PORT_OPTIONS:MHTTP_XSLT}
-USE_GNOME= libxml2 libxslt
+USE_GNOME+= libxml2 libxslt
CONFIGURE_ARGS+=--with-http_xslt_module
.endif
@@ -596,7 +597,7 @@ LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
libcurl.so:${PORTSDIR}/ftp/curl \
libyajl.so:${PORTSDIR}/devel/yajl
USE_APACHE= 22+
-USE_GNOME= libxml2
+USE_GNOME+= libxml2
MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION}/:modsecurity
DISTFILES+= modsecurity-${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/nginx/modsecurity
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index d593333ed2f0..99c63e1b5f46 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.8.0
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -508,7 +509,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-goodies-nginx-sticky-module-ng-c825
.endif
.if ${PORT_OPTIONS:MHTTP_XSLT}
-USE_GNOME= libxml2 libxslt
+USE_GNOME+= libxml2 libxslt
CONFIGURE_ARGS+=--with-http_xslt_module
.endif
@@ -592,7 +593,7 @@ LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
libcurl.so:${PORTSDIR}/ftp/curl \
libyajl.so:${PORTSDIR}/devel/yajl
USE_APACHE= 22+
-USE_GNOME= libxml2
+USE_GNOME+= libxml2
MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION}/:modsecurity
DISTFILES+= modsecurity-${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/nginx/modsecurity