aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>1998-09-21 13:42:14 +0800
committerjkoshy <jkoshy@FreeBSD.org>1998-09-21 13:42:14 +0800
commit04b7db41e82d2e28d86d40c685b317e37d54de7a (patch)
treee85f2138d863f094c60d6c3f36016e9c75354d80 /www
parent03e1b637e1546b503a359fca9de0186a57c00e8d (diff)
downloadfreebsd-ports-gnome-04b7db41e82d2e28d86d40c685b317e37d54de7a.tar.gz
freebsd-ports-gnome-04b7db41e82d2e28d86d40c685b317e37d54de7a.tar.zst
freebsd-ports-gnome-04b7db41e82d2e28d86d40c685b317e37d54de7a.zip
Import of `linbot', a web site management tool.
PR: ports/8003 Reviewed by: jkoshy Submitted by: Bill Fumerola (billf@chc-chimes.com)
Diffstat (limited to 'www')
-rw-r--r--www/linbot/Makefile27
-rw-r--r--www/linbot/distinfo1
-rw-r--r--www/linbot/pkg-comment1
-rw-r--r--www/linbot/pkg-descr9
-rw-r--r--www/linbot/pkg-plist8
-rw-r--r--www/webcheck/Makefile27
-rw-r--r--www/webcheck/distinfo1
-rw-r--r--www/webcheck/pkg-comment1
-rw-r--r--www/webcheck/pkg-descr9
-rw-r--r--www/webcheck/pkg-plist8
10 files changed, 92 insertions, 0 deletions
diff --git a/www/linbot/Makefile b/www/linbot/Makefile
new file mode 100644
index 000000000000..95530b1a8479
--- /dev/null
+++ b/www/linbot/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linbot
+# Version required: 0.8
+# Date created: 19 September 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= linbot-0.8
+CATEGORIES= www
+MASTER_SITES= http://starship.skyport.net/crew/marduk/linbot/
+
+MAINTAINER= billf@chc-chimes.com
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_BUILD= yeah
+
+MAN1= linbot.1
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/linbot
+ ${CP} ${WRKSRC}/*.py ${PREFIX}/share/linbot
+ ${CP} ${WRKSRC}/contrib/*.1 ${PREFIX}/man/man1
+ ${LN} -s ${PREFIX}/share/linbot/linbot.py ${PREFIX}/bin/linbot
+
+.include <bsd.port.mk>
diff --git a/www/linbot/distinfo b/www/linbot/distinfo
new file mode 100644
index 000000000000..49dc088ba6a3
--- /dev/null
+++ b/www/linbot/distinfo
@@ -0,0 +1 @@
+MD5 (linbot-0.8.tar.gz) = ee327410be4dacb838aa79b3012763f6
diff --git a/www/linbot/pkg-comment b/www/linbot/pkg-comment
new file mode 100644
index 000000000000..45312cc5bec9
--- /dev/null
+++ b/www/linbot/pkg-comment
@@ -0,0 +1 @@
+view structure of a web site, get a list of problems like broken links.
diff --git a/www/linbot/pkg-descr b/www/linbot/pkg-descr
new file mode 100644
index 000000000000..672819672772
--- /dev/null
+++ b/www/linbot/pkg-descr
@@ -0,0 +1,9 @@
+Linbot is the professional Site Management Tool for webmasters. Linbot
+allows webmasters to view the structure of a site, track down broken links,
+find potentially outdated web pages list links pointing to external sites,
+view portfolio of inline images, get a run-down of problems sorted by
+author and to do all this periodically without user intervention.
+
+http://starship.skyport.net/crew/marduk/linbot/
+
+Bill Fumerola (billf@chc-chimes.com)
diff --git a/www/linbot/pkg-plist b/www/linbot/pkg-plist
new file mode 100644
index 000000000000..7e929c18e1a6
--- /dev/null
+++ b/www/linbot/pkg-plist
@@ -0,0 +1,8 @@
+@exec mkdir -p %D/share/linbot
+share/linbot/config.py
+share/linbot/linbot.py
+share/linbot/myUrlLib.py
+share/linbot/robotparser.py
+@exec ln -fs %D/share/linbot/linbot.py %D/bin/linbot
+@unexec rm -rf %D/share/linbot
+@unexec rm %D/bin/linbot
diff --git a/www/webcheck/Makefile b/www/webcheck/Makefile
new file mode 100644
index 000000000000..95530b1a8479
--- /dev/null
+++ b/www/webcheck/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linbot
+# Version required: 0.8
+# Date created: 19 September 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= linbot-0.8
+CATEGORIES= www
+MASTER_SITES= http://starship.skyport.net/crew/marduk/linbot/
+
+MAINTAINER= billf@chc-chimes.com
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_BUILD= yeah
+
+MAN1= linbot.1
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/linbot
+ ${CP} ${WRKSRC}/*.py ${PREFIX}/share/linbot
+ ${CP} ${WRKSRC}/contrib/*.1 ${PREFIX}/man/man1
+ ${LN} -s ${PREFIX}/share/linbot/linbot.py ${PREFIX}/bin/linbot
+
+.include <bsd.port.mk>
diff --git a/www/webcheck/distinfo b/www/webcheck/distinfo
new file mode 100644
index 000000000000..49dc088ba6a3
--- /dev/null
+++ b/www/webcheck/distinfo
@@ -0,0 +1 @@
+MD5 (linbot-0.8.tar.gz) = ee327410be4dacb838aa79b3012763f6
diff --git a/www/webcheck/pkg-comment b/www/webcheck/pkg-comment
new file mode 100644
index 000000000000..45312cc5bec9
--- /dev/null
+++ b/www/webcheck/pkg-comment
@@ -0,0 +1 @@
+view structure of a web site, get a list of problems like broken links.
diff --git a/www/webcheck/pkg-descr b/www/webcheck/pkg-descr
new file mode 100644
index 000000000000..672819672772
--- /dev/null
+++ b/www/webcheck/pkg-descr
@@ -0,0 +1,9 @@
+Linbot is the professional Site Management Tool for webmasters. Linbot
+allows webmasters to view the structure of a site, track down broken links,
+find potentially outdated web pages list links pointing to external sites,
+view portfolio of inline images, get a run-down of problems sorted by
+author and to do all this periodically without user intervention.
+
+http://starship.skyport.net/crew/marduk/linbot/
+
+Bill Fumerola (billf@chc-chimes.com)
diff --git a/www/webcheck/pkg-plist b/www/webcheck/pkg-plist
new file mode 100644
index 000000000000..7e929c18e1a6
--- /dev/null
+++ b/www/webcheck/pkg-plist
@@ -0,0 +1,8 @@
+@exec mkdir -p %D/share/linbot
+share/linbot/config.py
+share/linbot/linbot.py
+share/linbot/myUrlLib.py
+share/linbot/robotparser.py
+@exec ln -fs %D/share/linbot/linbot.py %D/bin/linbot
+@unexec rm -rf %D/share/linbot
+@unexec rm %D/bin/linbot