aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-27 02:52:42 +0800
committerrm <rm@FreeBSD.org>2012-10-27 02:52:42 +0800
commit1f31654907cb6e0bd4358b24585e29923eefdfec (patch)
tree977a06bd6922f1a7328c02569d67bb2801ea9a6c /www
parente738c95798b8f59be55f9b32510eb4712920293b (diff)
downloadfreebsd-ports-gnome-1f31654907cb6e0bd4358b24585e29923eefdfec.tar.gz
freebsd-ports-gnome-1f31654907cb6e0bd4358b24585e29923eefdfec.tar.zst
freebsd-ports-gnome-1f31654907cb6e0bd4358b24585e29923eefdfec.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - move pkg-plist contents into Makefile:PLIST_FILES - trim Makefile header - limit python version to 2.x only - tab -> space change in pkg-descr:WWW PR: 173062 Submitted by: rm (myself) Approved by: glarkin (maintainer, by mail) Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/trac-timingandestimation/Makefile18
-rw-r--r--www/trac-timingandestimation/pkg-descr2
-rw-r--r--www/trac-timingandestimation/pkg-plist1
3 files changed, 8 insertions, 13 deletions
diff --git a/www/trac-timingandestimation/Makefile b/www/trac-timingandestimation/Makefile
index ac6458850be1..e7773d9d00c1 100644
--- a/www/trac-timingandestimation/Makefile
+++ b/www/trac-timingandestimation/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: trac-timingandestimation
-# Date created: February 26 2010
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= timingandestimation
PORTVERSION= 1.0.8b
+PORTREVISION= 1
CATEGORIES= www devel python
MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
LOCAL/glarkin
@@ -17,15 +14,14 @@ USE_ZIP= yes
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Add estimation and time tracking functionality to Trac
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
WRKSRC= ${WRKDIR}/${PORTNAME}plugin/branches/trac0.12-Permissions
-NO_BUILD= yes
-USE_PYTHON= 2.3+
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION:S/.r/_r/} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= ${PORTNAME}plugin
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:S/.r/_r/}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/trac-timingandestimation/pkg-descr b/www/trac-timingandestimation/pkg-descr
index fcb100d4d0ca..424edf1f2590 100644
--- a/www/trac-timingandestimation/pkg-descr
+++ b/www/trac-timingandestimation/pkg-descr
@@ -3,4 +3,4 @@ tracking to Trac. This basically adds CustomFields and CustomReports
and an interface for filling the dynamic variables for the report
(requires Javascript).
-WWW: http://trac-hacks.org/wiki/TimingAndEstimationPlugin
+WWW: http://trac-hacks.org/wiki/TimingAndEstimationPlugin
diff --git a/www/trac-timingandestimation/pkg-plist b/www/trac-timingandestimation/pkg-plist
deleted file mode 100644
index 71301efeea6d..000000000000
--- a/www/trac-timingandestimation/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/timingandestimationplugin-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg