aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-09 18:03:47 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-09 18:03:47 +0800
commit2b3c4416762ff4b090d2da1c54b817fce754761d (patch)
tree413f75c0b248eef7b1b46bfd1fe1d5bc855bf5cc /www
parentac7e80acb4c6e262dc3bd4741eee7962884dcfba (diff)
downloadfreebsd-ports-gnome-2b3c4416762ff4b090d2da1c54b817fce754761d.tar.gz
freebsd-ports-gnome-2b3c4416762ff4b090d2da1c54b817fce754761d.tar.zst
freebsd-ports-gnome-2b3c4416762ff4b090d2da1c54b817fce754761d.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
- Always check NGINX_OPENSSL after it is defined Approved by: portmgr blanket
Diffstat (limited to 'www')
-rw-r--r--www/tengine/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/www/tengine/Makefile b/www/tengine/Makefile
index 6bd615a3fa8f..54e5eb4784fa 100644
--- a/www/tengine/Makefile
+++ b/www/tengine/Makefile
@@ -730,20 +730,15 @@ CONFIGURE_ARGS+=--without-http_rewrite_module \
--without-pcre
.endif
-.if defined(NGINX_OPENSSL)
-USE_OPENSSL= yes
-.if ${PORT_OPTIONS:MSPDY}
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000028
-WITH_OPENSSL_PORT= yes
-.endif
-.endif
-.endif
-
.if defined(WITH_HTTP_SSL)
NGINX_OPENSSL= yes
CONFIGURE_ARGS+=--with-http_ssl_module
.endif
+.if defined(NGINX_OPENSSL)
+USES+= ssl
+.endif
+
.if ${PORT_OPTIONS:MHTTP_SSL}
WITH_HTTP_SSL= yes
.endif