aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-11-25 04:39:55 +0800
committerobrien <obrien@FreeBSD.org>1998-11-25 04:39:55 +0800
commit2b3f95bcb3673411470aec0c0555287f757de14e (patch)
treeec249ba284030034b7ac3b4a965822b7b6606184 /www
parent902e2bc6b93179a80fb25c45f646b0dc6088b40d (diff)
downloadfreebsd-ports-gnome-2b3f95bcb3673411470aec0c0555287f757de14e.tar.gz
freebsd-ports-gnome-2b3f95bcb3673411470aec0c0555287f757de14e.tar.zst
freebsd-ports-gnome-2b3f95bcb3673411470aec0c0555287f757de14e.zip
* Fix md5 checksum that I messed up on last commit.
* Add back Fortify support. It works with navigator-45, it should work here. (note that port is still broken so I can't fully test it) Going to get yelled at by: thepish
Diffstat (limited to 'www')
-rw-r--r--www/bsdi-netscape47-communicator/Makefile19
-rw-r--r--www/netscape47-communicator/Makefile19
2 files changed, 28 insertions, 10 deletions
diff --git a/www/bsdi-netscape47-communicator/Makefile b/www/bsdi-netscape47-communicator/Makefile
index be64bc9da1ee..3dda042a4140 100644
--- a/www/bsdi-netscape47-communicator/Makefile
+++ b/www/bsdi-netscape47-communicator/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1997
# Whom: thepish
#
-# $Id: Makefile,v 1.26 1998/10/19 13:15:14 thepish Exp $
+# $Id: Makefile,v 1.27 1998/10/20 06:45:18 asami Exp $
#
DISTNAME= communicator-v45-export.x86-unknown-freebsd
@@ -22,10 +22,15 @@ NO_BUILD= Yes
NDIR= ${PREFIX}/lib/netscape.45
BINDIR= ${PREFIX}/bin
-pre-extract:
.if defined(USE_128BIT)
- @${ECHO} "Sorry Fortify do not provide support for pre-release netscape versions"
-.endif
+MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
+ ftp://ftp.za.freebsd.org/pub/Fortify/
+DISTFILES+= Fortify-1.3.0-unix-x86.tar.gz
+RESTRICTED= "Contains strong cryptography"
+.else
+pre-extract:
+ @${ECHO} "You can make Netscape use 128-bit encryption by defining USE_128BIT"
+.endif # USE_128BIT
.if !defined(MULTIVERSION)
@${ECHO} "you can define MULTIVERSION to install the script which runs communicator-v45"
@@ -48,6 +53,10 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/movemail-src
- chown -R root.wheel ${NDIR}
+.if defined(USE_128BIT)
+ cd ${WRKDIR}/Fortify-1.3.0-unix-x86 && \
+ (${ECHO} yes ; ${ECHO} no) | ./Fortify.sh ${NDIR}/communicator-4.5.bin
+.endif
+ chown -R ${BINOWN}.${BINGRP} ${NDIR}
.include <bsd.port.mk>
diff --git a/www/netscape47-communicator/Makefile b/www/netscape47-communicator/Makefile
index be64bc9da1ee..3dda042a4140 100644
--- a/www/netscape47-communicator/Makefile
+++ b/www/netscape47-communicator/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1997
# Whom: thepish
#
-# $Id: Makefile,v 1.26 1998/10/19 13:15:14 thepish Exp $
+# $Id: Makefile,v 1.27 1998/10/20 06:45:18 asami Exp $
#
DISTNAME= communicator-v45-export.x86-unknown-freebsd
@@ -22,10 +22,15 @@ NO_BUILD= Yes
NDIR= ${PREFIX}/lib/netscape.45
BINDIR= ${PREFIX}/bin
-pre-extract:
.if defined(USE_128BIT)
- @${ECHO} "Sorry Fortify do not provide support for pre-release netscape versions"
-.endif
+MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
+ ftp://ftp.za.freebsd.org/pub/Fortify/
+DISTFILES+= Fortify-1.3.0-unix-x86.tar.gz
+RESTRICTED= "Contains strong cryptography"
+.else
+pre-extract:
+ @${ECHO} "You can make Netscape use 128-bit encryption by defining USE_128BIT"
+.endif # USE_128BIT
.if !defined(MULTIVERSION)
@${ECHO} "you can define MULTIVERSION to install the script which runs communicator-v45"
@@ -48,6 +53,10 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/movemail-src
- chown -R root.wheel ${NDIR}
+.if defined(USE_128BIT)
+ cd ${WRKDIR}/Fortify-1.3.0-unix-x86 && \
+ (${ECHO} yes ; ${ECHO} no) | ./Fortify.sh ${NDIR}/communicator-4.5.bin
+.endif
+ chown -R ${BINOWN}.${BINGRP} ${NDIR}
.include <bsd.port.mk>