aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-09-01 05:09:18 +0800
committerflo <flo@FreeBSD.org>2011-09-01 05:09:18 +0800
commit301c11490dbfce527669c17931e2cd3426a0b35f (patch)
tree9adf70e219df046266a79190030d4209c45d9147 /www
parentaaf30cc6e997bdaef82a8fbcb8301bc1f337ead3 (diff)
downloadfreebsd-ports-gnome-301c11490dbfce527669c17931e2cd3426a0b35f.tar.gz
freebsd-ports-gnome-301c11490dbfce527669c17931e2cd3426a0b35f.tar.zst
freebsd-ports-gnome-301c11490dbfce527669c17931e2cd3426a0b35f.zip
- update to 3.1.15 + vendor patch 10373 [1]
- portlintify [1] - make sure we pass ${command_args} to all invocations of ${command} [2] PR: ports/160342 [1] ports/156737 [2] Submitted by: Thomas-Martin Seck <tmseck@web.de> (maintainer) [1] Martin Birgmeier <martin.birgmeier@aon.at> [2] Approved by: maintainer [2]
Diffstat (limited to 'www')
-rw-r--r--www/squid31/Makefile10
-rw-r--r--www/squid31/distinfo6
-rw-r--r--www/squid31/files/squid.in6
3 files changed, 12 insertions, 10 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index e4448bb865e6..c5fdd6a15c24 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -81,14 +81,17 @@ PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://www2.tw.squid-cache.org/%SUBDIR%/
PATCH_SITE_SUBDIR= Versions/v3/3.1/changesets
-PATCHFILES= # empty
+PATCHFILES= squid-3.1-10373.patch
MAINTAINER= tmseck@web.de
COMMENT= HTTP Caching Proxy
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LATEST_LINK= squid31
-SQUID_STABLE_VER= 14
+SQUID_STABLE_VER= 15
CONFLICTS_INSTALL= squid-2.[0-9].* squid-3.[^1].* cacheboy-[0-9]* lusca-head-[0-9]*
GNU_CONFIGURE= yes
@@ -96,9 +99,6 @@ USE_BZIP2= yes
USE_PERL5= yes
USE_RC_SUBR= squid
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
SQUID_UID?= squid
SQUID_GID?= squid
diff --git a/www/squid31/distinfo b/www/squid31/distinfo
index 8dedc7186337..b199918cd548 100644
--- a/www/squid31/distinfo
+++ b/www/squid31/distinfo
@@ -1,2 +1,4 @@
-SHA256 (squid3.1/squid-3.1.14.tar.bz2) = 8faf16d73ae44029e698160386c45ab853f2fc842601bd550a1c5461815d8a3e
-SIZE (squid3.1/squid-3.1.14.tar.bz2) = 2510694
+SHA256 (squid3.1/squid-3.1.15.tar.bz2) = 1300f44dd4783697bacc262a7a9b32dbc9f550367fe82b70262864fdff715a35
+SIZE (squid3.1/squid-3.1.15.tar.bz2) = 2510536
+SHA256 (squid3.1/squid-3.1-10373.patch) = 42e64e6a4df593fee927f9849d6853dd45d68d449da93afaad523295894c2ebf
+SIZE (squid3.1/squid-3.1-10373.patch) = 1326
diff --git a/www/squid31/files/squid.in b/www/squid31/files/squid.in
index 54bbfaa3366c..d21b439fa85d 100644
--- a/www/squid31/files/squid.in
+++ b/www/squid31/files/squid.in
@@ -41,7 +41,7 @@
#
squid_checkrunning() {
- ${command} ${squid_flags} -k check 2>/dev/null
+ ${command} ${command_args} ${squid_flags} -k check 2>/dev/null
}
squid_setfib() {
@@ -55,7 +55,7 @@ squid_setfib() {
squid_stop() {
echo "Stopping ${name}."
- ${command} ${squid_flags} -k shutdown
+ ${command} ${command_args} ${squid_flags} -k shutdown
run_rc_command poll
}
@@ -66,7 +66,7 @@ rcvar=${name}_enable
command=%%PREFIX%%/sbin/squid
extra_commands=reload
-reload_cmd="${command} ${squid_flags} -k reconfigure"
+reload_cmd="${command} ${command_args} ${squid_flags} -k reconfigure"
start_precmd="squid_setfib"
stop_precmd="squid_checkrunning"
stop_cmd="squid_stop"