aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-05 11:21:42 +0800
committermarcus <marcus@FreeBSD.org>2004-08-05 11:21:42 +0800
commit327478aa7058cf4461f8bf241222dde4d2c90b0f (patch)
tree848e1695efcc423a60db30f5cda36692a9c5d505 /www
parent06246ac9da8f843658e35ac25c0108268d38b0bb (diff)
downloadfreebsd-ports-gnome-327478aa7058cf4461f8bf241222dde4d2c90b0f.tar.gz
freebsd-ports-gnome-327478aa7058cf4461f8bf241222dde4d2c90b0f.tar.zst
freebsd-ports-gnome-327478aa7058cf4461f8bf241222dde4d2c90b0f.zip
Update to 20040803.
* Add option to enable a UTF-8 hack to avoid problems with UTF-8 filenames and ISO locales * Add option to install a GNOME desktop item for firefox and/or thunderbird PR: 69956 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/firefox-remote/Makefile61
-rw-r--r--www/firefox-remote/distinfo4
-rw-r--r--www/firefox-remote/pkg-plist4
3 files changed, 58 insertions, 11 deletions
diff --git a/www/firefox-remote/Makefile b/www/firefox-remote/Makefile
index eff08773a1b0..db7b0b379519 100644
--- a/www/firefox-remote/Makefile
+++ b/www/firefox-remote/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= firefox
-PORTVERSION= 20040702
+PORTVERSION= 20040803
CATEGORIES= www
MASTER_SITES= http://www.webonaut.com/distfiles/${PORTNAME}${PKGNAMESUFFIX}/
PKGNAMESUFFIX= -remote
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
-EXTRACT_SUFX= .bz2
MAINTAINER= klammer@webonaut.com
COMMENT= Wrapper scripts for firefox web browser
@@ -19,17 +18,61 @@ COMMENT= Wrapper scripts for firefox web browser
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-NO_WRKSUBDIR= yes
-EXTRACT_AFTER_ARGS= > ${PORTNAME}
+
+UTF8_HACK= no
+FIREFOX_REMOTE= ${PORTNAME}${PKGNAMESUFFIX}
+THUNDERBIRD_REMOTE= thunderbird${PKGNAMESUFFIX}
+
+OPTIONS=UTF8_LOCALE "Use UTF8 locale (read Makefile for details)" off \
+ MENU_FIREFOX "Add GNOME menu entry for firefox" off \
+ MENU_THUNDERBIRD "Add GNOME menu entry for thunderbird" off
+
+.include <bsd.port.pre.mk>
+
+# firefox/thunderbird can't display unicode filenames with special
+# characters like umlaute in german correctly if a ISO-locale is set.
+# when enabled the remote scripts try to switch to the UTF8-locale if
+# available (e.g. de_DE.UTF8 instead of de_DE.ISO8859-xx)
+.if defined(WITH_UTF8_LOCALE)
+UTF8_HACK= yes
+.endif
+
+.if defined(WITH_MENU_FIREFOX)
+PLIST_SUB+= MENU_FIREFOX=""
+.else
+PLIST_SUB+= MENU_FIREFOX="@comment "
+.endif
+
+.if defined(WITH_MENU_THUNDERBIRD)
+PLIST_SUB+= MENU_THUNDERBIRD=""
+.else
+PLIST_SUB+= MENU_THUNDERBIRD="@comment "
+.endif
do-build:
@${REINPLACE_CMD} -e 's|@X11BASE@|${PREFIX}|g' \
- ${WRKDIR}/${PORTNAME}
+ ${WRKSRC}/${FIREFOX_REMOTE}
+ @${REINPLACE_CMD} -e 's|@UTF8@|${UTF8_HACK}|g' \
+ ${WRKSRC}/${FIREFOX_REMOTE}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
- ${LN} -s ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX} \
- ${PREFIX}/bin/thunderbird${PKGNAMESUFFIX}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${FIREFOX_REMOTE} \
+ ${PREFIX}/bin/${FIREFOX_REMOTE}
+ ${RM} -f ${PREFIX}/bin/${THUNDERBIRD_REMOTE}
+ ${LN} -s ${PREFIX}/bin/${FIREFOX_REMOTE} \
+ ${PREFIX}/bin/${THUNDERBIRD_REMOTE}
+.if defined (WITH_MENU_FIREFOX)
+ ${INSTALL_DATA} ${WRKSRC}/mozilla_firefox.desktop \
+ ${X11BASE}/share/gnome/applications/
+ ${INSTALL_DATA} ${WRKSRC}/mozilla_firefox.png \
+ ${X11BASE}/share/gnome/pixmaps/
+.endif
+.if defined (WITH_MENU_THUNDERBIRD)
+ ${INSTALL_DATA} ${WRKSRC}/mozilla_thunderbird.desktop \
+ ${X11BASE}/share/gnome/applications/
+ ${INSTALL_DATA} ${WRKSRC}/mozilla_thunderbird.png \
+ ${X11BASE}/share/gnome/pixmaps/
+.endif
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/firefox-remote/distinfo b/www/firefox-remote/distinfo
index b93ad88e3800..3dca7f1e2381 100644
--- a/www/firefox-remote/distinfo
+++ b/www/firefox-remote/distinfo
@@ -1,2 +1,2 @@
-MD5 (firefox-remote-20040702.bz2) = cb6a563b7dc5c5a296ace363183918eb
-SIZE (firefox-remote-20040702.bz2) = 877
+MD5 (firefox-remote-20040803.tar.bz2) = 41cb8969eab5233662c24bfa75585062
+SIZE (firefox-remote-20040803.tar.bz2) = 12789
diff --git a/www/firefox-remote/pkg-plist b/www/firefox-remote/pkg-plist
index 368e900f3504..6898e0e433c2 100644
--- a/www/firefox-remote/pkg-plist
+++ b/www/firefox-remote/pkg-plist
@@ -1,2 +1,6 @@
bin/firefox-remote
bin/thunderbird-remote
+%%MENU_FIREFOX%%share/gnome/applications/mozilla_firefox.desktop
+%%MENU_THUNDERBIRD%%share/gnome/applications/mozilla_thunderbird.desktop
+%%MENU_FIREFOX%%share/gnome/pixmaps/mozilla_firefox.png
+%%MENU_THUNDERBIRD%%share/gnome/pixmaps/mozilla_thunderbird.png