aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2011-08-22 19:58:24 +0800
committerrea <rea@FreeBSD.org>2011-08-22 19:58:24 +0800
commit336e128db7b88b5b36ada0230b5080a328c1c88e (patch)
tree0b6c875881be8c02d9961409a7c12dbf7313e0fd /www
parenteb331c9faa00122417133fc33d89ff3150a35b88 (diff)
downloadfreebsd-ports-gnome-336e128db7b88b5b36ada0230b5080a328c1c88e.tar.gz
freebsd-ports-gnome-336e128db7b88b5b36ada0230b5080a328c1c88e.tar.zst
freebsd-ports-gnome-336e128db7b88b5b36ada0230b5080a328c1c88e.zip
New port: www/trac-tickettemplate
TicketTemplate enable users to create ticket using templates which can be customized by Trac administrator and themselves. Approved by: erwin (mentor) Feature safe: yes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-tickettemplate/Makefile53
-rw-r--r--www/trac-tickettemplate/distinfo2
-rw-r--r--www/trac-tickettemplate/pkg-descr4
-rw-r--r--www/trac-tickettemplate/pkg-plist1
5 files changed, 61 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e2cfcd2cd358..99d92cf26473 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1839,6 +1839,7 @@
SUBDIR += trac-themeengine
SUBDIR += trac-ticketdelete
SUBDIR += trac-ticketimport
+ SUBDIR += trac-tickettemplate
SUBDIR += trac-timingandestimation
SUBDIR += trac-tocmacro
SUBDIR += trac-tweakui
diff --git a/www/trac-tickettemplate/Makefile b/www/trac-tickettemplate/Makefile
new file mode 100644
index 000000000000..9c3236036948
--- /dev/null
+++ b/www/trac-tickettemplate/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: trac-autocomplete
+# Date created: August 18, 2011
+# Whom: Eygene Ryabinkin <rea@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tickettemplate
+PORTVERSION= 0.7
+CATEGORIES= www python
+MASTER_SITES= http://dist.codelabs.ru/fbsd/trac-${PORTNAME}/
+PKGNAMEPREFIX= trac-
+DISTNAME= trac${PORTNAME}plugin-r${REL}
+
+MAINTAINER= rea@FreeBSD.org
+COMMENT= A plugin for making ticket templates
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= trac>=0.11:${PORTSDIR}/www/trac
+
+USE_PYTHON= yes
+USE_ZIP= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+# Python < 2.6 needs simplejson package.
+.if ${PYTHON_VER} == 2.4 || ${PYTHON_VER} == 2.5
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}simplejson:${PORTSDIR}/devel/py-simplejson
+.endif
+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= TracTicketTemplate
+PYDISTUTILS_NOEGGINFO= yes
+
+WRKSRC= ${WRKDIR}/trac${PORTNAME}plugin/0.11
+REL= 10605
+PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
+
+# We must fix file permissions -- ZIP file have 0000 for every file.
+# Directory permissions are fine (they aren't stored inside ZIP
+# file), but we set them too -- just in case.
+post-extract:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${CHMOD} 644
+ @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
+
+# Target to generate packaging list
+plist:
+ @${FIND} ${PYTHON_SITELIBDIR}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg -type f | ${SED} -e's|^${PYTHON_SITELIBDIR}/|%%PYTHON_SITELIBDIR%%/|;s|/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py[[:digit:]\.]*.egg|/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py%%PYTHON_VER%%.egg|'
+ @${FIND} ${PYTHON_SITELIBDIR}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg -type d -mindepth 1 | ${SORT} -r | ${SED} -e's|^${PYTHON_SITELIBDIR}/|@dirrm %%PYTHON_SITELIBDIR%%/|;s|/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py[[:digit:]\.]*.egg|/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py%%PYTHON_VER%%.egg|'
+ @[ -d ${PYTHON_SITELIBDIR}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg ] && ${ECHO} '@dirrm %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py%%PYTHON_VER%%.egg'
+
+.include <bsd.port.post.mk>
diff --git a/www/trac-tickettemplate/distinfo b/www/trac-tickettemplate/distinfo
new file mode 100644
index 000000000000..6bd1fb501fc8
--- /dev/null
+++ b/www/trac-tickettemplate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tractickettemplateplugin-r10605.zip) = b37a9509ace8ebb2b73b79fd614e3c5f00cc7cfc7cbdfd6e38f581880eed95f2
+SIZE (tractickettemplateplugin-r10605.zip) = 48209
diff --git a/www/trac-tickettemplate/pkg-descr b/www/trac-tickettemplate/pkg-descr
new file mode 100644
index 000000000000..02af7d2b312f
--- /dev/null
+++ b/www/trac-tickettemplate/pkg-descr
@@ -0,0 +1,4 @@
+TicketTemplate enable users to create ticket using templates
+which can be customized by Trac administrator and themselves.
+
+WWW: http://trac-hacks.org/wiki/TracTicketTemplatePlugin
diff --git a/www/trac-tickettemplate/pkg-plist b/www/trac-tickettemplate/pkg-plist
new file mode 100644
index 000000000000..e66eebbff89b
--- /dev/null
+++ b/www/trac-tickettemplate/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracTicketTemplate-0.7-py%%PYTHON_VER%%.egg