aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2012-05-09 05:25:51 +0800
committerdelphij <delphij@FreeBSD.org>2012-05-09 05:25:51 +0800
commit345f7fa4ed6c043fb9a29237788618095dcb4090 (patch)
treef293dc419a4f4dd9cd9ff15ce5bed8a17edcfb2c /www
parent7a96b5fd0fc9e211ae6228fa5a452556070d5e1b (diff)
downloadfreebsd-ports-gnome-345f7fa4ed6c043fb9a29237788618095dcb4090.tar.gz
freebsd-ports-gnome-345f7fa4ed6c043fb9a29237788618095dcb4090.tar.zst
freebsd-ports-gnome-345f7fa4ed6c043fb9a29237788618095dcb4090.zip
Creating delicious APIs for Django apps since 2010.
Here are some common reasons for tastypie: * You need an API that is RESTful and uses HTTP well. * You want to support deep relations. * You DON'T want to have to write your own serializer to make the output right. * You want an API framework that has little magic, very flexible and maps well to the problem domain. * You want/need XML serialization that is treated equally to JSON (and YAML is there too). * You want to support my perceived NIH syndrome, which is less about NIH and more about trying to help out friends/coworkers. PR: ports/167716 Submitted by: William Grzybowski <william88 gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-tastypie/Makefile25
-rw-r--r--www/py-django-tastypie/distinfo2
-rw-r--r--www/py-django-tastypie/pkg-descr16
4 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7aa805705aff..22774f22f051 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1471,6 +1471,7 @@
SUBDIR += py-django-signals-ahoy
SUBDIR += py-django-storages
SUBDIR += py-django-tagging
+ SUBDIR += py-django-tastypie
SUBDIR += py-django-threaded-multihost
SUBDIR += py-django12
SUBDIR += py-django13
diff --git a/www/py-django-tastypie/Makefile b/www/py-django-tastypie/Makefile
new file mode 100644
index 000000000000..8a74d61c400b
--- /dev/null
+++ b/www/py-django-tastypie/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: django-tastypie
+# Date created: May 8, 2012
+# Whom: William Grzybowski
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-tastypie
+PORTVERSION= 0.9.11
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= william88@gmail.com
+COMMENT= Create REST API for Django apps
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:${PORTSDIR}/devel/py-dateutil
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/py-django-tastypie/distinfo b/www/py-django-tastypie/distinfo
new file mode 100644
index 000000000000..20e6a89c9803
--- /dev/null
+++ b/www/py-django-tastypie/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-tastypie-0.9.11.tar.gz) = 6425f065aae6a6a3aecf6c83ed728efbd1f490ce32aabd16ddcdfb5826c74214
+SIZE (django-tastypie-0.9.11.tar.gz) = 519484
diff --git a/www/py-django-tastypie/pkg-descr b/www/py-django-tastypie/pkg-descr
new file mode 100644
index 000000000000..9d2d7520ba87
--- /dev/null
+++ b/www/py-django-tastypie/pkg-descr
@@ -0,0 +1,16 @@
+Creating delicious APIs for Django apps since 2010.
+
+Here are some common reasons for tastypie:
+
+ * You need an API that is RESTful and uses HTTP well.
+ * You want to support deep relations.
+ * You DON'T want to have to write your own serializer to make the output
+ right.
+ * You want an API framework that has little magic, very flexible and maps
+ well to the problem domain.
+ * You want/need XML serialization that is treated equally to JSON (and
+ YAML is there too).
+ * You want to support my perceived NIH syndrome, which is less about
+ NIH and more about trying to help out friends/coworkers.
+
+WWW: http://south.aeracode.org://github.com/toastdriven/django-tastypie/