aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-08-07 01:37:00 +0800
committerleeym <leeym@FreeBSD.org>2004-08-07 01:37:00 +0800
commit4c7f31b870097d8c1d81be2ad18aefbd80a28be2 (patch)
treef99a69df7bd5d2af75906340eb29b0959e21aada /www
parent4cbde22db8be6f7babd58c4ea1412d06ffaffc28 (diff)
downloadfreebsd-ports-gnome-4c7f31b870097d8c1d81be2ad18aefbd80a28be2.tar.gz
freebsd-ports-gnome-4c7f31b870097d8c1d81be2ad18aefbd80a28be2.tar.zst
freebsd-ports-gnome-4c7f31b870097d8c1d81be2ad18aefbd80a28be2.zip
Perl 5.8.4 and above add several security check when doing setuid.
One of these checks is that the interpreter must have string "perl" with it. http://sourceforge.net/mailarchive/forum.php?thread_id=4823748&forum_id=7581 - rename speedy_suid to speedy_suidperl (or speedyperl_suid will be fine, too) - utilize ECHO - replace all /usr/local with PREFIX will cause some problems when PREFIX isn't /usr/local (missing PERL5 libraries and modules... blah blah...) - bump PORTREVISION PR: 69970 Submitted by: leeym Reviewed by: lth
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile8
-rw-r--r--www/p5-CGI-SpeedyCGI/pkg-plist2
2 files changed, 5 insertions, 5 deletions
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index c4261d09ff7b..7faeb84e06e0 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CGI-SpeedyCGI
PORTVERSION= 2.22
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CGI
@@ -29,7 +30,7 @@ CONFIGURE_ENV+= WITHOUT_APACHE=yes
.else
PLIST_SUB+= APACHE=""
.if exists(${APXS})
-APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || ${ECHO} no
.endif
.if exists(${APXS}) && ${APXS_WORKS} != no
AP_LIBEXEC!= ${APXS} -q LIBEXECDIR
@@ -41,11 +42,10 @@ PLIST_SUB+= AP_LIBEXEC=${AP_LIBEXEC:S/^${PREFIX}\///}
post-configure:
@${PERL} -pi -e 's,^PREFIX = /usr$$,PREFIX = ${PREFIX},g;' \
- -e 's,/usr/local,${PREFIX},g;' \
${WRKSRC}/Makefile ${WRKSRC}/*/Makefile
post-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/speedy/speedy ${PREFIX}/bin/speedy_suid
- @${CHMOD} 4755 ${PREFIX}/bin/speedy_suid
+ @${INSTALL_PROGRAM} ${WRKSRC}/speedy/speedy ${PREFIX}/bin/speedy_suidperl
+ @${CHMOD} 4755 ${PREFIX}/bin/speedy_suidperl
.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-SpeedyCGI/pkg-plist b/www/p5-CGI-SpeedyCGI/pkg-plist
index cb58b91a3a18..c436ddb2033b 100644
--- a/www/p5-CGI-SpeedyCGI/pkg-plist
+++ b/www/p5-CGI-SpeedyCGI/pkg-plist
@@ -3,7 +3,7 @@
%%SITE_PERL%%/CGI/SpeedyCGI.pm
bin/speedy
bin/speedy_backend
-bin/speedy_suid
+bin/speedy_suidperl
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/SpeedyCGI
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/CGI 2>/dev/null || true