aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-05-18 10:05:44 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-05-18 10:05:44 +0800
commit5f299d51a5deabe57b150a82ec32ecacdb3a02d0 (patch)
tree55c039f7d00357ced7283898ab9e6453c0c5293b /www
parent467d4a7f1f2b1d08213b22cf2bf1601315879f6f (diff)
downloadfreebsd-ports-gnome-5f299d51a5deabe57b150a82ec32ecacdb3a02d0.tar.gz
freebsd-ports-gnome-5f299d51a5deabe57b150a82ec32ecacdb3a02d0.tar.zst
freebsd-ports-gnome-5f299d51a5deabe57b150a82ec32ecacdb3a02d0.zip
- Update to 2.1.2
- While I'm here, use USE_PHP to handle database dependencies Changes: http://bakery.cakephp.org/articles/markstory/2012/04/30/cakephp_2_1_2_2_2_0-beta_released PR: ports/167888 Submitted by: Christoph Theis <theis@gmx.at> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/cakephp2/Makefile24
-rw-r--r--www/cakephp2/distinfo4
-rw-r--r--www/cakephp2/pkg-plist3
3 files changed, 12 insertions, 19 deletions
diff --git a/www/cakephp2/Makefile b/www/cakephp2/Makefile
index de785854778c..7b7459f9e5f2 100644
--- a/www/cakephp2/Makefile
+++ b/www/cakephp2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cakephp
-PORTVERSION= 2.1.1
+PORTVERSION= 2.1.2
CATEGORIES= www
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/tarball/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTNAME}-${PORTVERSION}-${GITVERSION}
@@ -16,9 +16,9 @@ COMMENT= A framework for developing PHP web applications
LICENSE= MIT
-GITVERSION= 0-g43cf2f0
+GITVERSION= 0-g7fd1995
FETCH_ARGS= -pRr
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-0cad237
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-77aa960
PORTDOCS= README
@@ -28,7 +28,7 @@ CONFLICTS= cakephp-1.*
NO_BUILD= yes
USE_GETTEXT= yes
-USE_PHP= session
+USE_PHP= ctype session
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
IGNORE_WITH_PHP=4
@@ -92,26 +92,16 @@ SUB_FILES+= ${CONF}
PLIST_SUB+= CONFDIR=${CONFDIR_REL} ECHO_MSG=${ECHO_MSG} \
HTACCESS=${HTACCESS} APDEP=${APDEP}
-DB_DEFINED= no
-
.if defined(WITH_MYSQL)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_mysql.so:${PORTSDIR}/databases/php5-pdo_mysql
-DB_DEFINED= yes
+USE_PHP+= pdo pdo_mysql
.endif
.if defined(WITH_PGSQL)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-DB_DEFINED= yes
+USE_PHP+= pdo pdo_pgsql
.endif
.if defined(WITH_SQLITE)
-DB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_sqlite.so:${PORTSDIR}/databases/php5-pdo_sqlite
-DB_DEFINED= yes
-.endif
-
-.if ${DB_DEFINED} == "yes"
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo.so:${PORTSDIR}/databases/php5-pdo \
- ${DB_DEPENDS}
+USE_PHP+= pdo pdo_sqlite
.endif
.if defined(WITH_APC)
diff --git a/www/cakephp2/distinfo b/www/cakephp2/distinfo
index 5cd6efd57d4e..1aef384a5e9b 100644
--- a/www/cakephp2/distinfo
+++ b/www/cakephp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cakephp-cakephp-2.1.1-0-g43cf2f0.tar.gz) = e54f2fcb3eb14c8caaf773888613b01c7f7205c4ef82a50838ea2cecf9e7a9f3
-SIZE (cakephp-cakephp-2.1.1-0-g43cf2f0.tar.gz) = 1124497
+SHA256 (cakephp-cakephp-2.1.2-0-g7fd1995.tar.gz) = 393f668fe5b3b45686e3eb2a2f83884c505f4cc34fd1a2db6c5b39863324d9db
+SIZE (cakephp-cakephp-2.1.2-0-g7fd1995.tar.gz) = 1128890
diff --git a/www/cakephp2/pkg-plist b/www/cakephp2/pkg-plist
index dd7434263f46..f84b2f57f07c 100644
--- a/www/cakephp2/pkg-plist
+++ b/www/cakephp2/pkg-plist
@@ -370,6 +370,7 @@
%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/Database/PostgresTest.php
%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/Database/SqliteTest.php
%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/Database/SqlserverTest.php
+%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/DataSourceTest.php
%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/DboSourceTest.php
%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/Session/CacheSessionTest.php
%%WWWDIR%%/lib/Cake/Test/Case/Model/Datasource/Session/DatabaseSessionTest.php
@@ -716,6 +717,7 @@
%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/Vendor/welcome.php
%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/Vendor/Example/ExampleExample.php
%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Elements/plugin_element.ctp
+%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Elements/sub_dir/sub_element.ctp
%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Elements/test_plugin_element.ctp
%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Elements/translate.ctp
%%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Emails/text/test_plugin_tpl.ctp
@@ -1005,6 +1007,7 @@
@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Helper
@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Emails/text
@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Emails
+@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Elements/sub_dir
@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View/Elements
@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/View
@dirrm %%WWWDIR%%/lib/Cake/Test/test_app/Plugin/TestPlugin/Vendor/sample