aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-20 14:26:06 +0800
committerasami <asami@FreeBSD.org>1999-02-20 14:26:06 +0800
commit646a92a34a4334e098cff4856f33ae6dd581f001 (patch)
tree061c4e5daf5d8cf9eb0449eda266bd551ae552c2 /www
parentb35df9eb539c9437c643d97f068e1e7744b0b248 (diff)
downloadfreebsd-ports-gnome-646a92a34a4334e098cff4856f33ae6dd581f001.tar.gz
freebsd-ports-gnome-646a92a34a4334e098cff4856f33ae6dd581f001.tar.zst
freebsd-ports-gnome-646a92a34a4334e098cff4856f33ae6dd581f001.zip
Make this handle WRKDIRPREFIX correctly. Note this port is still broken
regardless.
Diffstat (limited to 'www')
-rw-r--r--www/p5-Apache/Makefile4
-rw-r--r--www/p5-Apache/files/patch-aa4
2 files changed, 4 insertions, 4 deletions
diff --git a/www/p5-Apache/Makefile b/www/p5-Apache/Makefile
index 76498ac32ae4..14d0e9c3e308 100644
--- a/www/p5-Apache/Makefile
+++ b/www/p5-Apache/Makefile
@@ -3,7 +3,7 @@
# Date created: April 26th 1997
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.10 1998/09/03 13:45:47 asami Exp $
+# $Id: Makefile,v 1.11 1998/09/15 21:31:55 asami Exp $
#
DISTNAME= mod_perl-1.07
@@ -19,7 +19,7 @@ BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/apache12:patch
BROKEN= perl5 upgrade
USE_PERL5= YES
-CONFIGURE_ENV= PORTSDIR=${PORTSDIR} INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+CONFIGURE_ENV= APACHEDIR=${WRKDIRPREFIX}${.CURDIR}/../apache12/work INSTALL_PROGRAM="${INSTALL_PROGRAM}"
MAN3= Apache.3 Apache::Constants.3 Apache::Options.3 \
Apache::Registry.3 Apache::Status.3 Bundle::Apache.3 \
Apache::Debug.3 mod_perl.3 Apache::SIG.3 Apache::Resource.3 \
diff --git a/www/p5-Apache/files/patch-aa b/www/p5-Apache/files/patch-aa
index b88da40d2e00..964d721a841d 100644
--- a/www/p5-Apache/files/patch-aa
+++ b/www/p5-Apache/files/patch-aa
@@ -13,10 +13,10 @@
-$APACHE_SRC_DEFAULT = $@ ?
- '../apache_x.x/src' :
- $Apache::MyConfig::Setup{Apache_Src} ;
-+opendir( WRKDIR, "$ENV{PORTSDIR}/www/apache12/work" ) || die( "Can't open $ENV{PORTSDIR}/www/apache/work: $!\n" );
++opendir( WRKDIR, "$ENV{APACHEDIR}" ) || die( "Can't open $ENV{APACHEDIR}: $!\n" );
+( $srcdir ) = grep( /^apache/, readdir( WRKDIR ) );
+closedir( WRKDIR );
-+$APACHE_SRC_DEFAULT = "$ENV{PORTSDIR}/www/apache12/work/" . $srcdir . "/src";
++$APACHE_SRC_DEFAULT = "$ENV{APACHEDIR}" . $srcdir . "/src";
my $PWD = cwd;
my %SSL = (