aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2001-04-15 16:40:22 +0800
committerache <ache@FreeBSD.org>2001-04-15 16:40:22 +0800
commit79adbdbad984c908334454ed0fac427b0ffbc136 (patch)
tree3fec5acb7e0e213fee6da935c7d0b402ab472bc9 /www
parenta7ec0c4f47569cce1876f6994f32b36d6f23535a (diff)
downloadfreebsd-ports-gnome-79adbdbad984c908334454ed0fac427b0ffbc136.tar.gz
freebsd-ports-gnome-79adbdbad984c908334454ed0fac427b0ffbc136.tar.zst
freebsd-ports-gnome-79adbdbad984c908334454ed0fac427b0ffbc136.zip
Install sample spelld.sh script
Diffstat (limited to 'www')
-rw-r--r--www/mnoGoSearch-current/Makefile2
-rw-r--r--www/mnoGoSearch-current/files/spelld.sh-dist24
-rw-r--r--www/mnoGoSearch-current/pkg-plist1
-rw-r--r--www/mnogosearch/Makefile2
-rw-r--r--www/mnogosearch/files/spelld.sh-dist24
-rw-r--r--www/mnogosearch/pkg-plist1
-rw-r--r--www/mnogosearch31/Makefile2
-rw-r--r--www/mnogosearch31/files/spelld.sh-dist24
-rw-r--r--www/mnogosearch31/pkg-plist1
9 files changed, 81 insertions, 0 deletions
diff --git a/www/mnoGoSearch-current/Makefile b/www/mnoGoSearch-current/Makefile
index fa27ca5614db..f661ee800663 100644
--- a/www/mnoGoSearch-current/Makefile
+++ b/www/mnoGoSearch-current/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mnogosearch
PORTVERSION= 3.1.12
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://search.mnogo.ru/Download/
@@ -65,6 +66,7 @@ post-install:
${CHMOD} 700 /var/mnogosearch/cache
${CHOWN} -R nobody.nogroup /var/mnogosearch/
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/mnogosearch
+ ${INSTALL_DATA} ${FILESDIR}/spelld.sh-dist ${PREFIX}/etc/rc.d/
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/www/mnoGoSearch-current/files/spelld.sh-dist b/www/mnoGoSearch-current/files/spelld.sh-dist
new file mode 100644
index 000000000000..e9f44ae6bf7d
--- /dev/null
+++ b/www/mnoGoSearch-current/files/spelld.sh-dist
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/sbin/spelld ]; then
+# Uncomment to disallow access from outside
+# /sbin/ipfw -q add 7001 deny tcp from any to any 7001
+ su -f -m nobody -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
+ fi
+ ;;
+stop)
+ killall spelld && echo -n ' spelld'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/www/mnoGoSearch-current/pkg-plist b/www/mnoGoSearch-current/pkg-plist
index 253b3e4c564c..ade4eb6167a1 100644
--- a/www/mnoGoSearch-current/pkg-plist
+++ b/www/mnoGoSearch-current/pkg-plist
@@ -1,6 +1,7 @@
etc/mnogosearch/indexer.conf-dist
etc/mnogosearch/search.htm-dist
etc/mnogosearch/spelld.conf-dist
+etc/rc.d/spelld.sh-dist
include/udm_agent.h
include/udm_alias.h
include/udm_boolean.h
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index fa27ca5614db..f661ee800663 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mnogosearch
PORTVERSION= 3.1.12
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://search.mnogo.ru/Download/
@@ -65,6 +66,7 @@ post-install:
${CHMOD} 700 /var/mnogosearch/cache
${CHOWN} -R nobody.nogroup /var/mnogosearch/
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/mnogosearch
+ ${INSTALL_DATA} ${FILESDIR}/spelld.sh-dist ${PREFIX}/etc/rc.d/
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/www/mnogosearch/files/spelld.sh-dist b/www/mnogosearch/files/spelld.sh-dist
new file mode 100644
index 000000000000..e9f44ae6bf7d
--- /dev/null
+++ b/www/mnogosearch/files/spelld.sh-dist
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/sbin/spelld ]; then
+# Uncomment to disallow access from outside
+# /sbin/ipfw -q add 7001 deny tcp from any to any 7001
+ su -f -m nobody -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
+ fi
+ ;;
+stop)
+ killall spelld && echo -n ' spelld'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/www/mnogosearch/pkg-plist b/www/mnogosearch/pkg-plist
index 253b3e4c564c..ade4eb6167a1 100644
--- a/www/mnogosearch/pkg-plist
+++ b/www/mnogosearch/pkg-plist
@@ -1,6 +1,7 @@
etc/mnogosearch/indexer.conf-dist
etc/mnogosearch/search.htm-dist
etc/mnogosearch/spelld.conf-dist
+etc/rc.d/spelld.sh-dist
include/udm_agent.h
include/udm_alias.h
include/udm_boolean.h
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index fa27ca5614db..f661ee800663 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mnogosearch
PORTVERSION= 3.1.12
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://search.mnogo.ru/Download/
@@ -65,6 +66,7 @@ post-install:
${CHMOD} 700 /var/mnogosearch/cache
${CHOWN} -R nobody.nogroup /var/mnogosearch/
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/mnogosearch
+ ${INSTALL_DATA} ${FILESDIR}/spelld.sh-dist ${PREFIX}/etc/rc.d/
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/www/mnogosearch31/files/spelld.sh-dist b/www/mnogosearch31/files/spelld.sh-dist
new file mode 100644
index 000000000000..e9f44ae6bf7d
--- /dev/null
+++ b/www/mnogosearch31/files/spelld.sh-dist
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/sbin/spelld ]; then
+# Uncomment to disallow access from outside
+# /sbin/ipfw -q add 7001 deny tcp from any to any 7001
+ su -f -m nobody -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
+ fi
+ ;;
+stop)
+ killall spelld && echo -n ' spelld'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/www/mnogosearch31/pkg-plist b/www/mnogosearch31/pkg-plist
index 253b3e4c564c..ade4eb6167a1 100644
--- a/www/mnogosearch31/pkg-plist
+++ b/www/mnogosearch31/pkg-plist
@@ -1,6 +1,7 @@
etc/mnogosearch/indexer.conf-dist
etc/mnogosearch/search.htm-dist
etc/mnogosearch/spelld.conf-dist
+etc/rc.d/spelld.sh-dist
include/udm_agent.h
include/udm_alias.h
include/udm_boolean.h