aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-06-06 22:54:23 +0800
committermiwi <miwi@FreeBSD.org>2009-06-06 22:54:23 +0800
commit8865c591ff9e73045e7143d456444be35097d110 (patch)
treef4af9a99767ee9a9596b45405e8ae669b3a8aaf7 /www
parentd58d81e1bc495801cb37f0c325d61b160917ee25 (diff)
downloadfreebsd-ports-gnome-8865c591ff9e73045e7143d456444be35097d110.tar.gz
freebsd-ports-gnome-8865c591ff9e73045e7143d456444be35097d110.tar.zst
freebsd-ports-gnome-8865c591ff9e73045e7143d456444be35097d110.zip
eCAP is a software interface that allows a network application,
such as an HTTP proxy or an ICAP server, to outsource content analysis and adaptation to a loadable module. WWW: http://www.e-cap.org/ PR: ports/135190 Submitted by: Thomas-Martin Seck <tmseck at web.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/libecap/Makefile28
-rw-r--r--www/libecap/distinfo3
-rw-r--r--www/libecap/pkg-descr5
-rw-r--r--www/libecap/pkg-plist30
5 files changed, 67 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 39606e6d0db3..64fcfc0832d8 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -323,6 +323,7 @@
SUBDIR += kompozer
SUBDIR += larbin
SUBDIR += libapreq2
+ SUBDIR += libecap
SUBDIR += libepc
SUBDIR += libghttp
SUBDIR += libgtkhtml
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
new file mode 100644
index 000000000000..971b8e3dbfdf
--- /dev/null
+++ b/www/libecap/Makefile
@@ -0,0 +1,28 @@
+# Ports collection Makefile for: libecap
+# Date created: 2009/06/02
+# Whom: Thomas-Martin Seck <tmseck@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libecap
+PORTVERSION= 0.0.2
+CATEGORIES= www security
+MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
+
+MAINTAINER= tmseck@web.de
+COMMENT= Library for module based network content analysis
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GCC= 4.2+
+
+PORTDOCS= CREDITS LICENSE NOTICE README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/libecap/distinfo b/www/libecap/distinfo
new file mode 100644
index 000000000000..a97530095cbb
--- /dev/null
+++ b/www/libecap/distinfo
@@ -0,0 +1,3 @@
+MD5 (libecap-0.0.2.tar.gz) = 9bd302fef03eba1e6627a4ad2942aa41
+SHA256 (libecap-0.0.2.tar.gz) = ec3a7acc848eeb3e93d9bae6bebae5d7f6eb32023b5e814b45daeea45b0731d6
+SIZE (libecap-0.0.2.tar.gz) = 298074
diff --git a/www/libecap/pkg-descr b/www/libecap/pkg-descr
new file mode 100644
index 000000000000..46bca2d4355f
--- /dev/null
+++ b/www/libecap/pkg-descr
@@ -0,0 +1,5 @@
+eCAP is a software interface that allows a network application,
+such as an HTTP proxy or an ICAP server, to outsource content
+analysis and adaptation to a loadable module.
+
+WWW: http://www.e-cap.org/
diff --git a/www/libecap/pkg-plist b/www/libecap/pkg-plist
new file mode 100644
index 000000000000..1ec6f0fb35a3
--- /dev/null
+++ b/www/libecap/pkg-plist
@@ -0,0 +1,30 @@
+@comment $FreeBSD$
+include/libecap/adapter/service.h
+include/libecap/adapter/xaction.h
+include/libecap/common/libecap.h
+include/libecap/common/registry.h
+include/libecap/common/forward.h
+include/libecap/common/errors.h
+include/libecap/common/log.h
+include/libecap/common/memory.h
+include/libecap/common/call.h
+include/libecap/common/area.h
+include/libecap/common/name.h
+include/libecap/common/names.h
+include/libecap/common/header.h
+include/libecap/common/body.h
+include/libecap/common/body_size.h
+include/libecap/common/message.h
+include/libecap/common/version.h
+include/libecap/common/delay.h
+include/libecap/common/autoconf.h
+include/libecap/host/host.h
+include/libecap/host/xaction.h
+@dirrm include/libecap/adapter
+@dirrm include/libecap/common
+@dirrm include/libecap/host
+@dirrm include/libecap
+lib/libecap.a
+lib/libecap.la
+lib/libecap.so
+lib/libecap.so.0