aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2011-07-25 10:56:02 +0800
committerlioux <lioux@FreeBSD.org>2011-07-25 10:56:02 +0800
commit916c31407444fa85bb53e33fd497377766a4458d (patch)
tree0663c4089c5b2201c341c82d916239cb9c167945 /www
parent1456cf49c4b34b966f518bd12bcceb544f306641 (diff)
downloadfreebsd-ports-gnome-916c31407444fa85bb53e33fd497377766a4458d.tar.gz
freebsd-ports-gnome-916c31407444fa85bb53e33fd497377766a4458d.tar.zst
freebsd-ports-gnome-916c31407444fa85bb53e33fd497377766a4458d.zip
New port py-tvdb_api version 1.5: API interface to TheTVDB.com
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-tvdb_api/Makefile24
-rw-r--r--www/py-tvdb_api/distinfo2
-rw-r--r--www/py-tvdb_api/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 29bac1e123fa..1affccafba48 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1585,6 +1585,7 @@
SUBDIR += py-tornado
SUBDIR += py-turbogears
SUBDIR += py-turbogears2
+ SUBDIR += py-tvdb_api
SUBDIR += py-twistedWeb
SUBDIR += py-twistedWeb2
SUBDIR += py-urlgrabber
diff --git a/www/py-tvdb_api/Makefile b/www/py-tvdb_api/Makefile
new file mode 100644
index 000000000000..f61c6e597ab0
--- /dev/null
+++ b/www/py-tvdb_api/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: tvdb api
+# Date created: Sun Jul 24 20:23:58 UTC 2011
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= tvdb_api
+PORTVERSION= 1.5
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= API interface to TheTVDB.com
+
+LICENSE= GPLv2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= \
+ %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/py-tvdb_api/distinfo b/www/py-tvdb_api/distinfo
new file mode 100644
index 000000000000..5921222e8f0b
--- /dev/null
+++ b/www/py-tvdb_api/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tvdb_api-1.5.tar.gz) = 5953c65caed5e7a8df65d3123375e798f4a55b2fed535f2a1451afe39861c4ba
+SIZE (tvdb_api-1.5.tar.gz) = 13755
diff --git a/www/py-tvdb_api/pkg-descr b/www/py-tvdb_api/pkg-descr
new file mode 100644
index 000000000000..7615ae76f2be
--- /dev/null
+++ b/www/py-tvdb_api/pkg-descr
@@ -0,0 +1,3 @@
+An easy to use API interface to TheTVDB.com.
+
+WWW: http://pypi.python.org/pypi/tvdb_api/