aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-21 15:28:50 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-21 15:28:50 +0800
commit96715fdb933d16c3f7fcb6f7ec75a7fab6a2fbf5 (patch)
treefa88c47d2400a60888354b4fcd36afa26060c2e0 /www
parent201f71627e75d788811ecdab46fd51664547f5a6 (diff)
downloadfreebsd-ports-gnome-96715fdb933d16c3f7fcb6f7ec75a7fab6a2fbf5.tar.gz
freebsd-ports-gnome-96715fdb933d16c3f7fcb6f7ec75a7fab6a2fbf5.tar.zst
freebsd-ports-gnome-96715fdb933d16c3f7fcb6f7ec75a7fab6a2fbf5.zip
Add nautilus-gtkhtml 0.3.2, a simple NautilusView component for
displaying html files in Nautilus.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/nautilus-gtkhtml/Makefile38
-rw-r--r--www/nautilus-gtkhtml/distinfo1
-rw-r--r--www/nautilus-gtkhtml/files/patch-configure13
-rw-r--r--www/nautilus-gtkhtml/pkg-comment1
-rw-r--r--www/nautilus-gtkhtml/pkg-descr4
-rw-r--r--www/nautilus-gtkhtml/pkg-plist22
7 files changed, 80 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0ea950d50c03..dda2faa24cec 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -198,6 +198,7 @@
SUBDIR += mozilla
SUBDIR += mozilla-embedded
SUBDIR += mozilla-headers
+ SUBDIR += nautilus-gtkhtml
SUBDIR += neon
SUBDIR += neowebscript
SUBDIR += netraider
diff --git a/www/nautilus-gtkhtml/Makefile b/www/nautilus-gtkhtml/Makefile
new file mode 100644
index 000000000000..141b881368f5
--- /dev/null
+++ b/www/nautilus-gtkhtml/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: nautilus-gtkhtml
+# Date created: 21 May 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nautilus-gtkhtml
+PORTVERSION= 0.3.2
+CATEGORIES= www gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtkhtml-2.0:${PORTSDIR}/www/libgtkhtml \
+ nautilus.2:${PORTSDIR}/x11-fm/nautilus2
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/www/nautilus-gtkhtml/distinfo b/www/nautilus-gtkhtml/distinfo
new file mode 100644
index 000000000000..390e96eba117
--- /dev/null
+++ b/www/nautilus-gtkhtml/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/nautilus-gtkhtml-0.3.2.tar.bz2) = 5cf8cf3cc261afd1ef486bd1126f7f9e
diff --git a/www/nautilus-gtkhtml/files/patch-configure b/www/nautilus-gtkhtml/files/patch-configure
new file mode 100644
index 000000000000..65ce6b225d68
--- /dev/null
+++ b/www/nautilus-gtkhtml/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD: /tmp/pcvs/ports/www/nautilus-gtkhtml/files/Attic/patch-configure,v 1.1 2002-05-21 07:28:50 sobomax Exp $
+
+--- configure.orig Mon May 20 15:11:25 2002
++++ configure Mon May 20 15:12:24 2002
+@@ -7374,6 +7374,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/www/nautilus-gtkhtml/pkg-comment b/www/nautilus-gtkhtml/pkg-comment
new file mode 100644
index 000000000000..1969d3f4ba39
--- /dev/null
+++ b/www/nautilus-gtkhtml/pkg-comment
@@ -0,0 +1 @@
+A simple NautilusView component for displaying html files in Nautilus
diff --git a/www/nautilus-gtkhtml/pkg-descr b/www/nautilus-gtkhtml/pkg-descr
new file mode 100644
index 000000000000..8bd6eb334a2d
--- /dev/null
+++ b/www/nautilus-gtkhtml/pkg-descr
@@ -0,0 +1,4 @@
+This is a simple NautilusView component which embeds a GtkHTML2 widget,
+used to display HTML files.
+
+WWW: http://www.gnome.org/
diff --git a/www/nautilus-gtkhtml/pkg-plist b/www/nautilus-gtkhtml/pkg-plist
new file mode 100644
index 000000000000..b5206a633cde
--- /dev/null
+++ b/www/nautilus-gtkhtml/pkg-plist
@@ -0,0 +1,22 @@
+bin/nautilus-gtkhtml-view
+libdata/bonobo/servers/Nautilus_View_gtkhtml.server
+share/locale/az/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/de/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/es/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/fi/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/fr/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/ja/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/ko/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/ms/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/no/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/pl/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/pt/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/ru/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/sk/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/sl/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/sv/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/tr/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/vi/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/wa/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/zh_CN/LC_MESSAGES/nautilus-gtkhtml.mo
+share/locale/zh_TW/LC_MESSAGES/nautilus-gtkhtml.mo