aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-03-18 15:33:59 +0800
committerclsung <clsung@FreeBSD.org>2011-03-18 15:33:59 +0800
commit96f467212d21c94f26a5ae5e17f014f656a6a761 (patch)
treea2f106fa1d29612e1b4d499d6808e23b728c62cd /www
parent8a4eb7ddcfe673c3f29867ab4f9e3442889a09bd (diff)
downloadfreebsd-ports-gnome-96f467212d21c94f26a5ae5e17f014f656a6a761.tar.gz
freebsd-ports-gnome-96f467212d21c94f26a5ae5e17f014f656a6a761.tar.zst
freebsd-ports-gnome-96f467212d21c94f26a5ae5e17f014f656a6a761.zip
Cuba is a microframework for web development originally
inspired by Rum, a tiny but powerful mapper for Rack applications. It integrates many templates via Tilt, and testing via Cutest and Capybara. WWW: http://github.com/soveran/cuba
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-cuba/Makefile22
-rw-r--r--www/rubygem-cuba/distinfo2
-rw-r--r--www/rubygem-cuba/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a576ce499d77..0d1dded0522d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1602,6 +1602,7 @@
SUBDIR += rubygem-anemone
SUBDIR += rubygem-bluecloth
SUBDIR += rubygem-cgi_multipart_eof_fix
+ SUBDIR += rubygem-cuba
SUBDIR += rubygem-davclient
SUBDIR += rubygem-domainatrix
SUBDIR += rubygem-emk-sinatra-url-for
diff --git a/www/rubygem-cuba/Makefile b/www/rubygem-cuba/Makefile
new file mode 100644
index 000000000000..154d35e269cb
--- /dev/null
+++ b/www/rubygem-cuba/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: cuba
+# Date created: 18 March 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= cuba
+PORTVERSION= 2.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Cuba is a microframework for web applications
+
+RUN_DEPENDS= rubygem-rack>=1.2:${PORTSDIR}/www/rubygem-rack \
+ rubygem-tilt>=1.2:${PORTSDIR}/devel/rubygem-tilt
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-cuba/distinfo b/www/rubygem-cuba/distinfo
new file mode 100644
index 000000000000..bed3b34db4d4
--- /dev/null
+++ b/www/rubygem-cuba/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/cuba-2.0.0.gem) = 2800cf3224104f6509da4ccec1840fe0a0c84df271476a2ba60b444ac4135f81
+SIZE (rubygem/cuba-2.0.0.gem) = 11264
diff --git a/www/rubygem-cuba/pkg-descr b/www/rubygem-cuba/pkg-descr
new file mode 100644
index 000000000000..b7f9102715c2
--- /dev/null
+++ b/www/rubygem-cuba/pkg-descr
@@ -0,0 +1,7 @@
+Cuba is a microframework for web development originally
+inspired by Rum, a tiny but powerful mapper for Rack applications.
+
+It integrates many templates via Tilt, and testing via
+Cutest and Capybara.
+
+WWW: http://github.com/soveran/cuba