aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-01 23:50:56 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-01 23:50:56 +0800
commit9f00bcd40fc9fa2e2d6f499f90dd40fd29ee6946 (patch)
tree7df6ab7777080086c70bc75d93c63cdd28f0e0c4 /www
parent5b57624948d457aa91a540313787eaaec3546099 (diff)
downloadfreebsd-ports-gnome-9f00bcd40fc9fa2e2d6f499f90dd40fd29ee6946.tar.gz
freebsd-ports-gnome-9f00bcd40fc9fa2e2d6f499f90dd40fd29ee6946.tar.zst
freebsd-ports-gnome-9f00bcd40fc9fa2e2d6f499f90dd40fd29ee6946.zip
gecko: temporarily hide DTRACE option on aarch64
PR: 214556
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/Makefile.options3
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/seamonkey/Makefile2
5 files changed, 3 insertions, 8 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index cd0803fbcbc4..0d6d319757fd 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -42,8 +42,6 @@ MOZILLA_NAME= Firefox
USE_GL= gl
USES= tar:xz
-BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
-
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index d1b4de791e00..5806c3155f3c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -40,8 +40,6 @@ MOZILLA_NAME= Firefox
USE_GL= gl
USES= tar:xz
-BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
-
FIREFOX_ICON= ${MOZILLA}.png
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/browser/chrome/icons/default/default48.png
MOZ_OPTIONS= --enable-application=browser \
diff --git a/www/firefox/Makefile.options b/www/firefox/Makefile.options
index 7e0813347696..ca26bd04b632 100644
--- a/www/firefox/Makefile.options
+++ b/www/firefox/Makefile.options
@@ -16,6 +16,9 @@ OPTIONS_MULTI_AUDIO= ALSA PULSEAUDIO
OPTIONS_EXCLUDE+= DTRACE
.endif
+# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
+OPTIONS_EXCLUDE_aarch64= DTRACE
+
# dtrace(1) crashes during build or fails to allocate space for probe
OPTIONS_EXCLUDE_FreeBSD_9= DTRACE
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 049a8e008adb..186f2058622f 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -39,8 +39,6 @@ MAKE_ENV= SKIP_GRE_REGISTRATION=1 mozappdir=${PREFIX}/lib/${MOZILLA}
LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
USE_LDCONFIG= ${PREFIX}/lib/${MOZILLA}
-BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
-
MOZ_OPTIONS?= --enable-application=xulrunner
USE_GECKO= gecko
CPE_PRODUCT= firefox_esr
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 7f7210513d65..90bfa3f4c5c7 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -44,8 +44,6 @@ MOZ_OPTIONS+= --enable-application=suite
USE_MOZILLA= # empty
MOZ_PKGCONFIG_FILES=
-BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
-
OPTIONS_DEFINE= LDAP LIGHTNING RUST
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3