aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-12 10:11:31 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-12 10:11:31 +0800
commita7e8f8c76aa3d551f1561dd1a23ac47677e1d975 (patch)
tree63c237c575100db1bba799026774efbc89332f3f /www
parent5e8813ff6bb53cb9deeb608f6ea52e538edd310b (diff)
downloadfreebsd-ports-gnome-a7e8f8c76aa3d551f1561dd1a23ac47677e1d975.tar.gz
freebsd-ports-gnome-a7e8f8c76aa3d551f1561dd1a23ac47677e1d975.tar.zst
freebsd-ports-gnome-a7e8f8c76aa3d551f1561dd1a23ac47677e1d975.zip
Add a patch to make mod_fastcgi work with Apache 2.2 (missed on last commit)
Convert to USE_APACHE framework. PR: ports/91190 Submitted by: Dominic Mitchell <dom@happygiraffe.net> Approved by: JunSeon Oh <hollywar@mail.holywar.net> (maintainer, timeout 5 weeks)
Diffstat (limited to 'www')
-rw-r--r--www/mod_fastcgi/Makefile1
-rw-r--r--www/mod_fastcgi/files/patch-apache2243
2 files changed, 44 insertions, 0 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index 9dbe870aa2ab..7a29803c0135 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_fastcgi
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.holywar.net/pub/FreeBSD/ \
http://www.fastcgi.com/dist/
diff --git a/www/mod_fastcgi/files/patch-apache22 b/www/mod_fastcgi/files/patch-apache22
new file mode 100644
index 000000000000..ec093988fe0a
--- /dev/null
+++ b/www/mod_fastcgi/files/patch-apache22
@@ -0,0 +1,43 @@
+Originally from
+http://fastcgi.com/archives/fastcgi-developers/2005-December/004060.html
+
+diff -ruN mod_fastcgi-2.4.2/fcgi.h mod_fastcgi-2.4.2-ap22/fcgi.h
+--- fcgi.h 2003-02-04 00:07:37.000000000 +0100
++++ fcgi.h 2005-12-07 21:05:55.000000000 +0100
+@@ -73,6 +73,36 @@
+ #define ap_reset_timeout(a)
+ #define ap_unblock_alarms()
+
++/* starting with apache 2.2 the backward-compatibility defines for
++ * 1.3 APIs are not available anymore. Define them ourselves here.
++ */
++#ifndef ap_copy_table
++
++#define ap_copy_table apr_table_copy
++#define ap_cpystrn apr_cpystrn
++#define ap_destroy_pool apr_pool_destroy
++#define ap_isspace apr_isspace
++#define ap_make_array apr_array_make
++#define ap_make_table apr_table_make
++#define ap_null_cleanup apr_pool_cleanup_null
++#define ap_palloc apr_palloc
++#define ap_pcalloc apr_pcalloc
++#define ap_psprintf apr_psprintf
++#define ap_pstrcat apr_pstrcat
++#define ap_pstrdup apr_pstrdup
++#define ap_pstrndup apr_pstrndup
++#define ap_push_array apr_array_push
++#define ap_register_cleanup apr_pool_cleanup_register
++#define ap_snprintf apr_snprintf
++#define ap_table_add apr_table_add
++#define ap_table_do apr_table_do
++#define ap_table_get apr_table_get
++#define ap_table_set apr_table_set
++#define ap_table_setn apr_table_setn
++#define ap_table_unset apr_table_unset
++
++#endif /* defined(ap_copy_table) */
++
+ #if (defined(HAVE_WRITEV) && !HAVE_WRITEV && !defined(NO_WRITEV)) || defined WIN32
+ #define NO_WRITEV
+ #endif