aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2007-03-11 01:04:08 +0800
committerdinoex <dinoex@FreeBSD.org>2007-03-11 01:04:08 +0800
commitb42927f689540df2f0f24c1292cd6558d0513432 (patch)
tree6400b472b3c60f56c8e6dfcd837ae734d8684404 /www
parentced701182f8c0dc2e64efdb5ed4c9a6f67b6c37a (diff)
downloadfreebsd-ports-gnome-b42927f689540df2f0f24c1292cd6558d0513432.tar.gz
freebsd-ports-gnome-b42927f689540df2f0f24c1292cd6558d0513432.tar.zst
freebsd-ports-gnome-b42927f689540df2f0f24c1292cd6558d0513432.zip
- fix unescape bug for default
Submitted by: Andrey Chernov
Diffstat (limited to 'www')
-rw-r--r--www/webalizer/Makefile2
-rw-r--r--www/webalizer/files/patch-unescape11
-rw-r--r--www/webalizer/files/webalizer-a-urasim_2.patch9
3 files changed, 12 insertions, 10 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 769b5ae7ff6a..f48d13307ddc 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webalizer
PORTVERSION= 2.1.10
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES+= www
MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/:main \
ftp://ftp.dinoex.de/pub/FreeBSD/distfiles/:main \
diff --git a/www/webalizer/files/patch-unescape b/www/webalizer/files/patch-unescape
new file mode 100644
index 000000000000..f14c9b37871f
--- /dev/null
+++ b/www/webalizer/files/patch-unescape
@@ -0,0 +1,11 @@
+--- webalizer.c.a-urasim Wed Apr 17 07:11:31 2002
++++ webalizer.c Tue Dec 23 23:26:23 2003
+@@ -1783,7 +1809,7 @@
+ if (*cp1) *cp2=from_hex(*cp1++)*16; /* convert hex to an ascii */
+ if (*cp1) *cp2+=from_hex(*cp1); /* (hopefully) character */
+ if ((*cp2<32)||(*cp2==127)) *cp2='_'; /* make '_' if its bad */
+- if (*cp1) cp2++; cp1++;
++ if (*cp1){ cp2++; cp1++;} /* bug? */
+ }
+ else *cp2++='%';
+ }
diff --git a/www/webalizer/files/webalizer-a-urasim_2.patch b/www/webalizer/files/webalizer-a-urasim_2.patch
index 9195ab73c0b9..42d49acc14d0 100644
--- a/www/webalizer/files/webalizer-a-urasim_2.patch
+++ b/www/webalizer/files/webalizer-a-urasim_2.patch
@@ -61,15 +61,6 @@
while (*cp1)
{
if (*cp1=='%') /* Found an escape? */
-@@ -1783,7 +1809,7 @@
- if (*cp1) *cp2=from_hex(*cp1++)*16; /* convert hex to an ascii */
- if (*cp1) *cp2+=from_hex(*cp1); /* (hopefully) character */
- if ((*cp2<32)||(*cp2==127)) *cp2='_'; /* make '_' if its bad */
-- if (*cp1) cp2++; cp1++;
-+ if (*cp1){ cp2++; cp1++;} /* bug? */
- }
- else *cp2++='%';
- }
@@ -1793,6 +1819,116 @@
return str; /* return the string */
}