aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-07-02 18:31:13 +0800
committerosa <osa@FreeBSD.org>2009-07-02 18:31:13 +0800
commitd1dfae0c3c9b28d27ee79ebad84b4f46ab130ede (patch)
tree1973e63661c1c467c702686e8874305353789853 /www
parent7a24c6ed68259be83272089681ac77995a061760 (diff)
downloadfreebsd-ports-gnome-d1dfae0c3c9b28d27ee79ebad84b4f46ab130ede.tar.gz
freebsd-ports-gnome-d1dfae0c3c9b28d27ee79ebad84b4f46ab130ede.tar.zst
freebsd-ports-gnome-d1dfae0c3c9b28d27ee79ebad84b4f46ab130ede.zip
Default stop signal is SIGTERM, the quick shutdown. Also nginx
understands QUIT signal for graceful (gradual) stop. Add gracefulstop extra command accordingly for stable and devel versions. Bump PORTREVISIONs. PR: ports/136232 (partialy)
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile1
-rw-r--r--www/nginx-devel/files/nginx.sh.in10
-rw-r--r--www/nginx/Makefile1
-rw-r--r--www/nginx/files/nginx.sh.in10
4 files changed, 20 insertions, 2 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index e1ef63359e7c..834b85ab5a42 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 0.8.4
+PORTREIVION= 1
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
diff --git a/www/nginx-devel/files/nginx.sh.in b/www/nginx-devel/files/nginx.sh.in
index b87ef0a8b295..b8e8e79c82f4 100644
--- a/www/nginx-devel/files/nginx.sh.in
+++ b/www/nginx-devel/files/nginx.sh.in
@@ -28,6 +28,7 @@ start_precmd="nginx_precmd"
restart_precmd="nginx_checkconfig"
reload_precmd="nginx_checkconfig"
configtest_cmd="nginx_checkconfig"
+gracefulstop_cmd="nginx_gracefulstop"
upgrade_precmd="nginx_checkconfig"
upgrade_cmd="nginx_upgrade"
command="%%PREFIX%%/sbin/nginx"
@@ -83,6 +84,13 @@ nginx_checkconfig()
eval ${command} ${nginx_flags} -t
}
+nginx_gracefulstop()
+{
+ echo "Performing a graceful stop:"
+ sig_stop="QUIT"
+ run_rc_command ${rc_prefix}stop $rc_extra_args || return 1
+}
+
nginx_upgrade()
{
echo "Upgrading nginx binary:"
@@ -112,5 +120,5 @@ nginx_precmd()
fi
}
-extra_commands="reload configtest upgrade"
+extra_commands="reload configtest upgrade gracefulstop"
run_rc_command "$1"
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 840038738294..58ae03457316 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 0.7.61
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
diff --git a/www/nginx/files/nginx.sh.in b/www/nginx/files/nginx.sh.in
index b87ef0a8b295..b8e8e79c82f4 100644
--- a/www/nginx/files/nginx.sh.in
+++ b/www/nginx/files/nginx.sh.in
@@ -28,6 +28,7 @@ start_precmd="nginx_precmd"
restart_precmd="nginx_checkconfig"
reload_precmd="nginx_checkconfig"
configtest_cmd="nginx_checkconfig"
+gracefulstop_cmd="nginx_gracefulstop"
upgrade_precmd="nginx_checkconfig"
upgrade_cmd="nginx_upgrade"
command="%%PREFIX%%/sbin/nginx"
@@ -83,6 +84,13 @@ nginx_checkconfig()
eval ${command} ${nginx_flags} -t
}
+nginx_gracefulstop()
+{
+ echo "Performing a graceful stop:"
+ sig_stop="QUIT"
+ run_rc_command ${rc_prefix}stop $rc_extra_args || return 1
+}
+
nginx_upgrade()
{
echo "Upgrading nginx binary:"
@@ -112,5 +120,5 @@ nginx_precmd()
fi
}
-extra_commands="reload configtest upgrade"
+extra_commands="reload configtest upgrade gracefulstop"
run_rc_command "$1"