aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committertijl <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commitd7b51d6e3b9874fae397ddfa8717c3be71d84edb (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /www
parent2739bac9ff93a8cdeb834d5da5f0c2720bad7903 (diff)
downloadfreebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.gz
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.tar.zst
freebsd-ports-gnome-d7b51d6e3b9874fae397ddfa8717c3be71d84edb.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'www')
-rw-r--r--www/jericho-html/Makefile2
-rw-r--r--www/tdom/Makefile1
-rw-r--r--www/tinymce/Makefile2
-rw-r--r--www/trac-tags/Makefile1
-rw-r--r--www/trac-wysiwyg/Makefile1
-rw-r--r--www/websh/Makefile2
-rw-r--r--www/zenphoto/Makefile2
7 files changed, 4 insertions, 7 deletions
diff --git a/www/jericho-html/Makefile b/www/jericho-html/Makefile
index e79f3b58d5c4..e101e826f78d 100644
--- a/www/jericho-html/Makefile
+++ b/www/jericho-html/Makefile
@@ -21,7 +21,7 @@ PLIST_FILES+= %%JAVAJARDIR%%/${PORTNAME}.jar
do-build:
(cd ${WRKSRC} && ${RM} -r classes/* && ${SETENV} \
- LANG=en_US.ISO8859-1 ${JAVAC} \
+ LANG=en_US.ISO8859-1 LC_ALL=en_US.ISO8859-1 ${JAVAC} \
-classpath ${INTERFACES:S, ,,g} \
-d classes src/java/net/htmlparser/jericho/*.java \
src/java/net/htmlparser/jericho/nodoc/*.java)
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index b09008282e8f..d6fa20a995bc 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -20,7 +20,6 @@ USE_GITHUB= yes
CONFIGURE_ARGS= --enable-threads --disable-tdomalloc
TEST_TARGET= test
-TEST_ENV= LANG=C
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/www/tinymce/Makefile b/www/tinymce/Makefile
index 9da729d5412d..8c6603861dec 100644
--- a/www/tinymce/Makefile
+++ b/www/tinymce/Makefile
@@ -34,7 +34,7 @@ MS_PLIST= ${WRKDIR}/.ms-pkg-plist
genplist: do-clean extract
@${ECHO} "@owner www" > ${MS_PLIST}
@${ECHO} "@group www" >> ${MS_PLIST}
- @cd ${WRKSRC}/ && ${FIND} -s * -type f | env LC_ALL=C ${SED} 's|^|%%WWWDIR%%/|' >> ${MS_PLIST}
+ @cd ${WRKSRC}/ && ${FIND} -s * -type f | ${SED} 's|^|%%WWWDIR%%/|' >> ${MS_PLIST}
@${ECHO} "@owner" >> ${MS_PLIST}
@${ECHO} "@group" >> ${MS_PLIST}
@${INSTALL} -m 600 ${MS_PLIST} ${PLIST}
diff --git a/www/trac-tags/Makefile b/www/trac-tags/Makefile
index 22ab5947b921..e0667e81440e 100644
--- a/www/trac-tags/Makefile
+++ b/www/trac-tags/Makefile
@@ -22,7 +22,6 @@ NO_ARCH= yes
.if !defined(SVN_REV)
.if defined(BOOTSTRAP)
-LANG= "C"
SVN_REV!= svn info http://trac-hacks.org/svn/tagsplugin/trunk/ | ${GREP} Revision | cut -d' ' -f2
.else
.include "Makefile.svn_rev"
diff --git a/www/trac-wysiwyg/Makefile b/www/trac-wysiwyg/Makefile
index 30430cd9afcb..9acacf11c013 100644
--- a/www/trac-wysiwyg/Makefile
+++ b/www/trac-wysiwyg/Makefile
@@ -24,7 +24,6 @@ NO_ARCH= yes
.if !defined(SVN_REV)
.if defined(BOOTSTRAP)
SVN_URL= http://trac-hacks.org/svn/tracwysiwygplugin/0.12/
-LANG= "C"
SVN_REV!= svn info ${SVN_URL} | ${GREP} Revision | cut -d' ' -f2
.else
.include "Makefile.svn_rev"
diff --git a/www/websh/Makefile b/www/websh/Makefile
index 01c1b7ee4a15..e1f7c7f3a684 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -53,7 +53,7 @@ post-configure:
-e 's,-DPACKAGE_[^=]*=."[^"]*",,g' ${WRKSRC}/Makefile
post-build test:
- ${SETENV} LANG=C HOME=${WRKDIR} ${MAKE_CMD} -C ${WRKSRC} test | ${AWK} '\
+ ${SETENV} HOME=${WRKDIR} ${MAKE_CMD} -C ${WRKSRC} test | ${AWK} '\
/Failed/ && $$NF {failed=1} \
END {exit failed} \
{print}'
diff --git a/www/zenphoto/Makefile b/www/zenphoto/Makefile
index ab7374454d13..5cb651d1973e 100644
--- a/www/zenphoto/Makefile
+++ b/www/zenphoto/Makefile
@@ -40,7 +40,7 @@ MS_PLIST= ${WRKDIR}/.ms-pkg-plist
genplist: do-clean extract
${ECHO_CMD} '@owner www' > ${MS_PLIST}
${ECHO_CMD} '@group www' >> ${MS_PLIST}
- cd ${WRKSRC}/ && ${FIND} * -type f | ${SETENV} LC_ALL=C ${SORT} | ${SED} 's|^|%%WWWDIR%%/|' >> ${MS_PLIST}
+ cd ${WRKSRC}/ && ${FIND} * -type f | ${SORT} | ${SED} 's|^|%%WWWDIR%%/|' >> ${MS_PLIST}
.for dir in ${MS_DIR}
${ECHO_CMD} '@dir %%WWWDIR%%/${dir}' >> ${MS_PLIST}
.endfor