aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-03-22 05:10:29 +0800
committersat <sat@FreeBSD.org>2007-03-22 05:10:29 +0800
commit0b29a421c8400e92cc5a8951898dd75ca11dbca6 (patch)
tree966255648d4b337ed048bad521f99a694704ed09 /www
parent98f6eee5ea78015065fb5ea5244cbc046803cb72 (diff)
downloadfreebsd-ports-gnome-0b29a421c8400e92cc5a8951898dd75ca11dbca6.tar.gz
freebsd-ports-gnome-0b29a421c8400e92cc5a8951898dd75ca11dbca6.tar.zst
freebsd-ports-gnome-0b29a421c8400e92cc5a8951898dd75ca11dbca6.zip
Add port www/horde-ansel - a gallery application
PR: ports/110551 Submitted by: Beech Rintoul <beech@alaskaparadise.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/horde-ansel/Makefile82
-rw-r--r--www/horde-ansel/distinfo3
-rw-r--r--www/horde-ansel/files/httpd.conf.ansel31
-rw-r--r--www/horde-ansel/files/pkg-deinstall.in24
-rw-r--r--www/horde-ansel/files/pkg-install.in24
-rw-r--r--www/horde-ansel/files/pkg-message.in11
-rw-r--r--www/horde-ansel/pkg-descr3
-rw-r--r--www/horde-ansel/pkg-plist170
9 files changed, 349 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 798e4487eb78..004b648327e0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -188,6 +188,7 @@
SUBDIR += helixplugin
SUBDIR += hiawatha
SUBDIR += hinventory-client
+ SUBDIR += horde-ansel
SUBDIR += horde-base
SUBDIR += horde-meta
SUBDIR += horde-passwd
diff --git a/www/horde-ansel/Makefile b/www/horde-ansel/Makefile
new file mode 100644
index 000000000000..2ffbae8bdaeb
--- /dev/null
+++ b/www/horde-ansel/Makefile
@@ -0,0 +1,82 @@
+# Ports collection makefile for: ansel
+# Date created: Mon Mar 19, 2007
+# Whom: Beech Rintoul <beech@alaskaparadise.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ansel
+PORTVERSION= 0.1.b20070319
+CATEGORIES= www
+MASTER_SITES= CENKES http://freebsd.alaskaparadise.com/source/
+PKGNAMEPREFIX= horde-
+
+MAINTAINER= beech@alaskaparadise.com
+COMMENT= Image gallery
+
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
+
+NO_BUILD= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
+USE_GETTEXT= yes
+REINPLACE_ARGS= -i ""
+
+PORTDOCS= CHANGES CREDITS TODO README
+CONFFILE= conf.xml
+SUB_DIRS= config gallery img js lib locale po scripts templates themes
+
+LHORDEDIR?= www/horde
+LANSDIR= ${LHORDEDIR}/ansel
+PEARDIR?= ${LOCALBASE}/share/pear
+
+PLIST_SUB= ANSDIR=${LANSDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
+SUB_LIST= ANSDIR=${ANSDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
+
+ANSDIR= ${PREFIX}/${LANSDIR}
+CONFDIR= ${ANSDIR}/config
+
+HOSTNAME?= `/bin/hostname`
+SERVOS?= ${OPSYS}-${OSREL}
+
+PORTREV_H?= ${LOCALBASE}/include/c-client/portrevision.h
+
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
+.else
+HORDE_INC= ${LOCALBASE}/etc/horde/
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
+
+pre-configure:
+ @${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
+ @${SED} -e "s:/home/httpd/html/horde/ansel:${ANSDIR}:" \
+ ${FILESDIR}/httpd.conf.ansel > ${WRKDIR}/httpd-ansel.conf
+
+do-install:
+ @${INSTALL} -d ${ANSDIR}/
+ @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${ANSDIR}/
+ @${CP} -p ${WRKSRC}/*.php ${ANSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
+ @${INSTALL_DATA} ${WRKDIR}/httpd-ansel.conf ${HORDE_INC}/
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${ANSDIR}/
+ @${CHMOD} -R o-rwx ${CONFDIR}/
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>
diff --git a/www/horde-ansel/distinfo b/www/horde-ansel/distinfo
new file mode 100644
index 000000000000..9fdc21870e51
--- /dev/null
+++ b/www/horde-ansel/distinfo
@@ -0,0 +1,3 @@
+MD5 (ansel-0.1.b20070319.tar.gz) = bbd5c8c5066f0003877c145057673b51
+SHA256 (ansel-0.1.b20070319.tar.gz) = 5cf6e82b693828d89fe5645c4938b03d5109230cda38c85ae3bd476c39d3f2a5
+SIZE (ansel-0.1.b20070319.tar.gz) = 645199
diff --git a/www/horde-ansel/files/httpd.conf.ansel b/www/horde-ansel/files/httpd.conf.ansel
new file mode 100644
index 000000000000..3fe09b370849
--- /dev/null
+++ b/www/horde-ansel/files/httpd.conf.ansel
@@ -0,0 +1,31 @@
+# This is included in Apache's httpd.conf for ansel
+#
+# For security, don't serve pages from the ansel configuration and
+# library directories.
+#
+<Directory "/home/httpd/html/horde/ansel/config">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/ansel/lib">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/ansel/locale">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/ansel/po">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/ansel/scripts">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/ansel/templates">
+ order deny,allow
+ deny from all
+</Directory>
+# End of ansel configuration ================
+
diff --git a/www/horde-ansel/files/pkg-deinstall.in b/www/horde-ansel/files/pkg-deinstall.in
new file mode 100644
index 000000000000..85a5073df124
--- /dev/null
+++ b/www/horde-ansel/files/pkg-deinstall.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup ansel config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls %%ANSDIR%%/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, delete it
+ rm -f $cf
+ ;;
+ 1) # config file has been updated, leave it alone
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi
diff --git a/www/horde-ansel/files/pkg-install.in b/www/horde-ansel/files/pkg-install.in
new file mode 100644
index 000000000000..1a51120f18b0
--- /dev/null
+++ b/www/horde-ansel/files/pkg-install.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+
+ POST-INSTALL)
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ # Copy over sample config files unless they already exist
+
+ for cf in `ls %%ANSDIR%%/config/*.dist | sed -e 's/\.dist//g'`; do
+ if [ ! -f $cf ]; then
+ cp -p $cf.dist $cf
+ fi
+ done
+ fi
+ ;;
+esac
diff --git a/www/horde-ansel/files/pkg-message.in b/www/horde-ansel/files/pkg-message.in
new file mode 100644
index 000000000000..df64a65b3087
--- /dev/null
+++ b/www/horde-ansel/files/pkg-message.in
@@ -0,0 +1,11 @@
+************************************************************************
+ANSEL has been installed in %%ANSDIR%% with your blank
+configuration files.
+
+Ansel must be configured; if not, see `pkg_info -D -x horde'.
+
+Finally, you must login to Horde as a Horde Administrator to finish the
+configuration.
+
+To protect your configuration files, you have to restart Apache.
+************************************************************************
diff --git a/www/horde-ansel/pkg-descr b/www/horde-ansel/pkg-descr
new file mode 100644
index 000000000000..9e41fc9c2869
--- /dev/null
+++ b/www/horde-ansel/pkg-descr
@@ -0,0 +1,3 @@
+Ansel is a Horde-based image gallery program
+
+WWW: http://cvs.horde.org/ansel/
diff --git a/www/horde-ansel/pkg-plist b/www/horde-ansel/pkg-plist
new file mode 100644
index 000000000000..8c821e671236
--- /dev/null
+++ b/www/horde-ansel/pkg-plist
@@ -0,0 +1,170 @@
+%%ANSDIR%%/config/.cvsignore
+%%ANSDIR%%/config/conf.xml
+%%ANSDIR%%/config/prefs.php.dist
+%%ANSDIR%%/gallery.php
+%%ANSDIR%%/gallery/captions.php
+%%ANSDIR%%/gallery/delete.php
+%%ANSDIR%%/gallery/index.php
+%%ANSDIR%%/gallery/sort.php
+%%ANSDIR%%/group.php
+%%ANSDIR%%/image.php
+%%ANSDIR%%/img/download.php
+%%ANSDIR%%/img/ecard.php
+%%ANSDIR%%/img/full.php
+%%ANSDIR%%/img/index.php
+%%ANSDIR%%/img/mini.php
+%%ANSDIR%%/img/screen.php
+%%ANSDIR%%/img/thumb.php
+%%ANSDIR%%/img/upload.php
+%%ANSDIR%%/index.php
+%%ANSDIR%%/js/controls.js
+%%ANSDIR%%/js/dragdrop.js
+%%ANSDIR%%/js/effects.js
+%%ANSDIR%%/js/scriptaculous.js
+%%ANSDIR%%/js/slideshow.js
+%%ANSDIR%%/js/src/controls.js
+%%ANSDIR%%/js/src/dragdrop.js
+%%ANSDIR%%/js/src/effects.js
+%%ANSDIR%%/js/src/scriptaculous.js
+%%ANSDIR%%/js/src/slideshow.js
+%%ANSDIR%%/lib/Ansel.php
+%%ANSDIR%%/lib/Block/gallery.php
+%%ANSDIR%%/lib/Block/random_gallery.php
+%%ANSDIR%%/lib/Block/random_photo.php
+%%ANSDIR%%/lib/Exif.php
+%%ANSDIR%%/lib/Exif/canon.php
+%%ANSDIR%%/lib/Exif/fujifilm.php
+%%ANSDIR%%/lib/Exif/gps.php
+%%ANSDIR%%/lib/Exif/nikon.php
+%%ANSDIR%%/lib/Exif/olympus.php
+%%ANSDIR%%/lib/Exif/sanyo.php
+%%ANSDIR%%/lib/Forms/Ecard.php
+%%ANSDIR%%/lib/Forms/Upload.php
+%%ANSDIR%%/lib/Views/Abstract.php
+%%ANSDIR%%/lib/Views/Gallery.php
+%%ANSDIR%%/lib/Views/Image.php
+%%ANSDIR%%/lib/XPPublisher.php
+%%ANSDIR%%/lib/api.php
+%%ANSDIR%%/lib/base.php
+%%ANSDIR%%/lib/version.php
+%%ANSDIR%%/list.php
+%%ANSDIR%%/locale/de_DE/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/en_US/help.xml
+%%ANSDIR%%/locale/es_ES/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/fi_FI/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/fi_FI/help.xml
+%%ANSDIR%%/locale/it_IT/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/lt_LT/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/sl_SI/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/sv_SE/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/locale/zh_TW/LC_MESSAGES/ansel.mo
+%%ANSDIR%%/perms.php
+%%ANSDIR%%/po/.cvsignore
+%%ANSDIR%%/po/README
+%%ANSDIR%%/po/ansel.pot
+%%ANSDIR%%/po/de_DE.po
+%%ANSDIR%%/po/es_ES.po
+%%ANSDIR%%/po/fi_FI.po
+%%ANSDIR%%/po/it_IT.po
+%%ANSDIR%%/po/lt_LT.po
+%%ANSDIR%%/po/sl_SI.po
+%%ANSDIR%%/po/sv_SE.po
+%%ANSDIR%%/po/zh_TW.po
+%%ANSDIR%%/scripts/.htaccess
+%%ANSDIR%%/scripts/ansel.php
+%%ANSDIR%%/scripts/garbage_collection.php
+%%ANSDIR%%/scripts/recursive_import.php
+%%ANSDIR%%/scripts/sql/ansel.sql
+%%ANSDIR%%/scripts/upgrades/2006-11-27_cleanup.php
+%%ANSDIR%%/scripts/upgrades/2006-11-27_datatree_to_sql_renames.php
+%%ANSDIR%%/scripts/upgrades/2006-11-27_fix_default_images.php
+%%ANSDIR%%/scripts/upgrades/2006-11-27_sql_images.php
+%%ANSDIR%%/templates/captions/captions.inc
+%%ANSDIR%%/templates/common-header.inc
+%%ANSDIR%%/templates/gallery/delete_confirmation.inc
+%%ANSDIR%%/templates/gallery/gallery.inc
+%%ANSDIR%%/templates/group/category.inc
+%%ANSDIR%%/templates/group/footer.inc
+%%ANSDIR%%/templates/group/header.inc
+%%ANSDIR%%/templates/group/owner.inc
+%%ANSDIR%%/templates/group/pager.inc
+%%ANSDIR%%/templates/image/edit_image.inc
+%%ANSDIR%%/templates/image/preview_image.inc
+%%ANSDIR%%/templates/list/filler.inc
+%%ANSDIR%%/templates/list/footer.inc
+%%ANSDIR%%/templates/list/gallery_footers.inc
+%%ANSDIR%%/templates/list/gallery_headers.inc
+%%ANSDIR%%/templates/list/gallery_summaries.inc
+%%ANSDIR%%/templates/list/header.inc
+%%ANSDIR%%/templates/list/images.inc
+%%ANSDIR%%/templates/list/pager.inc
+%%ANSDIR%%/templates/menu.inc
+%%ANSDIR%%/templates/view/gallery.inc
+%%ANSDIR%%/templates/view/image.inc
+%%ANSDIR%%/templates/view/subgallery_header.inc
+%%ANSDIR%%/templates/xppublish/javascript.inc
+%%ANSDIR%%/templates/xppublish/list.inc
+%%ANSDIR%%/templates/xppublish/login.inc
+%%ANSDIR%%/templates/xppublish/new.inc
+%%ANSDIR%%/test.php
+%%ANSDIR%%/themes/graphics/add.png
+%%ANSDIR%%/themes/graphics/ansel.png
+%%ANSDIR%%/themes/graphics/favicon.ico
+%%ANSDIR%%/themes/graphics/mini-error.png
+%%ANSDIR%%/themes/graphics/mygalleries.png
+%%ANSDIR%%/themes/graphics/mypics.png
+%%ANSDIR%%/themes/graphics/resize.png
+%%ANSDIR%%/themes/graphics/screen-error.png
+%%ANSDIR%%/themes/graphics/slideshow_next.png
+%%ANSDIR%%/themes/graphics/slideshow_pause.png
+%%ANSDIR%%/themes/graphics/slideshow_play.png
+%%ANSDIR%%/themes/graphics/slideshow_prev.png
+%%ANSDIR%%/themes/graphics/text.png
+%%ANSDIR%%/themes/graphics/thumb-error.png
+%%ANSDIR%%/themes/screen.css
+%%ANSDIR%%/view.php
+%%ANSDIR%%/xppublish.php
+%%HORDE_INC%%httpd-ansel.conf
+@dirrm %%ANSDIR%%/themes/graphics
+@dirrm %%ANSDIR%%/themes
+@dirrm %%ANSDIR%%/templates/xppublish
+@dirrm %%ANSDIR%%/templates/view
+@dirrm %%ANSDIR%%/templates/list
+@dirrm %%ANSDIR%%/templates/image
+@dirrm %%ANSDIR%%/templates/group
+@dirrm %%ANSDIR%%/templates/gallery
+@dirrm %%ANSDIR%%/templates/captions
+@dirrm %%ANSDIR%%/templates
+@dirrm %%ANSDIR%%/scripts/upgrades
+@dirrm %%ANSDIR%%/scripts/sql
+@dirrm %%ANSDIR%%/scripts
+@dirrm %%ANSDIR%%/po
+@dirrm %%ANSDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/zh_TW
+@dirrm %%ANSDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/sv_SE
+@dirrm %%ANSDIR%%/locale/sl_SI/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/sl_SI
+@dirrm %%ANSDIR%%/locale/lt_LT/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/lt_LT
+@dirrm %%ANSDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/it_IT
+@dirrm %%ANSDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/fi_FI
+@dirrm %%ANSDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/es_ES
+@dirrm %%ANSDIR%%/locale/en_US
+@dirrm %%ANSDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%ANSDIR%%/locale/de_DE
+@dirrm %%ANSDIR%%/locale
+@dirrm %%ANSDIR%%/lib/Views
+@dirrm %%ANSDIR%%/lib/Forms
+@dirrm %%ANSDIR%%/lib/Exif
+@dirrm %%ANSDIR%%/lib/Block
+@dirrm %%ANSDIR%%/lib
+@dirrm %%ANSDIR%%/js/src
+@dirrm %%ANSDIR%%/js
+@dirrm %%ANSDIR%%/img
+@dirrm %%ANSDIR%%/gallery
+@dirrm %%ANSDIR%%/config
+@dirrm %%ANSDIR%%