aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2003-06-20 18:46:30 +0800
committermatusita <matusita@FreeBSD.org>2003-06-20 18:46:30 +0800
commit13fab32688904402a90e9efda9d8e8f3e6aad671 (patch)
treeaab0d02eac0607ecdc1bd565bff1e9bd23a13864 /www
parentab861a2ed91a9acca13aef2c5984ca53ad630ae0 (diff)
downloadfreebsd-ports-gnome-13fab32688904402a90e9efda9d8e8f3e6aad671.tar.gz
freebsd-ports-gnome-13fab32688904402a90e9efda9d8e8f3e6aad671.tar.zst
freebsd-ports-gnome-13fab32688904402a90e9efda9d8e8f3e6aad671.zip
Use install(1) instead of cp(1), to set file mode (it is unhappy to users
that the config file is read-only). Install sample CSS file to aswiki home directory. Content changed, so bump the revision.
Diffstat (limited to 'www')
-rw-r--r--www/aswiki/Makefile1
-rw-r--r--www/aswiki/files/setup.sh3
2 files changed, 3 insertions, 1 deletions
diff --git a/www/aswiki/Makefile b/www/aswiki/Makefile
index 6c2f82331c9f..c10f5c4aeeb7 100644
--- a/www/aswiki/Makefile
+++ b/www/aswiki/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aswiki
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= www ruby
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/www/aswiki/files/setup.sh b/www/aswiki/files/setup.sh
index ce8f73f62ec9..857d55f14f43 100644
--- a/www/aswiki/files/setup.sh
+++ b/www/aswiki/files/setup.sh
@@ -33,7 +33,7 @@ ask_copy()
ans=YES
fi
if [ $ans = "YES" ]; then
- cp __DATADIR__/$file .
+ install -m 644 __DATADIR__/$file .
else
echo "$file is untouched; you may update with __DATADIR__/$file."
fi
@@ -48,6 +48,7 @@ if ask_noyes "Are you ready?"; then
echo -n "Copying files..."
ask_copy aswiki.conf
ask_copy aswiki.cgi
+ ask_copy default.css
echo "done."
else
echo "Stopped."