aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-06-09 11:45:15 +0800
committerwen <wen@FreeBSD.org>2010-06-09 11:45:15 +0800
commit2cd9af0b933aac76354097be0f83db018609a026 (patch)
tree541b031f0e7e62575f38c79ffb8507730c6acdce /www
parent0adeada0304e7745a98ceba95461ec0cf35492a1 (diff)
downloadfreebsd-ports-gnome-2cd9af0b933aac76354097be0f83db018609a026.tar.gz
freebsd-ports-gnome-2cd9af0b933aac76354097be0f83db018609a026.tar.zst
freebsd-ports-gnome-2cd9af0b933aac76354097be0f83db018609a026.zip
- Add an optional dependency on uWSGI
PR: ports/146867 Submitted by: Daniel Gerzo <danger@freebsd.org> Approved by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/cherokee/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index ad461f7813a0..8c790e472a0b 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -74,8 +74,9 @@ OPTIONS= WWWUSER "Run as www:www user" on \
FFMPEG "FFMpeg Support" off \
NLS "NLS Support" on \
INTPCRE "Use Internal PCRE Library" off \
- ADMIN "Build the Admin Interface" on \
- RRDTOOL "Usage Graphs Support" off
+ ADMIN "Build the Admin Interface" on \
+ RRDTOOL "Usage Graphs Support" off \
+ UWSGI "uWSGI Support" off
.include <bsd.port.options.mk>
@@ -150,6 +151,10 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
RUN_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool
.endif
+.ifdef WITH_UWSGI
+RUN_DEPENDS+= uwsgi:${PORTSDIR}/www/uwsgi
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|@mkdir_p@|${MKDIR} --|g'