aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-13 00:51:59 +0800
committermiwi <miwi@FreeBSD.org>2009-03-13 00:51:59 +0800
commit4a990124a14de06ac447e4a5350ebc4c8ad84ba3 (patch)
tree5b867cc7a5329c8aef3dc34f9069216e43fdeb73 /www
parent559e2f36843bb42a5981a986cb8776e9a9715504 (diff)
downloadfreebsd-ports-gnome-4a990124a14de06ac447e4a5350ebc4c8ad84ba3.tar.gz
freebsd-ports-gnome-4a990124a14de06ac447e4a5350ebc4c8ad84ba3.tar.zst
freebsd-ports-gnome-4a990124a14de06ac447e4a5350ebc4c8ad84ba3.zip
This module aims to smooth out the differences between pastebins, and provides
redundancy: if one site doesn't work, it just tries a different one. WWW: http://search.cpan.org/dist/App-Nopaste PR: ports/132500 Submitted by: bapt <baptiste.daroussin at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-App-Nopaste/Makefile68
-rw-r--r--www/p5-App-Nopaste/distinfo3
-rw-r--r--www/p5-App-Nopaste/pkg-descr4
-rw-r--r--www/p5-App-Nopaste/pkg-plist18
5 files changed, 94 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0131febdd808..2e81c705c70a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -623,6 +623,7 @@
SUBDIR += p5-Apache-Test
SUBDIR += p5-Apache2-Scoreboard
SUBDIR += p5-ApacheBench
+ SUBDIR += p5-App-Nopaste
SUBDIR += p5-AxKit
SUBDIR += p5-AxKit-XSP-Cookie
SUBDIR += p5-AxKit-XSP-ESQL
diff --git a/www/p5-App-Nopaste/Makefile b/www/p5-App-Nopaste/Makefile
new file mode 100644
index 000000000000..5413006a2a92
--- /dev/null
+++ b/www/p5-App-Nopaste/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: p5-App-Nopaste
+# Date created: 2009-03-10
+# Whom: bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-Nopaste
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= Easy access to any pastebin
+
+BUILD_DEPENDS+= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/MooseX/Getopt.pm:${PORTSDIR}/devel/p5-MooseX-Getopt
+
+RUN_DEPENDS+= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/MooseX/Getopt.pm:${PORTSDIR}/devel/p5-MooseX-Getopt
+
+OPTIONS= CLIPBOARD "Support Clipboard" On \
+ PASTEBIN "Support pastebin.com" On \
+ RAFB "Support rafb.net" On \
+ GITHUB "Support github" Off
+
+PERL_CONFIGURE= yes
+
+CONFLICTS= p5-WebService-NoPaste-0*
+
+MAN3= App::Nopaste.3 \
+ App::Nopaste::Command.3 \
+ App::Nopaste::Service.3 \
+ App::Nopaste::Service::Gist.3 \
+ App::Nopaste::Service::Husk.3 \
+ App::Nopaste::Service::Mathbin.3 \
+ App::Nopaste::Service::PastebinCom.3 \
+ App::Nopaste::Service::Pastie.3 \
+ App::Nopaste::Service::Rafb.3 \
+ App::Nopaste::Service::Shadowcat.3 \
+ App::Nopaste::Service::Snitch.3
+
+MAN1= nopaste.1
+
+.include <bsd.port.pre.mk>
+.if defined(WITH_PASTEBIN)
+BUILD_DEPENDS+= ${SITE_PERL}/WWW/Pastebin/PastebinCom/Create.pm:${PORTSDIR}/www/p5-WWW-Pastebin-PastebinCom-Create
+RUN_DEPENDS+= ${SITE_PERL}/WWW/Pastebin/PastebinCom/Create.pm:${PORTSDIR}/www/p5-WWW-Pastebin-PastebinCom-Create
+.endif
+.if defined(WITH_RAFB)
+BUILD_DEPENDS+= ${SITE_PERL}/WWW/Pastebin/RafbNet/Create.pm:${PORTSDIR}/www/p5-WWW-Pastebin-RafbNet-Create
+RUN_DEPENDS+= ${SITE_PERL}/WWW/Pastebin/RafbNet/Create.pm:${PORTSDIR}/www/p5-WWW-Pastebin-RafbNet-Create
+.endif
+.if defined(WITH_CLIPBOARD)
+BUILD_DEPENDS+= ${SITE_PERL}/Clipboard.pm:${PORTSDIR}/x11/p5-Clipboard
+RUN_DEPENDS+= ${SITE_PERL}/Clipboard.pm:${PORTSDIR}/x11/p5-Clipboard
+.endif
+.if defined(WITH_GITHUB)
+BUILD_DEPENDS+= ${SITE_PERL}/Git.pm:${PORTSDIR}/devel/git \
+ ${SITE_PERL}/Config/INI/Reader.pm:${PORTSDIR}/devel/p5-Config-INI
+
+RUN_DEPENDS+= ${SITE_PERL}/Git.pm:${PORTSDIR}/devel/git \
+ ${SITE_PERL}/Config/INI/Reader.pm:${PORTSDIR}/devel/p5-Config-INI
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-App-Nopaste/distinfo b/www/p5-App-Nopaste/distinfo
new file mode 100644
index 000000000000..d83226f74710
--- /dev/null
+++ b/www/p5-App-Nopaste/distinfo
@@ -0,0 +1,3 @@
+MD5 (App-Nopaste-0.10.tar.gz) = 78d560ad4fb67cb8ceb0d84c4de40ed0
+SHA256 (App-Nopaste-0.10.tar.gz) = 47057ad4482cec267443f21e61b0fe387ef5858fe4dd6745726db5d0b163cd4f
+SIZE (App-Nopaste-0.10.tar.gz) = 26323
diff --git a/www/p5-App-Nopaste/pkg-descr b/www/p5-App-Nopaste/pkg-descr
new file mode 100644
index 000000000000..545ccee5ad3a
--- /dev/null
+++ b/www/p5-App-Nopaste/pkg-descr
@@ -0,0 +1,4 @@
+This module aims to smooth out the differences between pastebins, and provides
+redundancy: if one site doesn't work, it just tries a different one.
+
+WWW: http://search.cpan.org/dist/App-Nopaste
diff --git a/www/p5-App-Nopaste/pkg-plist b/www/p5-App-Nopaste/pkg-plist
new file mode 100644
index 000000000000..3548cae9fe49
--- /dev/null
+++ b/www/p5-App-Nopaste/pkg-plist
@@ -0,0 +1,18 @@
+bin/nopaste
+%%SITE_PERL%%/App/Nopaste.pm
+%%SITE_PERL%%/App/Nopaste/Command.pm
+%%SITE_PERL%%/App/Nopaste/Service.pm
+%%SITE_PERL%%/App/Nopaste/Service/Gist.pm
+%%SITE_PERL%%/App/Nopaste/Service/Husk.pm
+%%SITE_PERL%%/App/Nopaste/Service/Mathbin.pm
+%%SITE_PERL%%/App/Nopaste/Service/PastebinCom.pm
+%%SITE_PERL%%/App/Nopaste/Service/Pastie.pm
+%%SITE_PERL%%/App/Nopaste/Service/Rafb.pm
+%%SITE_PERL%%/App/Nopaste/Service/Shadowcat.pm
+%%SITE_PERL%%/App/Nopaste/Service/Snitch.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/Nopaste/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/App/Nopaste
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/App
+@dirrm %%SITE_PERL%%/App/Nopaste/Service
+@dirrm %%SITE_PERL%%/App/Nopaste
+@dirrm %%SITE_PERL%%/App