aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-01 21:03:23 +0800
committerclsung <clsung@FreeBSD.org>2006-08-01 21:03:23 +0800
commit61a0fbcb27c2ce85f5107fda52de5737cfee8bba (patch)
tree2f7893e80203d442cd55a599bb5788f2d2536566 /www
parent6b5d91b6fe7bb72664984117c75e393efaa73a62 (diff)
downloadfreebsd-ports-gnome-61a0fbcb27c2ce85f5107fda52de5737cfee8bba.tar.gz
freebsd-ports-gnome-61a0fbcb27c2ce85f5107fda52de5737cfee8bba.tar.zst
freebsd-ports-gnome-61a0fbcb27c2ce85f5107fda52de5737cfee8bba.zip
- Update to 3.1.5
PR: ports/101164 Submitted by: Gea-Suan Lin <gslin_AT_gslin dot org>
Diffstat (limited to 'www')
-rw-r--r--www/udmsearch/Makefile45
-rw-r--r--www/udmsearch/distinfo6
-rw-r--r--www/udmsearch/files/patch-ab11
-rw-r--r--www/udmsearch/files/patch-configure.in (renamed from www/udmsearch/files/patch-aa)0
-rw-r--r--www/udmsearch/files/patch-sql.c12
-rw-r--r--www/udmsearch/files/patch-src-sql.c11
-rw-r--r--www/udmsearch/pkg-plist177
7 files changed, 136 insertions, 126 deletions
diff --git a/www/udmsearch/Makefile b/www/udmsearch/Makefile
index c32ba4d57a9f..0c7fbd7f39f5 100644
--- a/www/udmsearch/Makefile
+++ b/www/udmsearch/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= udmsearch
-PORTVERSION= 3.0.23
-PORTREVISION= 3
+PORTVERSION= 3.1.5
CATEGORIES= www databases
MASTER_SITES= http://search.mnogo.ru/Download/ \
http://udmsearch.real-time.com/Download/
@@ -15,51 +14,43 @@ MASTER_SITES= http://search.mnogo.ru/Download/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Full featured SQL-based hypertext search engine
-MAN1= indexer.1
-MAN5= indexer.conf.5
+OPTIONS= MSQL "MSQL support" off \
+ MYSQL "MYSQL support" on \
+ PGSQL "PGSQL support" off
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-charset-guesser \
--enable-freebsd-pthreads \
--sysconfdir=${PREFIX}/etc/udmsearch \
--localstatedir=/var/udmsearch
-.if defined(WITH_PGSQL)
-USE_PGSQL= YES
-CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql
+MAN1= indexer.1
+MAN5= indexer.conf.5
+
+.include <bsd.port.pre.mk>
-.elif defined(WITH_MSQL)
+.if defined(WITH_MSQL)
BUILD_DEPENDS= ${PREFIX}/lib/libmsql.a:${PORTSDIR}/databases/msql
CONFIGURE_ARGS+= --with-msql=${LOCALBASE}
+.endif
-.else
-# default to mysql
+.if !defined(WITHOUT_MYSQL)
USE_MYSQL= YES
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-
-pre-everything::
-.if !defined(WITH_MYSQL)
- @${ECHO_MSG}
- @${ECHO_MSG} "Defaulting to udmsearch with mysql support."
- @${ECHO_MSG}
- @${ECHO_MSG} "You may alternately build udmsearch with either msql or"
- @${ECHO_MSG} "postgresql support by invoking make with WITH_MSQL=yes or"
- @${ECHO_MSG} "WITH_PGSQL=yes respectively."
- @${ECHO_MSG}
.endif
+.if defined(WITH_PGSQL)
+USE_PGSQL= YES
+CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}/pgsql
.endif
pre-install:
- @${MKDIR} ${PREFIX}/share/udmsearch
+ @${MKDIR} ${DATADIR}
post-install:
- @cp -R ${WRKSRC}/create ${PREFIX}/share/udmsearch
- @${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/udmsearch
- @${STRIP_CMD} ${PREFIX}/sbin/indexer
- @${STRIP_CMD} ${PREFIX}/share/udmsearch/search.cgi
+ @${CP} -R ${WRKSRC}/create ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/udmsearch/distinfo b/www/udmsearch/distinfo
index ecb1a3477717..ef468305dd5a 100644
--- a/www/udmsearch/distinfo
+++ b/www/udmsearch/distinfo
@@ -1,3 +1,3 @@
-MD5 (udmsearch-3.0.23.tar.gz) = 8b6742482b89c57f198bf0a46fa56614
-SHA256 (udmsearch-3.0.23.tar.gz) = d9cec387247e23a5df01a4350ef4fcd4bf1664a3d8bfb6870208475b1a459f71
-SIZE (udmsearch-3.0.23.tar.gz) = 253488
+MD5 (udmsearch-3.1.5.tar.gz) = ee57e13852ee7adf2551879d9f3bcdf9
+SHA256 (udmsearch-3.1.5.tar.gz) = 75eae3042d6c1b96f71d0fad58957340dbc3d91d5ab261c95377cd5aef3167d6
+SIZE (udmsearch-3.1.5.tar.gz) = 350832
diff --git a/www/udmsearch/files/patch-ab b/www/udmsearch/files/patch-ab
deleted file mode 100644
index 71e80dd0ad83..000000000000
--- a/www/udmsearch/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Mon Jul 31 17:10:02 2000
-+++ src/Makefile.in Mon Jul 31 17:12:21 2000
-@@ -225,7 +225,7 @@
- @list='$(bin_PROGRAMS)'; for p in $$list; do \
- if test -f $$p; then \
- echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
-- $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
-+ $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/share/udmsearch/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
- else :; fi; \
- done
-
diff --git a/www/udmsearch/files/patch-aa b/www/udmsearch/files/patch-configure.in
index 899a23c76f8a..899a23c76f8a 100644
--- a/www/udmsearch/files/patch-aa
+++ b/www/udmsearch/files/patch-configure.in
diff --git a/www/udmsearch/files/patch-sql.c b/www/udmsearch/files/patch-sql.c
deleted file mode 100644
index 453bd67c3585..000000000000
--- a/www/udmsearch/files/patch-sql.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/sql.c.orig Tue Sep 19 17:14:21 2000
-+++ src/sql.c Mon Oct 13 09:59:28 2003
-@@ -204,7 +204,8 @@
- #define unlock_url(db) sql_query(db,"UNLOCK TABLES")
-
- static int InitDB(DB*db){
-- if (!(mysql_connect(&(db->mysql),DBHost,DBUser,DBPass))){
-+ mysql_init(&(db->mysql));
-+ if (!(mysql_real_connect(&(db->mysql),DBHost,DBUser,DBPass,DB_DEFAULT,0,NULL,0))){
- db->errcode=1;
- return(1);
- }
diff --git a/www/udmsearch/files/patch-src-sql.c b/www/udmsearch/files/patch-src-sql.c
new file mode 100644
index 000000000000..ba9d16e8244e
--- /dev/null
+++ b/www/udmsearch/files/patch-src-sql.c
@@ -0,0 +1,11 @@
+--- src/sql.c.orig Tue Aug 1 19:17:38 2006
++++ src/sql.c Tue Aug 1 19:18:11 2006
+@@ -200,7 +200,7 @@
+ db=(DB*)Indexer->db;
+ db->mysql.port=Indexer->Conf->DBPort;
+ db->mysql.unix_socket="/var/tmp/xxx";
+- if (!(mysql_connect(&(db->mysql),Indexer->Conf->DBHost,Indexer->Conf->DBUser,Indexer->Conf->DBPass))){
++ if (!(mysql_real_connect(&(db->mysql),Indexer->Conf->DBHost,Indexer->Conf->DBUser,Indexer->Conf->DBPass,NULL,0,NULL,0))){
+ db->errcode=1;
+ return(1);
+ }
diff --git a/www/udmsearch/pkg-plist b/www/udmsearch/pkg-plist
index 8c8e80a6deba..77dbdef3d1f1 100644
--- a/www/udmsearch/pkg-plist
+++ b/www/udmsearch/pkg-plist
@@ -1,91 +1,122 @@
+@comment $FreeBSD$
+%%DATADIR%%/create/ibase/create.sql
+%%DATADIR%%/create/msql/crc-multi.txt
+%%DATADIR%%/create/msql/crc.txt
+%%DATADIR%%/create/msql/create.txt
+%%DATADIR%%/create/msql/multi.txt
+%%DATADIR%%/create/mssql/create.sql
+%%DATADIR%%/create/mysql/categories.txt
+%%DATADIR%%/create/mysql/crc-multi.txt
+%%DATADIR%%/create/mysql/crc.txt
+%%DATADIR%%/create/mysql/create.txt
+%%DATADIR%%/create/mysql/ispell.txt
+%%DATADIR%%/create/mysql/multi.txt
+%%DATADIR%%/create/mysql/track.txt
+%%DATADIR%%/create/oracle/categories.sql
+%%DATADIR%%/create/oracle/crc-multi.sql
+%%DATADIR%%/create/oracle/crc.sql
+%%DATADIR%%/create/oracle/create.sql
+%%DATADIR%%/create/oracle/multi.sql
+%%DATADIR%%/create/oracle/track.sql
+%%DATADIR%%/create/pgsql/categories.txt
+%%DATADIR%%/create/pgsql/crc-multi.txt
+%%DATADIR%%/create/pgsql/crc.txt
+%%DATADIR%%/create/pgsql/create.txt
+%%DATADIR%%/create/pgsql/grant.txt
+%%DATADIR%%/create/pgsql/multi.txt
+%%DATADIR%%/create/pgsql/track.txt
+%%DATADIR%%/create/solid/README
+%%DATADIR%%/create/solid/create.txt
+%%DATADIR%%/create/solid/multi.txt
+%%DATADIR%%/create/stopwords/stop.cz.txt
+%%DATADIR%%/create/stopwords/stop.de.txt
+%%DATADIR%%/create/stopwords/stop.dk.txt
+%%DATADIR%%/create/stopwords/stop.en.big
+%%DATADIR%%/create/stopwords/stop.en.huge
+%%DATADIR%%/create/stopwords/stop.en.txt
+%%DATADIR%%/create/stopwords/stop.es.txt
+%%DATADIR%%/create/stopwords/stop.fr.txt
+%%DATADIR%%/create/stopwords/stop.it.txt
+%%DATADIR%%/create/stopwords/stop.nl.txt
+%%DATADIR%%/create/stopwords/stop.no.txt
+%%DATADIR%%/create/stopwords/stop.pl.txt
+%%DATADIR%%/create/stopwords/stop.pt.txt
+%%DATADIR%%/create/stopwords/stop.ru.txt
+%%DATADIR%%/create/stopwords/stop.sk.txt
+%%DATADIR%%/create/stopwords/stop.ua.txt
+%%DATADIR%%/create/sybase/README
+%%DATADIR%%/create/sybase/create.sql
+%%DATADIR%%/create/virtuoso/crc.txt
+%%DATADIR%%/create/virtuoso/create.txt
+%%DATADIR%%/create/virtuoso/multi.txt
+%%DOCSDIR%%/HTDB.txt
+%%DOCSDIR%%/HTTP-codes.txt
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/NEWS.html
+%%DOCSDIR%%/UdmSearch-Oracle8.html
+%%DOCSDIR%%/bugs.txt
+%%DOCSDIR%%/cachemode.txt
+%%DOCSDIR%%/categories.txt
+%%DOCSDIR%%/charset.txt
+%%DOCSDIR%%/follow.txt
+%%DOCSDIR%%/hrefonly.txt
+%%DOCSDIR%%/html.txt
+%%DOCSDIR%%/ispell.txt
+%%DOCSDIR%%/lib.txt
+%%DOCSDIR%%/mp3.txt
+%%DOCSDIR%%/parsers.txt
+%%DOCSDIR%%/performance.txt
+%%DOCSDIR%%/search.txt
+%%DOCSDIR%%/storage.txt
+%%DOCSDIR%%/syslog.txt
+%%DOCSDIR%%/tags.txt
+%%DOCSDIR%%/templates.txt
+%%DOCSDIR%%/tracking.txt
+%%DOCSDIR%%/usage.txt
+bin/search.cgi
+bin/udm-config
etc/udmsearch/indexer.conf-dist
etc/udmsearch/search.htm-dist
-share/udmsearch/search.cgi
-share/udmsearch/create/oracle/crc-multi.sql
-share/udmsearch/create/oracle/create.sql
-share/udmsearch/create/oracle/multi.sql
-share/udmsearch/create/sybase/create.sql
-share/udmsearch/create/sybase/README
-share/udmsearch/create/stopwords/stop.en.1.txt
-share/udmsearch/create/stopwords/stop.ru.txt
-share/udmsearch/create/stopwords/stop.pt.txt
-share/udmsearch/create/stopwords/stop.no.txt
-share/udmsearch/create/stopwords/stop.nl.txt
-share/udmsearch/create/stopwords/stop.fr.txt
-share/udmsearch/create/stopwords/stop.es.txt
-share/udmsearch/create/stopwords/stop.pl.txt
-share/udmsearch/create/stopwords/stop.en.txt
-share/udmsearch/create/stopwords/stop.de.txt
-share/udmsearch/create/stopwords/stop.dk.txt
-share/udmsearch/create/stopwords/stop.it.txt
-share/udmsearch/create/stopwords/stop.ua.txt
-share/udmsearch/create/stopwords/stop.cz.txt
-share/udmsearch/create/solid/create.txt
-share/udmsearch/create/solid/README
-share/udmsearch/create/solid/multi.txt
-share/udmsearch/create/pgsql/create.txt
-share/udmsearch/create/pgsql/crc.txt
-share/udmsearch/create/pgsql/multi.txt
-share/udmsearch/create/pgsql/crc-multi.txt
-share/udmsearch/create/virtuoso/create.txt
-share/udmsearch/create/virtuoso/multi.txt
-share/udmsearch/create/virtuoso/crc.txt
-share/udmsearch/create/mysql/create.txt
-share/udmsearch/create/mysql/crc.txt
-share/udmsearch/create/mysql/multi.txt
-share/udmsearch/create/mysql/crc-multi.txt
-share/udmsearch/create/mysql/ispell.txt
-share/udmsearch/create/mssql/create.sql
-share/udmsearch/create/msql/multi.txt
-share/udmsearch/create/msql/create.txt
-share/udmsearch/create/msql/crc.txt
-share/udmsearch/create/msql/crc-multi.txt
-share/udmsearch/create/ibase/create.sql
+include/udm_boolean.h
+include/udm_cache.h
include/udm_charset.h
include/udm_common.h
include/udm_conf.h
include/udm_config.h
+include/udm_crc32.h
include/udm_db.h
+include/udm_ftp.h
+include/udm_host.h
include/udm_hrefs.h
+include/udm_http.h
+include/udm_id3.h
include/udm_indexer.h
include/udm_log.h
include/udm_mutex.h
include/udm_os.h
include/udm_parseurl.h
+include/udm_search_tl.h
+include/udm_searchtool.h
+include/udm_socket.h
include/udm_spell.h
include/udm_utils.h
+include/udm_xmalloc.h
include/udmsearch.h
lib/libudmsearch.a
+lib/libudmsearch.la
sbin/indexer
-bin/udm-config
-share/doc/udmsearch/INSTALL
-share/doc/udmsearch/parsers.txt
-share/doc/udmsearch/syslog.txt
-share/doc/udmsearch/templates.txt
-share/doc/udmsearch/usage.txt
-share/doc/udmsearch/HTTP-codes.txt
-share/doc/udmsearch/HTDB.txt
-share/doc/udmsearch/search.txt
-share/doc/udmsearch/ispell.txt
-share/doc/udmsearch/follow.txt
-share/doc/udmsearch/storage.txt
-share/doc/udmsearch/hrefonly.txt
-share/doc/udmsearch/UdmSearch-Oracle8.html
-share/doc/udmsearch/NEWS.html
-share/doc/udmsearch/lib.txt
-share/doc/udmsearch/html.txt
-share/doc/udmsearch/charset.txt
-@dirrm share/doc/udmsearch
-@dirrm share/udmsearch/create/ibase
-@dirrm share/udmsearch/create/msql
-@dirrm share/udmsearch/create/mssql
-@dirrm share/udmsearch/create/mysql
-@dirrm share/udmsearch/create/oracle
-@dirrm share/udmsearch/create/pgsql
-@dirrm share/udmsearch/create/solid
-@dirrm share/udmsearch/create/stopwords
-@dirrm share/udmsearch/create/sybase
-@dirrm share/udmsearch/create/virtuoso
-@dirrm share/udmsearch/create
-@dirrm share/udmsearch
-@dirrm etc/udmsearch
+sbin/splitter
+@dirrmtry %%DATADIR%%/create/ibase
+@dirrmtry %%DATADIR%%/create/msql
+@dirrmtry %%DATADIR%%/create/mssql
+@dirrmtry %%DATADIR%%/create/mysql
+@dirrmtry %%DATADIR%%/create/oracle
+@dirrmtry %%DATADIR%%/create/pgsql
+@dirrmtry %%DATADIR%%/create/solid
+@dirrmtry %%DATADIR%%/create/stopwords
+@dirrmtry %%DATADIR%%/create/sybase
+@dirrmtry %%DATADIR%%/create/virtuoso
+@dirrmtry %%DATADIR%%/create
+@dirrmtry %%DATADIR%%
+@dirrmtry %%DOCSDIR%%
+@dirrmtry etc/udmsearch