aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2010-05-07 04:11:33 +0800
committerstefan <stefan@FreeBSD.org>2010-05-07 04:11:33 +0800
commit6e70cf935f8d48bdc58d9b904f3052d086963339 (patch)
tree147988f336faa23dda0f2478984bc52f19e4f57c /www
parent691e9743c023a5e37cf33a0e5ea7fbe1f94bfd69 (diff)
downloadfreebsd-ports-gnome-6e70cf935f8d48bdc58d9b904f3052d086963339.tar.gz
freebsd-ports-gnome-6e70cf935f8d48bdc58d9b904f3052d086963339.tar.zst
freebsd-ports-gnome-6e70cf935f8d48bdc58d9b904f3052d086963339.zip
Fix stopping the server process via the port's rc.d script.
PR: ports/140829 Submitted by: Ruben van Staveren <ruben@verweg.com> Approved by: maintainer timeout (>5 months)
Diffstat (limited to 'www')
-rw-r--r--www/tomcat55/Makefile1
-rw-r--r--www/tomcat55/files/tomcat55.sh.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index f55cb383bea7..e2b9d745b2e3 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.28
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat55/files/tomcat55.sh.in b/www/tomcat55/files/tomcat55.sh.in
index 1ac100ed9f5b..fc634f090997 100644
--- a/www/tomcat55/files/tomcat55.sh.in
+++ b/www/tomcat55/files/tomcat55.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o ucomm= -p $rc_pid`
+ procname=`ps -o command= -p $rc_pid | cut -f 1 -d ' '`
fi
fi
if [ -z "$procname" ]; then