aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2002-05-31 19:21:08 +0800
committernork <nork@FreeBSD.org>2002-05-31 19:21:08 +0800
commitd217d465587dd6030f403d90ef8a452ba93f8670 (patch)
treedeadabb8f21b493aa41a27ecb18b115e5a363c2c /www
parent0b8184ce3ab9a95853bcb94bcc885fbc3f7488ff (diff)
downloadfreebsd-ports-gnome-d217d465587dd6030f403d90ef8a452ba93f8670.tar.gz
freebsd-ports-gnome-d217d465587dd6030f403d90ef8a452ba93f8670.tar.zst
freebsd-ports-gnome-d217d465587dd6030f403d90ef8a452ba93f8670.zip
Add www/p5-Apache-DumpHeaders, an Apache module that watches HTTP
transactions under mod_perl, looking at the headers. Reviewed by: knu (mentor) Approved by: knu (mentor)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-DumpHeaders/Makefile25
-rw-r--r--www/p5-Apache-DumpHeaders/distinfo1
-rw-r--r--www/p5-Apache-DumpHeaders/pkg-comment1
-rw-r--r--www/p5-Apache-DumpHeaders/pkg-descr7
-rw-r--r--www/p5-Apache-DumpHeaders/pkg-plist6
6 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8e1565e5129a..581fc03a5071 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -228,6 +228,7 @@
SUBDIR += p5-Apache-AuthenURL
SUBDIR += p5-Apache-AutoIndex
SUBDIR += p5-Apache-DBI
+ SUBDIR += p5-Apache-DumpHeaders
SUBDIR += p5-Apache-Filter
SUBDIR += p5-Apache-Icon
SUBDIR += p5-Apache-Language
diff --git a/www/p5-Apache-DumpHeaders/Makefile b/www/p5-Apache-DumpHeaders/Makefile
new file mode 100644
index 000000000000..52027e3a5bc4
--- /dev/null
+++ b/www/p5-Apache-DumpHeaders/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Apache-DumpHeaders
+# Date created: 2002-05-31
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-DumpHeaders
+PORTVERSION= 0.94
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::DumpHeaders.3 Apache::ProxyPassThru.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-DumpHeaders/distinfo b/www/p5-Apache-DumpHeaders/distinfo
new file mode 100644
index 000000000000..c9af79b1b9ac
--- /dev/null
+++ b/www/p5-Apache-DumpHeaders/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-DumpHeaders-0.94.tar.gz) = 3043751b559df3fffb4f2788888c1507
diff --git a/www/p5-Apache-DumpHeaders/pkg-comment b/www/p5-Apache-DumpHeaders/pkg-comment
new file mode 100644
index 000000000000..4d72ae9799fb
--- /dev/null
+++ b/www/p5-Apache-DumpHeaders/pkg-comment
@@ -0,0 +1 @@
+Watches HTTP transactions under mod_perl, looking at the headers
diff --git a/www/p5-Apache-DumpHeaders/pkg-descr b/www/p5-Apache-DumpHeaders/pkg-descr
new file mode 100644
index 000000000000..e18f41435506
--- /dev/null
+++ b/www/p5-Apache-DumpHeaders/pkg-descr
@@ -0,0 +1,7 @@
+This module is used to watch an HTTP transaction,
+looking at the client and servers headers. With
+Apache::ProxyPassThru configured, you are able to
+watch your browser talk to any server besides the
+one with this module living inside.
+
+Author: Ask Bjoern Hansen <ask@develooper.com>
diff --git a/www/p5-Apache-DumpHeaders/pkg-plist b/www/p5-Apache-DumpHeaders/pkg-plist
new file mode 100644
index 000000000000..2a0aee1b1544
--- /dev/null
+++ b/www/p5-Apache-DumpHeaders/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/DumpHeaders.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ProxyPassThru.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/DumpHeaders/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/DumpHeaders 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true