aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-06-23 11:11:54 +0800
committerijliao <ijliao@FreeBSD.org>2004-06-23 11:11:54 +0800
commitdba7aa0473570219da53bde37487f576bc8026b1 (patch)
tree76d35ea9de65790c6017e813993e0fef7c2f56d8 /www
parent6888e87466efb7cfff1d7de4776900f7e985aad7 (diff)
downloadfreebsd-ports-gnome-dba7aa0473570219da53bde37487f576bc8026b1.tar.gz
freebsd-ports-gnome-dba7aa0473570219da53bde37487f576bc8026b1.tar.zst
freebsd-ports-gnome-dba7aa0473570219da53bde37487f576bc8026b1.zip
add sitebar 3.2.5
The Bookmark Server for Personal and Team Use
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/sitebar/Makefile38
-rw-r--r--www/sitebar/distinfo2
-rw-r--r--www/sitebar/pkg-descr9
4 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 92693b286dd2..2c7617f090dd 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -571,6 +571,7 @@
SUBDIR += scout
SUBDIR += screem
SUBDIR += sidplug
+ SUBDIR += sitebar
SUBDIR += sitecopy
SUBDIR += slash
SUBDIR += smarty
diff --git a/www/sitebar/Makefile b/www/sitebar/Makefile
new file mode 100644
index 000000000000..3439a4072e77
--- /dev/null
+++ b/www/sitebar/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: sitebar
+# Date created: Jun 23, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sitebar
+PORTVERSION= 3.2.5
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= SiteBar-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The Bookmark Server for Personal and Team Use
+
+USE_BZIP2= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+DATADIR?= ${PREFIX}/www/${PORTNAME}
+
+pre-everything::
+ @${ECHO_CMD} "***************************************************************"
+ @${ECHO_CMD} "* Please installs PHP with MySQL extension before using this. *"
+ @${ECHO_CMD} "***************************************************************"
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/* ${DATADIR}
+ @${FIND} ${DATADIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/sitebar/distinfo b/www/sitebar/distinfo
new file mode 100644
index 000000000000..b5f1ba612ff9
--- /dev/null
+++ b/www/sitebar/distinfo
@@ -0,0 +1,2 @@
+MD5 (SiteBar-3.2.5.tar.bz2) = 16a37723bb77cf437c0843f80d2a42e1
+SIZE (SiteBar-3.2.5.tar.bz2) = 252327
diff --git a/www/sitebar/pkg-descr b/www/sitebar/pkg-descr
new file mode 100644
index 000000000000..fad94d629cb7
--- /dev/null
+++ b/www/sitebar/pkg-descr
@@ -0,0 +1,9 @@
+SiteBar is a multi-user, multi-group bookmark server that lets users view,
+add, import, and maintain bookmarks from anywhere. It offers enterprise-
+quality access rights and granular permissions. Corporations can use it as
+a complete intranet bookmark solution, and end-users can use it to access
+their bookmark collection from anywhere, and share it with friends. It is
+intended for use in a browser's sidebar, and offers a clean, easy to use
+interface.
+
+WWW: http://www.sitebar.org/