aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-02-17 22:34:14 +0800
committerclement <clement@FreeBSD.org>2004-02-17 22:34:14 +0800
commitf0f99a4cde63f32fad3763871d99ded6911847e8 (patch)
tree1d46f769801fdb93da63b1e32888bf837d9561ca /www
parent5a01e326166be634ad829602a89d06b0010e1613 (diff)
downloadfreebsd-ports-gnome-f0f99a4cde63f32fad3763871d99ded6911847e8.tar.gz
freebsd-ports-gnome-f0f99a4cde63f32fad3763871d99ded6911847e8.tar.zst
freebsd-ports-gnome-f0f99a4cde63f32fad3763871d99ded6911847e8.zip
Add webreport 1.5, webReport is a web log statistics program for web
hosting sites. WebReport is a web log statistics reporting program especially designed for virtual web hosting sites. It is also very useful for signle hosting sites. the main difference between WebReport and other statics programs is a configuration file which allows for easy manipulation of the features. WWW: http://www.inter7.com/webreport2.html PR: ports/62904 Submitted by: ismail@enderunix.org
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/webreport/Makefile36
-rw-r--r--www/webreport/distinfo2
-rw-r--r--www/webreport/files/patch-Makefile22
-rw-r--r--www/webreport/files/patch-webreport.c42
-rw-r--r--www/webreport/pkg-descr6
-rw-r--r--www/webreport/pkg-message4
7 files changed, 113 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 33e924a4d719..037f1c0db34f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -575,6 +575,7 @@
SUBDIR += webglimpse
SUBDIR += weblint
SUBDIR += webredirect
+ SUBDIR += webreport
SUBDIR += webresolve
SUBDIR += webstats
SUBDIR += webstone
diff --git a/www/webreport/Makefile b/www/webreport/Makefile
new file mode 100644
index 000000000000..e11484c014af
--- /dev/null
+++ b/www/webreport/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: webreport
+# Date created: 06 Feb 2004
+# Whom: ismail@enderunix.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= webreport
+PORTVERSION= 1.5
+CATEGORIES= www
+MASTER_SITES= http://www.inter7.com/webreport/
+
+MAINTAINER= ismail@EnderUNIX.org
+COMMENT= WebReport is a web log statistics program for web hosting sites
+
+USE_REINPLACE= yes
+
+PORTDOCS= INSTALL
+PLIST_FILES= bin/webreport etc/webreport.conf-dist
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,ulong,unsigned long,;s,/etc/,${PREFIX}/etc/,' ${WRKSRC}/webreport.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/webreport ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/webreport.conf ${PREFIX}/etc/webreport.conf-dist
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
+
+.include <bsd.port.mk>
diff --git a/www/webreport/distinfo b/www/webreport/distinfo
new file mode 100644
index 000000000000..0ecb55b9297f
--- /dev/null
+++ b/www/webreport/distinfo
@@ -0,0 +1,2 @@
+MD5 (webreport-1.5.tar.gz) = 53775790be7b62839acfe22d00748b61
+SIZE (webreport-1.5.tar.gz) = 25501
diff --git a/www/webreport/files/patch-Makefile b/www/webreport/files/patch-Makefile
new file mode 100644
index 000000000000..4a083af36b83
--- /dev/null
+++ b/www/webreport/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Mon Oct 8 18:09:18 2001
++++ Makefile Tue Feb 17 15:22:44 2004
+@@ -24,8 +24,8 @@
+ DEBUG= -g
+ #OPT= -O2
+
+-CFLAGS= -c $(OPT) $(DEBUG)
+-LDFLAGS= $(DEBUG)
++CFLAGS+= -c $(OPT)
++#LDFLAGS+= $(LDFLAGS)
+
+ .c.o:
+ $(CC) $(CFLAGS) $<
+@@ -33,6 +33,8 @@
+ BINS = webreport
+
+ OBJ = webreport.o
++
++all: webreport
+
+ webreport: $(OBJ) webreport.h
+ $(CC) $(LDFLAGS) $(OBJ) -o webreport
diff --git a/www/webreport/files/patch-webreport.c b/www/webreport/files/patch-webreport.c
new file mode 100644
index 000000000000..0ba8a884e090
--- /dev/null
+++ b/www/webreport/files/patch-webreport.c
@@ -0,0 +1,42 @@
+--- webreport.c.org Sat Feb 7 17:06:38 2004
++++ webreport.c Sat Feb 7 17:06:47 2004
+@@ -22,7 +22,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <time.h>
+-#include <getopt.h>
++#include <unistd.h>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -808,7 +808,7 @@
+ }
+
+ char *comma_string_long(in_long )
+- ulong in_long;
++ unsigned long in_long;
+ {
+ char tmpbuf[MAX_TINY_BUF];
+ static char tmpbuf1[MAX_TINY_BUF];
+@@ -1866,10 +1866,10 @@
+
+ report_open_files()
+ {
+- strncpy( Globals.TextReportName, "/usr/tmp/webreport.text.XXXXXX", 100);
++ strncpy( Globals.TextReportName, "/var/tmp/webreport.text.XXXXXX", 100);
+ mkstemp(Globals.TextReportName);
+
+- strncpy( Globals.HTMLReportName, "/usr/tmp/webreport.html.XXXXXX", 100);
++ strncpy( Globals.HTMLReportName, "/var/tmp/webreport.html.XXXXXX", 100);
+ mkstemp(Globals.HTMLReportName);
+
+ Globals.TextReport = fopen(Globals.TextReportName, "w");
+@@ -2084,7 +2084,7 @@
+ fputs( Globals.TmpBuf, fs);
+ }
+ } else {
+- fprintf( Globals.HTMLReport,
++ fprintf(Globals.HTMLReport,
+ "Subject: %s\n", Globals.cur_site->title);
+ fprintf( Globals.HTMLReport,
+ "Content-Type: text/html; charset=us-ascii\n");
diff --git a/www/webreport/pkg-descr b/www/webreport/pkg-descr
new file mode 100644
index 000000000000..68a16e24dfff
--- /dev/null
+++ b/www/webreport/pkg-descr
@@ -0,0 +1,6 @@
+WebReport is a web log statistics reporting program especially designed for
+virtual web hosting sites. It is also very useful for signle hosting sites.
+the main difference between WebReport and other statics programs is a
+configuration file which allows for easy manipulation of the features.
+
+WWW: http://www.inter7.com/webreport2.html
diff --git a/www/webreport/pkg-message b/www/webreport/pkg-message
new file mode 100644
index 000000000000..b7ddf601fa79
--- /dev/null
+++ b/www/webreport/pkg-message
@@ -0,0 +1,4 @@
+
+Read the %%PREFIX%%/share/doc/webreport/INSTALL to configure webreport
+
+Edit the %%PREFIX%%/etc/webreport.conf