aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2011-11-02 09:45:20 +0800
committerclsung <clsung@FreeBSD.org>2011-11-02 09:45:20 +0800
commitf36440a70ce2db9abd8da7bbac13aaa07ac3cc21 (patch)
tree21a715023573ca788c5b1b44711c9caf7d99f642 /www
parentc0def8a527e5afa3c583466eba5effba4ffe989f (diff)
downloadfreebsd-ports-gnome-f36440a70ce2db9abd8da7bbac13aaa07ac3cc21.tar.gz
freebsd-ports-gnome-f36440a70ce2db9abd8da7bbac13aaa07ac3cc21.tar.zst
freebsd-ports-gnome-f36440a70ce2db9abd8da7bbac13aaa07ac3cc21.zip
A mini-framework for Django for creating RESTful APIs.
Piston is a relatively small Django application that lets you create application programming interfaces (API) for your sites. It has several unique features: * Ties into Django's internal mechanisms. * Supports OAuth out of the box (as well as Basic/Digest or custom auth.) * Doesn't require tying to models, allowing arbitrary resources. * Speaks JSON, YAML, Python Pickle & XML (and HATEOAS.) * Ships with a convenient reusable library in Python * Respects and encourages proper use of HTTP (status codes, ...) * Has built in (optional) form validation (via Django), throttling, etc. * Supports streaming, with a small memory footprint. WWW: https://bitbucket.org/jespern/django-piston
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-piston/Makefile24
-rw-r--r--www/py-django-piston/distinfo2
-rw-r--r--www/py-django-piston/pkg-descr17
4 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3b4498700bc1..26312f0a07b5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1477,6 +1477,7 @@
SUBDIR += py-django-livesettings
SUBDIR += py-django-mptt
SUBDIR += py-django-pipeline
+ SUBDIR += py-django-piston
SUBDIR += py-django-profiles
SUBDIR += py-django-registration
SUBDIR += py-django-signals-ahoy
diff --git a/www/py-django-piston/Makefile b/www/py-django-piston/Makefile
new file mode 100644
index 000000000000..a71c7912c16e
--- /dev/null
+++ b/www/py-django-piston/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-django-piston
+# Date created: 2011-11-02
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= django-piston
+PORTVERSION= 0.2.2.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Piston is a Django mini-framework creating APIs
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:${PORTSDIR}/www/py-django
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/www/py-django-piston/distinfo b/www/py-django-piston/distinfo
new file mode 100644
index 000000000000..c9408e8ec361
--- /dev/null
+++ b/www/py-django-piston/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-piston-0.2.2.1.tar.gz) = 0fcdc2d4e971a05539f2473f3b7563a8d8b297658d7b81537da0ce74e6b4ee4b
+SIZE (django-piston-0.2.2.1.tar.gz) = 24351
diff --git a/www/py-django-piston/pkg-descr b/www/py-django-piston/pkg-descr
new file mode 100644
index 000000000000..5bd9da155b7a
--- /dev/null
+++ b/www/py-django-piston/pkg-descr
@@ -0,0 +1,17 @@
+A mini-framework for Django for creating RESTful APIs.
+
+Piston is a relatively small Django application that lets you
+create application programming interfaces (API) for your sites.
+
+It has several unique features:
+
+ * Ties into Django's internal mechanisms.
+ * Supports OAuth out of the box (as well as Basic/Digest or custom auth.)
+ * Doesn't require tying to models, allowing arbitrary resources.
+ * Speaks JSON, YAML, Python Pickle & XML (and HATEOAS.)
+ * Ships with a convenient reusable library in Python
+ * Respects and encourages proper use of HTTP (status codes, ...)
+ * Has built in (optional) form validation (via Django), throttling, etc.
+ * Supports streaming, with a small memory footprint.
+
+WWW: https://bitbucket.org/jespern/django-piston