aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /www
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'www')
-rw-r--r--www/aria/Makefile12
-rw-r--r--www/logtools/Makefile6
-rw-r--r--www/p5-Apache-Peek/Makefile10
-rw-r--r--www/wsmake/Makefile12
4 files changed, 20 insertions, 20 deletions
diff --git a/www/aria/Makefile b/www/aria/Makefile
index d25de8169349..514611233893 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -16,12 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.t/test/}
MAINTAINER= nakai@FreeBSD.org
COMMENT= Yet another download tool
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not build"
-.endif
-
USE_BZIP2= yes
USE_GNOME= gtk12
USE_OPENSSL= yes
@@ -31,6 +25,12 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g; \
s|-lssl|-lcrypto -lssl|g; \
diff --git a/www/logtools/Makefile b/www/logtools/Makefile
index 3d8e0ceb6e35..e88f61debd3f 100644
--- a/www/logtools/Makefile
+++ b/www/logtools/Makefile
@@ -14,13 +14,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= xaa+ports@timewasters.nl
COMMENT= Useful tools to deal with CLF files (Common Log File format)
+GNU_CONFIGURE= yes
+MAN1= clfmerge.1 logprn.1 funnel.1 clfsplit.1 clfdomainsplit.1
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile (bad C++ code)"
.endif
-GNU_CONFIGURE= yes
-MAN1= clfmerge.1 logprn.1 funnel.1 clfsplit.1 clfdomainsplit.1
-
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Peek/Makefile b/www/p5-Apache-Peek/Makefile
index e1f4cf392198..4fadea16b6d3 100644
--- a/www/p5-Apache-Peek/Makefile
+++ b/www/p5-Apache-Peek/Makefile
@@ -18,15 +18,15 @@ COMMENT= A perl5 data debugging tool for the XS programmer
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/B/Graph.pm:${PORTSDIR}/devel/p5-B-Graph
+PERL_CONFIGURE= YES
+
+MAN3= Apache::Peek.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
-PERL_CONFIGURE= YES
-
-MAN3= Apache::Peek.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
.include <bsd.port.post.mk>
diff --git a/www/wsmake/Makefile b/www/wsmake/Makefile
index 9426d08d40a7..bff0f5051394 100644
--- a/www/wsmake/Makefile
+++ b/www/wsmake/Makefile
@@ -20,12 +20,6 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= jkoshy@freebsd.org
COMMENT= Software for production and maintenance of web sites
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BZIP2= YES
GNU_CONFIGURE= YES
@@ -33,6 +27,12 @@ WSMAKE_MASTER_SITE= http://www.wsmake.org
WSMAKE_DOCDIR= ${PREFIX}/share/doc/wsmake
WSMAKE_EXDIR= ${PREFIX}/share/examples/wsmake
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
# Install examples and optional documentation.
post-install:
${MKDIR} ${WSMAKE_EXDIR}