aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-02-17 12:43:21 +0800
committerrafan <rafan@FreeBSD.org>2007-02-17 12:43:21 +0800
commitf87f9b236afc959a38f4b68df1addb66049e8ce5 (patch)
tree9df9da43ba3a368d3e4a0c21742e70be1ae0603f /www
parent6c86fbe00b5d0ac08dc8784d62d212fcfc0c6ebb (diff)
downloadfreebsd-ports-gnome-f87f9b236afc959a38f4b68df1addb66049e8ce5.tar.gz
freebsd-ports-gnome-f87f9b236afc959a38f4b68df1addb66049e8ce5.tar.zst
freebsd-ports-gnome-f87f9b236afc959a38f4b68df1addb66049e8ce5.zip
- Update to 5.6
PR: ports/109163 Submitted by: Hugo Leisink <hugo at leisink.org> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/hiawatha/Makefile25
-rw-r--r--www/hiawatha/distinfo6
-rw-r--r--www/hiawatha/pkg-plist10
3 files changed, 23 insertions, 18 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 7368b54d9344..2ff70363f670 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= hiawatha
-PORTVERSION= 5.3
+PORTVERSION= 5.6
CATEGORIES= www
MASTER_SITES= http://hiawatha.leisink.org/files/
MAINTAINER= hugo@leisink.net
COMMENT= An advanced and secure webserver for Unix
-MAN1= hiawatha.1 cgi_wrapper.1
+MAN1= hiawatha.1 cgi-wrapper.1 php-fcgi.1 wigwam.1
MANCOMPRESSED= no
USE_RC_SUBR= hiawatha
@@ -22,10 +22,11 @@ SUB_FILES= pkg-message
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var webrootdir=${PREFIX}/www/hiawatha
-OPTIONS= SSL "Compile with SSL support?" On
-OPTIONS+= PHP "Include the CGI version of PHP?" On
+OPTIONS= SSL "Support for Secure Sockets Layer (SSL)?" On
+OPTIONS+= CACHE "Internal file caching support?" On
+OPTIONS+= COMMAND "Enable the Hiawatha CommandChannel?" Off
-CONFIG_FILES= httpd.conf mimetype.conf throttle.conf cgi_wrapper.conf
+CONFIG_FILES= httpd.conf mimetype.conf throttle.conf cgi-wrapper.conf php-fcgi.conf
.include <bsd.port.pre.mk>
@@ -33,15 +34,17 @@ CONFIG_FILES= httpd.conf mimetype.conf throttle.conf cgi_wrapper.conf
CONFIGURE_ARGS+=--disable-ssl
.endif
-.if !defined(WITHOUT_PHP)
-WANT_PHP_CGI= yes
+.if defined(WITHOUT_CACHE)
+CONFIGURE_ARGS+=--disable-cache
+.endif
+
+.if defined(WITH_COMMAND)
+CONFIGURE_ARGS+=--enable-command
.endif
post-install:
- ${CP} -f ${WRKSRC}/extra/fcgi-server ${PREFIX}/sbin
- ${CP} -f ${WRKSRC}/extra/newroot ${PREFIX}/sbin
- @for _file in ${CONFIG_FILES} ; do \
- ${CP} -f ${WRKSRC}/etc/hiawatha/$${_file} ${PREFIX}/etc/hiawatha/$${_file}.sample ; \
+ @for file in ${CONFIG_FILES} ; do \
+ ${CP} -f ${WRKSRC}/etc/hiawatha/$${file} ${PREFIX}/etc/hiawatha/$${file}.sample ; \
done
${CP} -f ${WRKSRC}/doc/index.html ${PREFIX}/www/hiawatha/index.html.sample
@${CAT} ${PKGMESSAGE}
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
index 17c8e434da24..05a2bedf9f5d 100644
--- a/www/hiawatha/distinfo
+++ b/www/hiawatha/distinfo
@@ -1,3 +1,3 @@
-MD5 (hiawatha-5.3.tar.gz) = 16a3d7e720fb4b1a7dd66f77c60b7dc5
-SHA256 (hiawatha-5.3.tar.gz) = 168dc7fec581a905600a4a1d50dd35e3e635a8601e5b6a023a326ce15654ae37
-SIZE (hiawatha-5.3.tar.gz) = 184446
+MD5 (hiawatha-5.6.tar.gz) = 3c471a19793e838b58201d711f19d0c3
+SHA256 (hiawatha-5.6.tar.gz) = 27f570eb41409606cdf16b77e73293587e2337a7c4f2981eae0a019dc461991a
+SIZE (hiawatha-5.6.tar.gz) = 194423
diff --git a/www/hiawatha/pkg-plist b/www/hiawatha/pkg-plist
index 2cde753fd23b..6aa02bcb21ec 100644
--- a/www/hiawatha/pkg-plist
+++ b/www/hiawatha/pkg-plist
@@ -1,16 +1,18 @@
sbin/hiawatha
-sbin/cgi_wrapper
+sbin/cgi-wrapper
sbin/wigwam
-sbin/fcgi-server
+sbin/php-fcgi
sbin/newroot
@unexec if cmp -s %D/etc/hiawatha/httpd.conf %D/etc/hiawatha/httpd.conf.sample; then rm -f %D/etc/hiawatha/httpd.conf; fi
@unexec if cmp -s %D/etc/hiawatha/mimetype.conf %D/etc/hiawatha/mimetype.conf.sample; then rm -f %D/etc/hiawatha/mimetype.conf; fi
@unexec if cmp -s %D/etc/hiawatha/throttle.conf %D/etc/hiawatha/throttle.conf.sample; then rm -f %D/etc/hiawatha/throttle.conf; fi
-@unexec if cmp -s %D/etc/hiawatha/cgi_wrapper.conf %D/etc/hiawatha/cgi_wrapper.conf.sample; then rm -f %D/etc/hiawatha/cgi_wrapper.conf; fi
+@unexec if cmp -s %D/etc/hiawatha/cgi-wrapper.conf %D/etc/hiawatha/cgi-wrapper.conf.sample; then rm -f %D/etc/hiawatha/cgi-wrapper.conf; fi
+@unexec if cmp -s %D/etc/hiawatha/php-fcgi.conf %D/etc/hiawatha/php-fcgi.conf.sample; then rm -f %D/etc/hiawatha/php-fcgi.conf; fi
etc/hiawatha/httpd.conf.sample
etc/hiawatha/mimetype.conf.sample
etc/hiawatha/throttle.conf.sample
-etc/hiawatha/cgi_wrapper.conf.sample
+etc/hiawatha/cgi-wrapper.conf.sample
+etc/hiawatha/php-fcgi.conf.sample
@dirrm etc/hiawatha
@unexec if cmp -s %D/www/hiawatha/index.html %D/www/hiawatha/index.html.sample; then rm -f %D/www/hiawatha/index.html; fi
www/hiawatha/index.html.sample