aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-01-21 06:40:09 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-01-21 06:40:09 +0800
commit125a916135f77f05e9870d83f83432a2fdea6456 (patch)
tree97ba2e01e15d91ef1930c60c5173af1f43fc4348 /www
parent87b9a010868b2f744a7718bb47124b1d9b8ecd8e (diff)
downloadfreebsd-ports-gnome-125a916135f77f05e9870d83f83432a2fdea6456.tar.gz
freebsd-ports-gnome-125a916135f77f05e9870d83f83432a2fdea6456.tar.zst
freebsd-ports-gnome-125a916135f77f05e9870d83f83432a2fdea6456.zip
Serializes and deserializes Path::Class objects as file:// URI.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Path-Class-URI/Makefile29
-rw-r--r--www/p5-Path-Class-URI/distinfo3
-rw-r--r--www/p5-Path-Class-URI/pkg-descr3
-rw-r--r--www/p5-Path-Class-URI/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ee521dc52de9..b12c3412fb0e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -971,6 +971,7 @@
SUBDIR += p5-POE-Component-Server-SOAP
SUBDIR += p5-POE-Component-Server-SimpleHTTP
SUBDIR += p5-ParallelUA
+ SUBDIR += p5-Path-Class-URI
SUBDIR += p5-PodToHTML
SUBDIR += p5-RT-Client-REST
SUBDIR += p5-RT-Extension-LDAPImport
diff --git a/www/p5-Path-Class-URI/Makefile b/www/p5-Path-Class-URI/Makefile
new file mode 100644
index 000000000000..f4c733e63f45
--- /dev/null
+++ b/www/p5-Path-Class-URI/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Path::Class::URI
+# Date created: 20 Jan 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Path-Class-URI
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for serialize Path::Class objects as file:// URI
+
+RUN_DEPENDS= \
+ p5-Path-Class>0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-Exporter-Lite>0:${PORTSDIR}/devel/p5-Exporter-Lite
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Path::Class::URI.3 \
+ Path::Class::Unicode.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Path-Class-URI/distinfo b/www/p5-Path-Class-URI/distinfo
new file mode 100644
index 000000000000..a3cfb5d327da
--- /dev/null
+++ b/www/p5-Path-Class-URI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Path-Class-URI-0.04.tar.gz) = 68e679fcd0b70361fe37a9f48fd15e99
+SHA256 (Path-Class-URI-0.04.tar.gz) = 7d4aaa055c9b3c4dcb0acaba3dbb97680b6e96f6190cde5d9f53ab831d14bea9
+SIZE (Path-Class-URI-0.04.tar.gz) = 37585
diff --git a/www/p5-Path-Class-URI/pkg-descr b/www/p5-Path-Class-URI/pkg-descr
new file mode 100644
index 000000000000..043ad052d214
--- /dev/null
+++ b/www/p5-Path-Class-URI/pkg-descr
@@ -0,0 +1,3 @@
+Serializes and deserializes Path::Class objects as file:// URI.
+
+WWW: http://search.cpan.org/dist/Path-Class-URI/
diff --git a/www/p5-Path-Class-URI/pkg-plist b/www/p5-Path-Class-URI/pkg-plist
new file mode 100644
index 000000000000..dcc7cd71a1f6
--- /dev/null
+++ b/www/p5-Path-Class-URI/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Class/URI/.packlist
+%%SITE_PERL%%/Path/Class/URI.pm
+%%SITE_PERL%%/Path/Class/Unicode.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Class/URI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path