aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-07-27 21:39:52 +0800
committertobez <tobez@FreeBSD.org>2007-07-27 21:39:52 +0800
commit405d4328250e96c6c8d3a989bcd057109236f6a4 (patch)
tree2b9e2d601a79c81f901accd78c0688438a6336c5 /www
parent603f43d3692dbd09ccaeec98ae70f745718e7beb (diff)
downloadfreebsd-ports-gnome-405d4328250e96c6c8d3a989bcd057109236f6a4.tar.gz
freebsd-ports-gnome-405d4328250e96c6c8d3a989bcd057109236f6a4.tar.zst
freebsd-ports-gnome-405d4328250e96c6c8d3a989bcd057109236f6a4.zip
Update to 1.5p6.
Changes (as taken from 16461.82.215.41.237.1185016981.squirrel@webmail.xs4all.nl): 1) On FreeBSD there was a rather embarrassing bug when sendfile was used, which manifests itself in bogus 'premature end of file' messages in the error log. This should now be fixed. 2) There were some stupid mistakes in the way in which Content-Length, and Range headers were computed and/or parsed. This had to do with the fact that size_t is 32 bit on most 32-bit platforms, but file sizes can be much bigger. 3) Mathopd would refuse to open files larger than 2 GB on Solaris or Linux. This should now be fixed, provided you follow the instructions in the Makefile. 4) The SanitizePath feature (the one that substitutes // for /, etc. in request URIs) has been retrofitted into 1.5. 5) Some cosmetic changes were made to the Makefile in 1.6. These were merged also.
Diffstat (limited to 'www')
-rw-r--r--www/mathopd/Makefile2
-rw-r--r--www/mathopd/distinfo6
-rw-r--r--www/mathopd/files/patch-aa30
3 files changed, 22 insertions, 16 deletions
diff --git a/www/mathopd/Makefile b/www/mathopd/Makefile
index fda6d930b6b5..e8d37a97d410 100644
--- a/www/mathopd/Makefile
+++ b/www/mathopd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mathopd
-PORTVERSION= 1.5p5
+PORTVERSION= 1.5p6
CATEGORIES= www
MASTER_SITES= http://www.mathopd.org/dist/
diff --git a/www/mathopd/distinfo b/www/mathopd/distinfo
index 34ecc23cc14f..c781a09ffb35 100644
--- a/www/mathopd/distinfo
+++ b/www/mathopd/distinfo
@@ -1,3 +1,3 @@
-MD5 (mathopd-1.5p5.tar.gz) = 48b54bf1e9673203a8f18a4fefab4730
-SHA256 (mathopd-1.5p5.tar.gz) = a9ccc2e5fbda606a3d7701e9c87a7f5f50c1c80f2a05336a6451035ae89de6b5
-SIZE (mathopd-1.5p5.tar.gz) = 58519
+MD5 (mathopd-1.5p6.tar.gz) = c26b466f20ddcdc6b68180a248f3156c
+SHA256 (mathopd-1.5p6.tar.gz) = f7afdd8a3f9979f9ac3af15109e8599d2641d9a57d05fcddc4e51a20ac31d779
+SIZE (mathopd-1.5p6.tar.gz) = 60634
diff --git a/www/mathopd/files/patch-aa b/www/mathopd/files/patch-aa
index fc2e133f62ca..56d36606876c 100644
--- a/www/mathopd/files/patch-aa
+++ b/www/mathopd/files/patch-aa
@@ -1,6 +1,6 @@
---- src/Makefile.orig Sun Dec 14 20:37:51 2003
-+++ src/Makefile Thu May 6 12:16:48 2004
-@@ -1,49 +1,8 @@
+--- src/Makefile.orig Fri Jul 27 15:30:54 2007
++++ src/Makefile Fri Jul 27 15:35:04 2007
+@@ -1,54 +1,9 @@
-BIN = mathopd
-CC = gcc
-CFLAGS = -O -Wall
@@ -10,26 +10,32 @@
-PREFIX = /usr/local
-SBINDIR = $(PREFIX)/sbin
+PROG= mathopd
-+SRCS= base64.c cgi.c config.c core.c dump.c imap.c log.c \
-+ main.c redirect.c request.c util.c stub.c sendfile.c
-+BINDIR?=${PREFIX}/sbin
++SRCS=
++SRCS= base64.c cgi.c config.c core.c dump.c imap.c log.c main.c \
++ redirect.c request.c util.c stub.c sendfile.c
++BINDIR?= ${PREFIX}/sbin
+NOMAN= yes
+LDADD= -lcrypt
-# On Solaris, uncomment the following
--# CPPFLAGS = -DNEED_INET_ATON -DHAVE_CRYPT_H
--# LIBS = -lsocket -lnsl
+-# CPPFLAGS = -DHAVE_CRYPT_H
+-# LIBS = -lsocket -lnsl -lresolv
-
-# On Linux, uncomment the following
-# CPPFLAGS = -DHAVE_CRYPT_H
-
+-# For Linux or Solaris:
+-# To add support for large files (>2GB), uncomment the following.
+-# You do not need this for 64-bit executables.
+-# CPPFLAGS += -D_FILE_OFFSET_BITS=64
+-
-OBJS = base64.o cgi.o config.o core.o dump.o imap.o log.o main.o \
-- redirect.o request.o util.o stub.o
+- redirect.o request.o util.o stub.o $(EXTRA_OBJS)
-DEPENDS = mathopd.h Makefile
-
-# Uncomment the following if your system does not support the poll() function
-# CPPFLAGS += -DPOLL_EMULATION
--# OBJS += poll-emul.o
+-# EXTRA_OBJS += poll-emul.o
-
-# Uncomment the following if your system does not have the socklen_t type
-# CPPFLAGS += -DNEED_SOCKLEN_T
@@ -43,11 +49,11 @@
-# CPPFLAGS += -DFREEBSD_SENDFILE
-# If you define any of the SENDFILE conditionals, make sure to uncomment
-# the next line as well.
--# OBJS += sendfile.o
+-# EXTRA_OBJS += sendfile.o
-
-all: $(BIN)
-install: $(BIN)
-- install -c $(BIN) $(SBINDIR)
+- install -c $(BIN) $(DESTDIR)$(SBINDIR)
-$(BIN): $(OBJS)
- $(CC) $(LDFLAGS) -o $(BIN) $(OBJS) $(LIBS)
-$(OBJS): $(DEPENDS)