aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-10-12 17:06:17 +0800
committermat <mat@FreeBSD.org>2017-10-12 17:06:17 +0800
commit4609c9e867830f2a15258478f29f794b97676dcf (patch)
tree4e276eff5a36cfbec8aaa631c017c918d78c29da /www
parent31957cd5f3158b47a5ec2fe356d7c01eeb0cde00 (diff)
downloadfreebsd-ports-gnome-4609c9e867830f2a15258478f29f794b97676dcf.tar.gz
freebsd-ports-gnome-4609c9e867830f2a15258478f29f794b97676dcf.tar.zst
freebsd-ports-gnome-4609c9e867830f2a15258478f29f794b97676dcf.zip
Stripping go binaries is perfectly fine.
https://dominik.honnef.co/posts/2016/10/go-and-strip/ Sponsored by: Absolight
Diffstat (limited to 'www')
-rw-r--r--www/go-www/Makefile2
-rw-r--r--www/grafana3/Makefile2
-rw-r--r--www/minio-client/Makefile1
-rw-r--r--www/uchiwa/Makefile2
4 files changed, 0 insertions, 7 deletions
diff --git a/www/go-www/Makefile b/www/go-www/Makefile
index 7f7fcbf009f4..e9704de3a66f 100644
--- a/www/go-www/Makefile
+++ b/www/go-www/Makefile
@@ -19,8 +19,6 @@ GH_ACCOUNT= nbari:DEFAULT
GH_TUPLE= golang:crypto:847319b:crypto/src/golang.org/x/crypto
GH_SUBDIR= src/github.com/nbari/${PORTNAME}
-STRIP= # stripping can break go binaries
-
PLIST_FILES= bin/www
post-patch:
diff --git a/www/grafana3/Makefile b/www/grafana3/Makefile
index 8430ebe62c50..e8e027be08b4 100644
--- a/www/grafana3/Makefile
+++ b/www/grafana3/Makefile
@@ -97,8 +97,6 @@ SUB_LIST+= GRAFANA_USER=${GRAFANA_USER} \
PLIST_SUB+= GRAFANAHOMEDIR=${GRAFANAHOMEDIR}
-STRIP=
-
post-extract:
@${MKDIR} ${WRKSRC}/src/github.com/grafana/grafana
.for src in .bowerrc .bra.toml .editorconfig .github .gitignore .hooks \
diff --git a/www/minio-client/Makefile b/www/minio-client/Makefile
index cf12815dbb40..7e8459fda53e 100644
--- a/www/minio-client/Makefile
+++ b/www/minio-client/Makefile
@@ -32,7 +32,6 @@ GH_TAGNAME= RELEASE.2017-02-06T20-16-19Z
GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${GH_PROJECT}
MAKE_ENV= GOPATH=${WRKSRC} GOROOT=${LOCALBASE}/go
-STRIP= # stripping can break go binaries
PLIST_FILES= bin/${MC}
do-build:
diff --git a/www/uchiwa/Makefile b/www/uchiwa/Makefile
index 16b33c750070..6d2a7588edc7 100644
--- a/www/uchiwa/Makefile
+++ b/www/uchiwa/Makefile
@@ -46,8 +46,6 @@ GH_TUPLE+= kless:osutil:3ac994847c4376a4b905fc0a19f450c5a4bec647:klessosutil/src
USERS= uchiwa
GROUPS= uchiwa
-STRIP= #
-
post-extract:
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
.for src in .travis.yml Gruntfile.js bower.json package.json uchiwa \