aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-11 13:08:40 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-11 13:08:40 +0800
commit4e87c9eae0f0627bcf95025bf1ec7770411ab21e (patch)
tree05ab308960a14ccc53ccd552f3b04fe6f2ee5de7 /www
parent83ed714e9db5469988f8e16fefe592321baa647c (diff)
downloadfreebsd-ports-gnome-4e87c9eae0f0627bcf95025bf1ec7770411ab21e.tar.gz
freebsd-ports-gnome-4e87c9eae0f0627bcf95025bf1ec7770411ab21e.tar.zst
freebsd-ports-gnome-4e87c9eae0f0627bcf95025bf1ec7770411ab21e.zip
mod_whatkilledus is an experimental module for Apache httpd 2.x which
tracks the current request and logs a report of the active request when a child process crashes. Requirements: Apache httpd >= 2.0.49 must be built with the --enable-exception-hook configure option and mod_so enabled. Activating mod_whatkilledus: 1. Load it like any other DSO. LoadModule whatkilledus_module modules/mod_whatkilledus.so 2. Enable exception hooks for modules like mod_whatkilledus: EnableExceptionHook On 3. Choose where the report on current activity should be written. If you want it reported to some place other than the error log, use the WhatKilledUsLog directive to specify a fully-qualified filename for the log. Note that the web server user id (e.g., "nobody") must be able to create or append to this log file, as the log file is not opened until a crash occurs. WWW: http://people.apache.org/~trawick/exception_hook.html PR: ports/151932 Submitted by: Frank Wall <fw at moov.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_whatkilledus/Makefile39
-rw-r--r--www/mod_whatkilledus/distinfo4
-rw-r--r--www/mod_whatkilledus/pkg-descr23
4 files changed, 67 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1b8edac649be..7360b046c20b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -563,6 +563,7 @@
SUBDIR += mod_vhost_ldap
SUBDIR += mod_vhs
SUBDIR += mod_webkit
+ SUBDIR += mod_whatkilledus
SUBDIR += mod_wsgi
SUBDIR += mod_wsgi3
SUBDIR += mod_xmlns
diff --git a/www/mod_whatkilledus/Makefile b/www/mod_whatkilledus/Makefile
new file mode 100644
index 000000000000..75335631dc71
--- /dev/null
+++ b/www/mod_whatkilledus/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_whatkilledus
+# Date created: Thu Nov 4 10:08:27 CET 2010
+# Whom: Frank Wall <fw@moov.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_whatkilledus
+PORTVERSION= 2.0
+CATEGORIES= www
+MASTER_SITES= http://people.apache.org/~trawick/ \
+ http://dl.moov.de/freebsd/${PORTNAME}/
+DISTFILES= mod_whatkilledus.c test_char.h
+EXTRACT_ONLY= # empty
+
+MAINTAINER= fw@moov.de
+COMMENT= Logs a report when a child process crashes
+
+MAKE_JOBS_SAFE= yes
+
+USE_APACHE= 20+
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+SHORTMODNAME= whatkilledus
+
+WRKSRC= ${WRKDIR}
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/mod_whatkilledus.c ${WRKSRC}
+ ${CP} ${DISTDIR}/test_char.h ${WRKSRC}
+
+pre-build:
+ @${ECHO_MSG} "*********************** PLEASE NOTE! ***********************"
+ @${ECHO_MSG} "Apache httpd must be built with the --enable-exception-hook"
+ @${ECHO_MSG} "configure option and mod_so enabled."
+ @${ECHO_MSG} "*********************** PLEASE NOTE! ***********************"
+
+.include <bsd.port.mk>
diff --git a/www/mod_whatkilledus/distinfo b/www/mod_whatkilledus/distinfo
new file mode 100644
index 000000000000..1286abe0bf95
--- /dev/null
+++ b/www/mod_whatkilledus/distinfo
@@ -0,0 +1,4 @@
+SHA256 (mod_whatkilledus.c) = 28c5c7b2b756513d31a87d707e5878d46795d125e5eb38d913a5d1713d203c90
+SIZE (mod_whatkilledus.c) = 12274
+SHA256 (test_char.h) = 424d330cc397e98cff333f33a3b00ef4abf84e405e26aedd898d293f3d12b590
+SIZE (test_char.h) = 1094
diff --git a/www/mod_whatkilledus/pkg-descr b/www/mod_whatkilledus/pkg-descr
new file mode 100644
index 000000000000..bac7a77d92cf
--- /dev/null
+++ b/www/mod_whatkilledus/pkg-descr
@@ -0,0 +1,23 @@
+mod_whatkilledus is an experimental module for Apache httpd 2.x which
+tracks the current request and logs a report of the active request
+when a child process crashes.
+
+Requirements: Apache httpd >= 2.0.49 must be built with the
+--enable-exception-hook configure option and mod_so enabled.
+
+Activating mod_whatkilledus:
+
+ 1. Load it like any other DSO.
+ LoadModule whatkilledus_module modules/mod_whatkilledus.so
+
+ 2. Enable exception hooks for modules like mod_whatkilledus:
+ EnableExceptionHook On
+
+ 3. Choose where the report on current activity should be written. If
+ you want it reported to some place other than the error log, use the
+ WhatKilledUsLog directive to specify a fully-qualified filename for
+ the log. Note that the web server user id (e.g., "nobody") must
+ be able to create or append to this log file, as the log file is
+ not opened until a crash occurs.
+
+WWW: http://people.apache.org/~trawick/exception_hook.html